Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No prompt to update? LOST THOUSANDS OF TABS because you broke SESSION MANAGER!

  • 2 replies
  • 11 have this problem
  • 1 view
  • Last reply by Stormcraft

more options

I'm LIVID. Firefox used to always ask before updating, and it would tell you when the update breaks add-ons... Not anymore apparently.

I have 8 profiles with numerous sessions, each containing dozens to hundreds of tabs. I do a lot of research and move around a lot online. My memory is not so perfect that I can recall even a fraction of what I just lost. but that doesn't mean it wasn't important. that was years of research that I bounce around on with all my sessions and continually make new ones. HOLY HELL I'm so upset that you've "upgraded" my browser to no longer have a session manager. If I cannot get those sessions back, I will literally never use firefox again.

All Replies (2)

more options

unfortunately 56.0.2 is no longer safe to use for every day use do to security issues, but 52.5.0 ESR is. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018.

You should make a backup of your Profile before going back and just because: https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Please let us know if this solved your issue or if need further assistance.

more options

Thanks for the reply. I've installed that version, but I'm seeing the same new browser with my main extensions disabled and unable to use still. There was even a built-in session manager on the last FF which was handy too, and that is also not there. It looks like the new FF. Should I have uninstalled FF first? The 52.5.0 ESR showed as an upgrade, so I just installed it.