Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

STOP IGNORING/OVERRIDING MY PREFERENCES AND SETTINGS AND AUTO-UPDATING TO FF57!!!

  • 8 replies
  • 2 have this problem
  • 191 views
  • Last reply by Guillermo

more options

I UNINSTALLED THE ABORTION THAT IS FF57. USING REVO, AND MADE SURE I DELETED ALL THE LEFTOVERS. I THEN REINSTALLED 56.0.2 AND HEY-PRESTO, GOT ALL MY ADD-ONS BACK! AFTER SETTING MY OPTIONS TO "NEVER CHECK FOR UPDATES", THOUGHT I WAS HAPPY. BUT OH NO, MOZILLA KNOW WHAT I WANT BETTER THAN I DO! I'M GOING TO GET THE GARBAGE THAT IS FF57 RAMMED DOWN MY THROAT WHETHER I LIKE IT OR NOT (AND I CERTAINLY DO NOT!!!). NEXT RESTART FF57 ASSAULTS MY MACHINE WITHOUT EVEN ASKING. STOP THIS SHITE FROM SELF INSTALLING REGARDLESS OF USER SETTINGS NOT TO!!!

Chosen solution

Hi Fred, Happy & richeardnpaul,

Just to let you know that I have done shut downs and restarts of Firefox with PC on, and restarts of the PC itself and my preferences seem to have held and been observed so far (screenshot below). Maybe someone at Mozilla IS listening?

Just to be on the safe side, I have cut both maintenanceservice and maintenanceservice_installer applications out of the Program Files folder and saved them to my Toolkit flash drive. Will look out for adverse reactions on next startup.

I have also bookmarked this page for any future needs or info. Sorry for taking so long to get back to you all (busy Monday), and thanks for all your help and useful suggestions. Rgds

Read this answer in context 👍 0

All Replies (8)

more options

Please turn off your Caps Lock. In text talk, this is shouting.


First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v57+] Type about:preferences#general<enter> in the address bar. Select Update.

Check the settings.

Also turn off Use a background service to install updates

more options

Sorry bout the caps Fred - don't do forums much, eyesight not what it was and I was just trying to be clear. I've already gone back to v56.0.2 again and the image I get with about:preferences#advanced<enter> (attached) shows the Options I have; only Advanced button is for Language and Appearance. about:preferences#general<enter> gives the same image/options I just want v56 not to accept forced update to v57 - any thoughts on how to turn off "Use a background service to install updates" in v56 would be greatly appreciated. Will mind my P's & Q's (in lowercase) in future.

more options

PS When reinstalling v56, I unchecked Mozilla Maintenance Service. Shouldn't that have disabled background updating?

more options

Guillermo said

PS When reinstalling v56, I unchecked Mozilla Maintenance Service. Shouldn't that have disabled background updating?

Hi  !

You will have to remove Mozilla Maintenance Service from your system (Control Panel => Programs and Features).

Would you please take a look at this article, and scroll down to the section:

Uninstalling the Mozilla Maintenance Service

more options

Hi Happy, Looks like Mozilla Maintenance Service wasn't installed (as it shouldn't have been because of the uncheck in v56 2nd reinstall). It doesn't appear in my list @ (Control Panel => Programs and Features) or in Revo. Tried using "maintenance" in search bar in case it was masquerading under a similar but not quite name - no hits after "ma" (screenshot attached). Looked at the article again and read it twice in case I had missed something - couldn't see anything else. Have kept this machine hibernated as v57 install happens after FF exit and restart. I need FF working "AS IS" today. Will try a shutdown and restart tonight and will feedback here - Thank you and thanks to Fred for your kind help. Rgds.

Modified by Guillermo

more options

Repeat the search in the Programs folder.

more options

I had this problem too, which was unfortunate because every time that Firefox updated it also updated Lastpass which broke that plugin because WE aren't ready yet. This meant I had to do two downgrades every time that I restarted Firefox and it didn't respect my settings.

My way around this was to turn off all the update mechnisms, remove and not reinstall the maintenance service in Windows, and to delete the updater executable in the Mozilla Firefox folder. This is updater.exe on Windows. I was still getting a notification about installing a fresh copy of Firefox but after searching for update in about:config and disabling every option that looked like it could be to do with system updates I resolved that issue too.

Modified by richardnpaul

more options

Chosen Solution

Hi Fred, Happy & richeardnpaul,

Just to let you know that I have done shut downs and restarts of Firefox with PC on, and restarts of the PC itself and my preferences seem to have held and been observed so far (screenshot below). Maybe someone at Mozilla IS listening?

Just to be on the safe side, I have cut both maintenanceservice and maintenanceservice_installer applications out of the Program Files folder and saved them to my Toolkit flash drive. Will look out for adverse reactions on next startup.

I have also bookmarked this page for any future needs or info. Sorry for taking so long to get back to you all (busy Monday), and thanks for all your help and useful suggestions. Rgds

Modified by Guillermo