Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox will not open without User Account Control asking if I will allow it to make changes on my computer every time - Windows 2010

  • 3 replies
  • 3 have this problem
  • 2331 views
  • Last reply by cor-el

more options

I keep getting prompting EVERY time without fail by User Account Control - "Do you want to allow this app to make changes to your device?" (Firefox Software Updater). I click yes but if I close and click to reopen Firefox it will prompt me again! This can and has gone indefinitely. I have the latest updates. My computer has all the latest updates. Everything has the latest updates. So why do I still get this annoying message?

Chosen solution

I read through all the archived comments on previous posts and NONE of them worked for me. So if that describes your experience then here is a simple solution:

"C:\User\YOURUSERNAME\AppData\Local\Mozilla\updates\EFCF176E110C211B\0" Change the very last character from "0" to 1. That's it! Your problem is gone.

This problem is now solved

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

I read through all the archived comments on previous posts and NONE of them worked for me. So if that describes your experience then here is a simple solution:

"C:\User\YOURUSERNAME\AppData\Local\Mozilla\updates\EFCF176E110C211B\0" Change the very last character from "0" to 1. That's it! Your problem is gone.

This problem is now solved

more options

I tried this and had to change EFC...211B to the string in my case so it read: C:\Users\Owner\AppData\Local\Mozilla\updates\308046B0AF4A39CB

This was an empty file so using \0 (to start from the same pace as the advice) or \1, all I got was an error :" Windows can't find 'the string above' Check the spelling and try again".

How do I insert \0 or \1 on the end of a file name? Answer: I can't; \ / are forbidden characters. Back to square 1.

more options

Check that Firefox isn't set to run as Administrator.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab.

Make sure all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder.