X
Tap here to go to the mobile version of the site.

Support Forum

on 14-11-2017 I have updated Firefox and it is now superslow in everything ;-(

Posted

Today we’re thrilled to introduce you to our brand new browser — Firefox Quantum.

What you’ll notice first is that the new Firefox is blazing fast.

This message was 14-11 in my mailbox and I have made a update, I restarted my computer with windows 10 64bit and now the new browser is incredebly slow in everything I do in Firefox Quantum, typing or a new search, name it and it is superslow.

Example, to write this question took me more than 15 minuits

Today we’re thrilled to introduce you to our brand new browser — Firefox Quantum. What you’ll notice first is that the new Firefox is blazing fast. This message was 14-11 in my mailbox and I have made a update, I restarted my computer with windows 10 64bit and now the new browser is incredebly slow in everything I do in Firefox Quantum, typing or a new search, name it and it is superslow. Example, to write this question took me more than 15 minuits

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Shadow110 1072 solutions 14836 answers

See if Multi-Processor Support is turned on. Multi-processor support feature may be disabled depending on your setup (it was for me) - you can check this by launching Firefox, then enter in "about:support" in the address bar; near the bottom, you should see a heading that says: "Multiprocess Windows", then look at the value next to it. If it says "0/1", then that means it's disabled. If 0/2 or higher it is on.

Open Windows Task Manager and find out how many process are running and how much ram is being used. (mine runs at 800 - 1500MB with 10 tabs open)

Go to Tools --> Options --> Performance Untick Use Recommended, Untick use Hardware Acceleration and Change Content Process to a lower number than recommended then Restart Firefox.

If the above does not work try below as you updated and so all the other stuff came along for the ride. The below Full Version Installer maybe the answer as well as clean install.

Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

See if Multi-Processor Support is turned on. Multi-processor support feature may be disabled depending on your setup (it was for me) - you can check this by launching Firefox, then enter in "about:support" in the address bar; near the bottom, you should see a heading that says: "Multiprocess Windows", then look at the value next to it. If it says "0/1", then that means it's disabled. If 0/2 or higher it is on. Open Windows Task Manager and find out how many process are running and how much ram is being used. (mine runs at 800 - 1500MB with 10 tabs open) Go to Tools --> Options --> Performance Untick Use Recommended, Untick use Hardware Acceleration and Change Content Process to a lower number than recommended then Restart Firefox. If the above does not work try below as you updated and so all the other stuff came along for the ride. The below Full Version Installer maybe the answer as well as clean install. Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

Question owner

I have reinstalled Firefox as discribed above but without solving the problem, the browser is still very slow. With Edge from Microsoft it goes normal. The Firefox version before Quatum worked good

I have reinstalled Firefox as discribed above but without solving the problem, the browser is still very slow. With Edge from Microsoft it goes normal. The Firefox version before Quatum worked good
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23463 answers

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]
Kosakk01 0 solutions 2 answers

I have the same issue. Dial up slow! Horrible! I tried to refresh Firefox and also (can't remember the term) where you go back to previous. Well I lost all my personal bookmarks and everything that makes Firefox unique to me. Freaking out now that once my other computers update I will lose them there also. Not happy at all. If anyone has any tips on how to get my things back I would love the help.

I have the same issue. Dial up slow! Horrible! I tried to refresh Firefox and also (can't remember the term) where you go back to previous. Well I lost all my personal bookmarks and everything that makes Firefox unique to me. Freaking out now that once my other computers update I will lose them there also. Not happy at all. If anyone has any tips on how to get my things back I would love the help.