X
Tap here to go to the mobile version of the site.

Support Forum

Tabs on bottom

Posted

Hi,

Firefox 57 is running very well. However, I miss my "Tabs o bottom" or "Firefox Themes Restorer". How can I get he tabs UNDER the address line and Bookmark line / on top of the website, please?

Thank you

Kalle

Hi, Firefox 57 is running very well. However, I miss my "Tabs o bottom" or "Firefox Themes Restorer". How can I get he tabs UNDER the address line and Bookmark line / on top of the website, please? Thank you Kalle

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

jscher2000
  • Top 10 Contributor
7685 solutions 62576 answers

Chosen Solution

Could you take a look at this thread: [https://support.mozilla.org/questions/1184503 How do I get the tabs back below the bookmarks toolbar (where they SHOULD be) in Firefox Quantum?]

Question owner

PERFECT! I can say even I as a "no-computer-freak" could follow the steps and have now "my" tabs on bottom... where they belongs to. Thank you SO MUCH jscher2000 Kalle

PERFECT! I can say even I as a "no-computer-freak" could follow the steps and have now "my" tabs on bottom... where they belongs to. Thank you SO MUCH jscher2000 Kalle
rish907 0 solutions 2 answers

KalleKulle said

Hi, Firefox 57 is running very well. However, I miss my "Tabs o bottom" or "Firefox Themes Restorer". How can I get he tabs UNDER the address line and Bookmark line / on top of the website, please? Thank you Kalle

Same issue. I had the Tabs on Bottom (Australis) which no longer works. Tabs on top is such a nuance. Hope they fix this asap

''KalleKulle [[#question-1184737|said]]'' <blockquote> Hi, Firefox 57 is running very well. However, I miss my "Tabs o bottom" or "Firefox Themes Restorer". How can I get he tabs UNDER the address line and Bookmark line / on top of the website, please? Thank you Kalle </blockquote> Same issue. I had the Tabs on Bottom (Australis) which no longer works. Tabs on top is such a nuance. Hope they fix this asap
jscher2000
  • Top 10 Contributor
7685 solutions 62576 answers

Helpful Reply

Hi rish907, "they" -- the user interface changers -- are unlikely to anything ASAP. But you can do it yourself if you have 5 minutes.

(A) You need to create a new chrome folder in your profile folder. This article has the steps for that (#1, #2, and optionally #3)

https://www.userchrome.org/how-create-userchrome-css.html

(B) Download the following file and move it into that chrome folder:

https://www.userchrome.org/samples/userChrome-tabs_on_bottom.css

(C) Rename the file to just userChrome.css

The next time you quit Firefox and start it up again, it should discover that file and apply the rules.

Now... if you are on Mac, you may need to use Customize to add a flexible space to the left end of the main toolbar to avoid overlapping the 3 buttons that appear upper left on any window.

If you are on Windows and don't display the menu bar or title bar, you may need to add a spacer on the right.

Hi rish907, "they" -- the user interface changers -- are unlikely to anything ASAP. But you can do it yourself if you have 5 minutes. (A) You need to create a new '''chrome''' folder in your profile folder. This article has the steps for that (#1, #2, and optionally #3) https://www.userchrome.org/how-create-userchrome-css.html (B) Download the following file and move it into that chrome folder: https://www.userchrome.org/samples/userChrome-tabs_on_bottom.css (C) Rename the file to just '''userChrome.css''' The next time you quit Firefox and start it up again, it should discover that file and apply the rules. Now... if you are on Mac, you may need to use Customize to add a flexible space to the left end of the main toolbar to avoid overlapping the 3 buttons that appear upper left on any window. If you are on Windows and don't display the menu bar or title bar, you may need to add a spacer on the right.
Roary 0 solutions 3 answers

Hi. I've got this problem too. I for the life of me can't get the css file to work. Here's what I've got. I downloaded the file from here . Any help would be great as the update is total crap IMO

Hi. I've got this problem too. I for the life of me can't get the css file to work. Here's what I've got. I downloaded the file from [https://www.userchrome.org/samples/userChrome-tabs_on_bottom.css here] . Any help would be great as the update is total crap IMO
jscher2000
  • Top 10 Contributor
7685 solutions 62576 answers

Hi Roary, one more step: go ahead and shorten the name down to userChrome.css (which is the only name Firefox looks for).

The reason the download has that longer name is in case you already have userChrome.css, I don't want to blow away your existing style rules.

Hi Roary, one more step: go ahead and shorten the name down to userChrome.css (which is the only name Firefox looks for). The reason the download has that longer name is in case you already have userChrome.css, I don't want to blow away your existing style rules.
JHHJ 1 solutions 8 answers

I too am so frustrated with this and can't get this to work either. WHERE do I put the chrome folder? And does this even work for Mac computers?

Thank you !

I too am so frustrated with this and can't get this to work either. WHERE do I put the chrome folder? And does this even work for Mac computers? Thank you !
jscher2000
  • Top 10 Contributor
7685 solutions 62576 answers

JHHJ said

I too am so frustrated with this and can't get this to work either. WHERE do I put the chrome folder? And does this even work for Mac computers?

Yes, it works on Macs. There is an issue with the three window buttons overlapping the main toolbar after you move it to the top, both on Mac and Windows. If you want to try it anyway, please start with this reply:

https://support.mozilla.org/questions/1184737#answer-1033146

''JHHJ [[#answer-1034268|said]]'' <blockquote> I too am so frustrated with this and can't get this to work either. WHERE do I put the chrome folder? And does this even work for Mac computers? </blockquote> Yes, it works on Macs. There is an issue with the three window buttons overlapping the main toolbar after you move it to the top, both on Mac and Windows. If you want to try it anyway, please start with this reply: https://support.mozilla.org/questions/1184737#answer-1033146
JHHJ 1 solutions 8 answers

Thank you jscher2000. I was really thrown by the profile thing, but the video explained it well, and I did finally get it work yesterday.

I really appreciate your time to respond and give full details for this solution. I wouldn't have had a clue on that solution at all! Like others, I hoped for a simple option to customize the tabs feature. Maybe next update things will be simpler. :-)

cheers

Thank you jscher2000. I was really thrown by the profile thing, but the video explained it well, and I did finally get it work yesterday. I really appreciate your time to respond and give full details for this solution. I wouldn't have had a clue on that solution at all! Like others, I hoped for a simple option to customize the tabs feature. Maybe next update things will be simpler. :-) cheers
Armory 0 solutions 2 answers

Now... if you are on Mac, you may need to use Customize to add a flexible space to the left end of the main toolbar to avoid overlapping the 3 buttons that appear upper left on any window.


On MacOS, if you'd prefer not to use the flexible space customization, you can thicken the top border of the main Firefox window. I prefer this method as it also adds a 'handle' to the top of the Firefox window to grab with the mouse (at the expense of wasting a bit of the window's usable space). This can be done by adding a value to the #nav-bar's 'border-top-width:' Using npx (n=1, 2, 3, etc.) to get your desired width. (Using other available thickness values, i.e. nem, or thin, medium, thick, probably won't give you the exact width you need.) I'm using 24px.

Now... if you are on Mac, you may need to use Customize to add a flexible space to the left end of the main toolbar to avoid overlapping the 3 buttons that appear upper left on any window. On MacOS, if you'd prefer not to use the flexible space customization, you can thicken the top border of the main Firefox window. I prefer this method as it also adds a 'handle' to the top of the Firefox window to grab with the mouse (at the expense of wasting a bit of the window's usable space). This can be done by adding a value to the #nav-bar's 'border-top-width:' Using npx (n=1, 2, 3, etc.) to get your desired width. (Using other available thickness values, i.e. nem, or thin, medium, thick, probably won't give you the exact width you need.) I'm using 24px.
JHHJ 1 solutions 8 answers

"This can be done by adding a value to the #nav-bar's 'border-top-width:' Using npx (n=1, 2, 3, etc.) to get your desired width. (Using other available thickness values, i.e. nem, or thin, medium, thick, probably won't give you the exact width you need.) I'm using 24px."


Where would I find that to do this change?

"This can be done by adding a value to the #nav-bar's 'border-top-width:' Using npx (n=1, 2, 3, etc.) to get your desired width. (Using other available thickness values, i.e. nem, or thin, medium, thick, probably won't give you the exact width you need.) I'm using 24px." Where would I find that to do this change?
Armory 0 solutions 2 answers

Sorry for not tying that in better... Please use jscher2000's solution above and then edit that same userChrome.css file that you would install. For Example:

#nav-bar { /* main toolbar */
   -moz-box-ordinal-group: 1 !important;
   border-top-width: 24px !important;
Sorry for not tying that in better... Please use jscher2000's solution above and then edit that same userChrome.css file that you would install. For Example: <pre>#nav-bar { /* main toolbar */ -moz-box-ordinal-group: 1 !important; border-top-width: 24px !important;</pre>

Modified by Armory

JHHJ 1 solutions 8 answers

Hmm... I tried this but it didn't make a difference in the widths. It did add an extra empty bar above the URL line. There must be something off. Any idea? It's not overly important, but if it's an easy fix, I'm in! Thanks.

Armory said

Sorry for not tying that in better... Please use jscher2000's solution above and then edit that same userChrome.css file that you would install. For Example: "#nav-bar { /* main toolbar */" " -moz-box-ordinal-group: 1 !important;" " border-top-width: 24px !important;"
Hmm... I tried this but it didn't make a difference in the widths. It did add an extra empty bar above the URL line. There must be something off. Any idea? It's not overly important, but if it's an easy fix, I'm in! Thanks. ''Armory [[#answer-1034967|said]]'' <blockquote> Sorry for not tying that in better... Please use jscher2000's solution above and then edit that same userChrome.css file that you would install. For Example: "#nav-bar { /* main toolbar */" " -moz-box-ordinal-group: 1 !important;" " border-top-width: 24px !important;" </blockquote>
jscher2000
  • Top 10 Contributor
7685 solutions 62576 answers

Helpful Reply

JHHJ said

Hmm... I tried this but it didn't make a difference in the widths. It did add an extra empty bar above the URL line. There must be something off.

That was one way to make room for the 3 buttons above the main toolbar, so the blank space was the goal. (CSS uses the word width for border thickness both on the top, bottom, left and right.)

''JHHJ [[#answer-1035009|said]]'' <blockquote> Hmm... I tried this but it didn't make a difference in the widths. It did add an extra empty bar above the URL line. There must be something off. </blockquote> That was one way to make room for the 3 buttons above the main toolbar, so the blank space was the goal. (CSS uses the word width for border thickness both on the top, bottom, left and right.)
JHHJ 1 solutions 8 answers

Oh I see. No problem. I thought width was referring to the height of the existing bars, and it would make them a bit taller. They are a bit tight, but there is the option to change density, such as it is. Thanks for quick responses!

jscher2000 said

That was one way to make room for the 3 buttons above the main toolbar, so the blank space was the goal. (CSS uses the word width for border thickness both on the top, bottom, left and right.)
Oh I see. No problem. I thought width was referring to the height of the existing bars, and it would make them a bit taller. They are a bit tight, but there is the option to change density, such as it is. Thanks for quick responses! ''jscher2000 [[#answer-1035011|said]]'' <blockquote>'' That was one way to make room for the 3 buttons above the main toolbar, so the blank space was the goal. (CSS uses the word width for border thickness both on the top, bottom, left and right.) </blockquote>

Modified by JHHJ

Roary 0 solutions 3 answers

jscher2000 said

Hi Roary, one more step: go ahead and shorten the name down to userChrome.css (which is the only name Firefox looks for). The reason the download has that longer name is in case you already have userChrome.css, I don't want to blow away your existing style rules.

Thanks. It's working now :)

''jscher2000 [[#answer-1034255|said]]'' <blockquote> Hi Roary, one more step: go ahead and shorten the name down to userChrome.css (which is the only name Firefox looks for). The reason the download has that longer name is in case you already have userChrome.css, I don't want to blow away your existing style rules. </blockquote> Thanks. It's working now :)
gakjones 0 solutions 1 answers

Did Google buy out Mozilla? I am definitely getting the chrome vibe..

I tried the solution but it is not a solution. I just moves the tabs under the file menu. I really need the tabs under everything where where they are supposed to be. Anyone figure out how to truly fix this growing issue?

Did Google buy out Mozilla? I am definitely getting the chrome vibe.. I tried the solution but it is not a solution. I just moves the tabs under the file menu. I really need the tabs under everything where where they are supposed to be. Anyone figure out how to truly fix this growing issue?
jscher2000
  • Top 10 Contributor
7685 solutions 62576 answers

Hi gakjones, Google did not buy out Mozilla.

I'm not sure what you mean by "moves the tabs under the file menu." That's where they normally are, on the top row, below the menu bar and title bar. The custom style rule should move the tabs below the main toolbar and bookmarks toolbar.

Could you double-check the folder and file name?

(1) You can open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder"/"Show in Finder"/"Open Directory" button. This should launch a new window listing various files and folders in your system's file viewer (e.g., Windows Explorer, Finder).

(2) Find the chrome folder, making sure its name is entirely lower case, and double-click into it

(3) Confirm that the userChrome.css file -- only the C is capitalized -- is a CSS file or Style Sheet file and not a text file. An example from Windows 7 is attached.

Hi gakjones, Google did not buy out Mozilla. I'm not sure what you mean by "moves the tabs under the file menu." That's where they normally are, on the top row, below the menu bar and title bar. The custom style rule should move the tabs below the main toolbar and bookmarks toolbar. Could you double-check the folder and file name? (1) You can open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder"/"Show in Finder"/"Open Directory" button. This should launch a new window listing various files and folders in your system's file viewer (e.g., Windows Explorer, Finder). (2) Find the '''chrome''' folder, making sure its name is entirely lower case, and double-click into it (3) Confirm that the '''userChrome.css''' file -- only the C is capitalized -- is a CSS file or Style Sheet file and not a text file. An example from Windows 7 is attached.
FireFok_user 0 solutions 2 answers

I worked on this for a couple hours trying to get the CSS file to work.

I found the profile folders but there were 3 listed and none had the chrome folder so I added it to one that I thought was correct.

Restarted FF but it would not take.

Tried restarting the PC and FF several times to no avail.

Took a chance and copied the folder with the CSS file to one of the other folders.

To my amazement it worked perfectly.

I worked on this for a couple hours trying to get the CSS file to work. I found the profile folders but there were 3 listed and none had the chrome folder so I added it to one that I thought was correct. Restarted FF but it would not take. Tried restarting the PC and FF several times to no avail. Took a chance and copied the folder with the CSS file to one of the other folders. To my amazement it worked perfectly.
nanciewanda 0 solutions 19 answers

FireFok_user said

I worked on this for a couple hours trying to get the CSS file to work. I found the profile folders but there were 3 listed and none had the chrome folder so I added it to one that I thought was correct. Restarted FF but it would not take. Tried restarting the PC and FF several times to no avail. Took a chance and copied the folder with the CSS file to one of the other folders. To my amazement it worked perfectly.

I did this and it didn't work at all!

''FireFok_user [[#answer-1040034|said]]'' <blockquote> I worked on this for a couple hours trying to get the CSS file to work. I found the profile folders but there were 3 listed and none had the chrome folder so I added it to one that I thought was correct. Restarted FF but it would not take. Tried restarting the PC and FF several times to no avail. Took a chance and copied the folder with the CSS file to one of the other folders. To my amazement it worked perfectly. </blockquote> I did this and it didn't work at all!