X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Where did my bookmark folders go with new update?

Posted

I installed the new Firefox update this morning and when I click on the bookmarks icon at the top my bookmark folders have vanished. the only bookmarks I have are my recently bookmarked ones.

Where did they go?

I installed the new Firefox update this morning and when I click on the bookmarks icon at the top my bookmark folders have vanished. the only bookmarks I have are my recently bookmarked ones. Where did they go?

Chosen solution

Note that there is a "Show your bookmarks" button (star with a bar below it) in the Customize palette that you can drag to the Navigation Toolbar.

Read this answer in context 34

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

BelFox 6 solutions 49 answers

Hi lonegreywolf20,

Did you use the built-in updater to upgrade? Or did you make changes to your Firefox profile folder?

First you can check if an add-on is causing the problem, by opening Firefox in safe mode (see below).

Alternatively, you could check if backups were made and try to restore them: see https://support.mozilla.org/en-US/kb/restore-bookmarks-from-backup-or-move-them

Hope this helps! Best regards, BelFox

EDIT: possibly, the bookmarks are just hidden. Try using the 'Show my bookmarks' button (see next posts) or press Ctrl+B.


Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Hi lonegreywolf20, Did you use the built-in updater to upgrade? Or did you make changes to your Firefox profile folder? First you can check if an add-on is causing the problem, by opening Firefox in safe mode (see below). Alternatively, you could check if backups were made and try to restore them: see https://support.mozilla.org/en-US/kb/restore-bookmarks-from-backup-or-move-them Hope this helps! Best regards, BelFox EDIT: possibly, the bookmarks are just hidden. Try using the 'Show my bookmarks' button (see next posts) or press Ctrl+B. -------- '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Modified by BelFox

danfoto 0 solutions 4 answers

Helpful Reply

I have the same issue and it is still present in Safe Mode. Your upgrade seems to have lost all the folders of bookmarks that I had until this morning and I am mightily annoyed about it.

I have the same issue and it is still present in Safe Mode. Your upgrade seems to have lost all the folders of bookmarks that I had until this morning and I am mightily annoyed about it.
jeanditi 0 solutions 20 answers

Helpful Reply

Same problem over here

I sure hope this issue gets resolved, I NEED many of these links - it took a long time to put them together.

Same problem over here I sure hope this issue gets resolved, I NEED many of these links - it took a long time to put them together.
jeanditi 0 solutions 20 answers

danfoto said

I have the same issue and it is still present in Safe Mode. Your upgrade seems to have lost all the folders of bookmarks that I had until this morning and I am mightily annoyed about it.

Yes, while there are the last few recently bookmarked links and my toolbar bookmarks, there is NO SIGN of all of my Bookmark Folders.

''danfoto [[#answer-1029100|said]]'' <blockquote> I have the same issue and it is still present in Safe Mode. Your upgrade seems to have lost all the folders of bookmarks that I had until this morning and I am mightily annoyed about it. </blockquote> Yes, while there are the last few recently bookmarked links and my toolbar bookmarks, there is NO SIGN of all of my Bookmark Folders.
jeanditi 0 solutions 20 answers

Right - as of now, the only way I can see my FOLDERS is to click on the new icon (beside the download icon) click on bookmarks and THEN at the very bottom, Click on "Show all Bookmarks"

This opens a window and there I clicked on Bookmark Menu. Here I can see my folders and if I double click on the folders, I can see the links/bookmarks.

At least it is a start!!

Right - as of now, the only way I can see my FOLDERS is to click on the new icon (beside the download icon) click on bookmarks and THEN at the very bottom, Click on "Show all Bookmarks" This opens a window and there I clicked on Bookmark Menu. Here I can see my folders and if I double click on the folders, I can see the links/bookmarks. At least it is a start!!
jeanditi 0 solutions 20 answers

OR, click on the other icon that looks like a book and that opens up the panel on the left side of the screen - then click on Bookmarks Menu and the list of Folders shows up.

OR, click on the other icon that looks like a book and that opens up the panel on the left side of the screen - then click on Bookmarks Menu and the list of Folders shows up.
cor-el
  • Top 10 Contributor
  • Moderator
16238 solutions 146593 answers

Chosen Solution

Note that there is a "Show your bookmarks" button (star with a bar below it) in the Customize palette that you can drag to the Navigation Toolbar.

Note that there is a "Show your bookmarks" button (star with a bar below it) in the Customize palette that you can drag to the Navigation Toolbar.
jeanditi 0 solutions 20 answers

cor-el said

Note that there is a "Show your bookmarks" button (star with a bar below it) in the Customize palette that you can drag to the Navigation Toolbar.

I have gone back to see what is in the options within the Customize tab, and there is only the "Bookmarks Menu" icon, (star with a bar below it) which I already dragged into the box to add it to the Menu bar - when I click on Bookmarks on dropdown from the tab beside the downloads icon, it only shows me those recently bookmarked items again.

''cor-el [[#answer-1030232|said]]'' <blockquote> Note that there is a "Show your bookmarks" button (star with a bar below it) in the Customize palette that you can drag to the Navigation Toolbar. </blockquote> I have gone back to see what is in the options within the Customize tab, and there is only the "Bookmarks Menu" icon, (star with a bar below it) which I already dragged into the box to add it to the Menu bar - when I click on Bookmarks on dropdown from the tab beside the downloads icon, it only shows me those recently bookmarked items again.

Question owner

Cor-el's response is what worked for me.

Cor-el's response is what worked for me.
GeorgeNJ 0 solutions 8 answers

I have the same issue which is infuriating. It was so convenient and perfect the way it was, what is the point of burying it somewhere deep in the program? Please help!

BTW, none of the ideas above worked for me, either.

I have the same issue which is infuriating. It was so convenient and perfect the way it was, what is the point of burying it somewhere deep in the program? Please help! BTW, none of the ideas above worked for me, either.

Modified by GeorgeNJ

BelFox 6 solutions 49 answers

Alternatively, press Ctrl+B to open the bookmarks side panel.

Best regards, BelFox

Alternatively, press Ctrl+B to open the bookmarks side panel. Best regards, BelFox
jeanditi 0 solutions 20 answers

GeorgeNJ said

I have the same issue which is infuriating. It was so convenient and perfect the way it was, what is the point of burying it somewhere deep in the program? Please help! BTW, none of the ideas above worked for me, either.

There is another thread about this problem that I started - there are a few more suggestions there. https://support.mozilla.org/en-US/questions/1185656#answer-1030192

''GeorgeNJ [[#answer-1031393|said]]'' <blockquote> I have the same issue which is infuriating. It was so convenient and perfect the way it was, what is the point of burying it somewhere deep in the program? Please help! BTW, none of the ideas above worked for me, either. </blockquote> There is another thread about this problem that I started - there are a few more suggestions there. https://support.mozilla.org/en-US/questions/1185656#answer-1030192
jeanditi 0 solutions 20 answers

For me, the best solution is to get the bookmark icon on the toolbar, (you will see in the comments in the thread I just linked to, how to get the bookmarks icon on your toolbar) and by clicking that, the bookmark menu can be found as a column pops up on the left side of the screen. If you get that column, make sure you click on "Bookmarks Menu" and when you do, the folders should show up there.

For me, the best solution is to get the bookmark icon on the toolbar, (you will see in the comments in the thread I just linked to, how to get the bookmarks icon on your toolbar) and by clicking that, the bookmark menu can be found as a column pops up on the left side of the screen. If you get that column, make sure you click on "Bookmarks Menu" and when you do, the folders should show up there.
jeanditi 0 solutions 20 answers

Yeah, and ctl-B opens up the Bookmarks in the column on the left.

Yeah, and ctl-B opens up the Bookmarks in the column on the left.
cor-el
  • Top 10 Contributor
  • Moderator
16238 solutions 146593 answers

Note that you need to place the "Show your bookmarks" icon on the main Navigation Toolbar and not in the overflow area '>>' since it behaves differently when placed there.

Note that you need to place the "Show your bookmarks" icon on the main Navigation Toolbar and not in the overflow area '>>' since it behaves differently when placed there.
GeorgeNJ 0 solutions 8 answers

cor-el said

Note that you need to place the "Show your bookmarks" icon on the main Navigation Toolbar and not in the overflow area '>>' since it behaves differently when placed there.

Sorry for looking not-so-intelligent, but where is the "Show Your Bookmarks" icon? I have the link for it as "Show All Bookmarks", but no icon. And what does '>>' mean?

Mac Sierra 10.12.6

Update: I just saw your previous message and I think I got it. However, I still don't understand what you mean by the overflow area.

''cor-el [[#answer-1031648|said]]'' <blockquote> Note that you need to place the "Show your bookmarks" icon on the main Navigation Toolbar and not in the overflow area '>>' since it behaves differently when placed there. </blockquote> Sorry for looking not-so-intelligent, but where is the "Show Your Bookmarks" icon? I have the link for it as "Show All Bookmarks", but no icon. And what does '>>' mean? Mac Sierra 10.12.6 Update: I just saw your previous message and I think I got it. However, I still don't understand what you mean by the overflow area.

Modified by GeorgeNJ

GeorgeNJ 0 solutions 8 answers

cor-el said

Note that there is a "Show your bookmarks" button (star with a bar below it) in the Customize palette that you can drag to the Navigation Toolbar.

I tried this and I think it worked. Thx.

''cor-el [[#answer-1030232|said]]'' <blockquote> Note that there is a "Show your bookmarks" button (star with a bar below it) in the Customize palette that you can drag to the Navigation Toolbar. </blockquote> I tried this and I think it worked. Thx.
Ishabaka 0 solutions 1 answers

Yes. It's a bloody disaster. I've updated to Firefox 57, lost all the bookmark folders, reinstalled 56 - they were back, updated to Firefox 57 again - lost my folders. It is a REALLY SERIOUS BUG that Mozilla MUST FIX. Telling people to use "safe mode" is ridiculous. If I didn't have to use safe mode in 56, I shouldn't have to use safe mode in 57. Stop making excuses Mozilla, and fix this!!!!!!!!!!!!!!

Yes. It's a bloody disaster. I've updated to Firefox 57, lost all the bookmark folders, reinstalled 56 - they were back, updated to Firefox 57 again - lost my folders. It is a REALLY SERIOUS BUG that Mozilla MUST FIX. Telling people to use "safe mode" is ridiculous. If I didn't have to use safe mode in 56, I shouldn't have to use safe mode in 57. Stop making excuses Mozilla, and fix this!!!!!!!!!!!!!!

Modified by Ishabaka

BelFox 6 solutions 49 answers

Hi Ishabaka,

Chances are high your bookmarks aren't lost, but were placed under a new button 'Bookmarks Menu' (found in the Customization Panel > drag the button onto the toolbar first). Please have a look there or check if your folders are shown in the bookmarks side panel (Ctrl+B).

Opening Firefox in 'safe mode' is just a way to check whether add-ons are causing problems and is not meant as a permanent solution ;-)

Please let us know if you can find back your bookmarks in FF57.

Best regards, BelFox

Hi Ishabaka, Chances are high your bookmarks aren't lost, but were placed under a new button 'Bookmarks Menu' (found in the Customization Panel > drag the button onto the toolbar first). Please have a look there or check if your folders are shown in the bookmarks side panel (Ctrl+B). Opening Firefox in 'safe mode' is just a way to check whether add-ons are causing problems and is not meant as a permanent solution ;-) Please let us know if you can find back your bookmarks in FF57. Best regards, BelFox

Modified by BelFox

alliki63 0 solutions 1 answers

Hi guys, I too had problems with folders from my bookmarks disappearing. Seems I may have found a solution at least for me. Go to the customize page, instead of dragging the 'bookmarks menu' into the 'drag & drop' box I instead dragged it into the area that says 'bookmarks toolbar items'. This has placed it below the other icons on the tab. When I click on this all my bookmarks show up, folders and all. Hope my description makes sense and helps.

Hi guys, I too had problems with folders from my bookmarks disappearing. Seems I may have found a solution at least for me. Go to the customize page, instead of dragging the 'bookmarks menu' into the 'drag & drop' box I instead dragged it into the area that says 'bookmarks toolbar items'. This has placed it below the other icons on the tab. When I click on this all my bookmarks show up, folders and all. Hope my description makes sense and helps.