Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

URL bar won't remember or autocomplete previous URLs

  • 6 replies
  • 5 have this problem
  • 1398 views
  • Last reply by Orius

more options

I ran a program called Auslogics Boostspeed on my computer to cleanup privacy and performance issues. After running the program, I noticed that half of the links were missing from my bookmarks toolbar, and that my URL address bar no longer autocompleted URLs as I would type them. I was able to restore the bookmarks from the bookmarks backup, but the URL bar is still a mystery.

For example, I am used to just typing "F" and then it will auto-complete facebook.com. But now when I type "F", it insists on doing a Google search for "F", with no suggestion for Facebook. It doesn't remember any of the websites I go to, even if I just went to them 5 minutes ago.

This conflict does not resolve by starting in Safe Mode.

Things I have already tried: 1) Making sure that Options --> Privacy ---> URL bar has history, bookmarks and open tabs selected. 2) The various about:config tweaks. None of them have visibly changed from before the conflict, unless I've overlooked something. 3) Deleting the places.sqlite files from the profile folder and restarting the browser.

The only thing I can think of is that maybe Boostspeed changed a performance setting on my computer that is somehow causing a conflict, but I have no way of backtracking it.

This problem is very frustrating and is limiting my browsing experience. I rely on URL auto-complete for everything.

I ran a program called Auslogics Boostspeed on my computer to cleanup privacy and performance issues. After running the program, I noticed that half of the links were missing from my bookmarks toolbar, and that my URL address bar no longer autocompleted URLs as I would type them. I was able to restore the bookmarks from the bookmarks backup, but the URL bar is still a mystery. For example, I am used to just typing "F" and then it will auto-complete facebook.com. But now when I type "F", it insists on doing a Google search for "F", with no suggestion for Facebook. It doesn't remember any of the websites I go to, even if I just went to them 5 minutes ago. This conflict does not resolve by starting in Safe Mode. Things I have already tried: 1) Making sure that Options --> Privacy ---> URL bar has history, bookmarks and open tabs selected. 2) The various about:config tweaks. None of them have visibly changed from before the conflict, unless I've overlooked something. 3) Deleting the places.sqlite files from the profile folder and restarting the browser. The only thing I can think of is that maybe Boostspeed changed a performance setting on my computer that is somehow causing a conflict, but I have no way of backtracking it. This problem is very frustrating and is limiting my browsing experience. I rely on URL auto-complete for everything.

Chosen solution

Ugh, third party "boosters" that do not document what they do...

Orius said

For example, I am used to just typing "F" and then it will auto-complete facebook.com. But now when I type "F", it insists on doing a Google search for "F", with no suggestion for Facebook. It doesn't remember any of the websites I go to, even if I just went to them 5 minutes ago. ...
Things I have already tried: ...
2) The various about:config tweaks. None of them have visibly changed from before the conflict, unless I've overlooked something.

What tweaks? If the in-URL-bar autofill is not happening, check this one:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autoFill preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Any improvement?

Read this answer in context 👍 3

All Replies (6)

more options

To summarize this problem: URL bar history auto-complete is not working. Search and Tab suggestions work just fine.

I have not been able to locate a solution to this issue. I'm very close to uninstalling Firefox and switching to a different browser.

more options

Chosen Solution

Ugh, third party "boosters" that do not document what they do...

Orius said

For example, I am used to just typing "F" and then it will auto-complete facebook.com. But now when I type "F", it insists on doing a Google search for "F", with no suggestion for Facebook. It doesn't remember any of the websites I go to, even if I just went to them 5 minutes ago. ...
Things I have already tried: ...
2) The various about:config tweaks. None of them have visibly changed from before the conflict, unless I've overlooked something.

What tweaks? If the in-URL-bar autofill is not happening, check this one:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autoFill preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Any improvement?

more options

By the way, they have this on their support page:

Is it possible to roll back the changes made by BoostSpeed?

Yes, you can roll back all changes through Rescue Center which you can access through the program’s interface (go to Auslogics BoostSpeed -> at the lower left-hand corner find and click on Backups). Once Rescue Center is open, select a backup from the list and click the Restore button.

Sounds like a last resort since it isn't specific to Firefox.

more options

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

See also:

If the Places Maintenance extension can't repair the places.sqlite database then remove all places.sqlite file(s) in the Firefox profile folder to make Firefox rebuild the places.sqlite database from the most recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


Your System Details list shows that you have a user.js file in the profile folder to initialize prefs each time Firefox starts. The user.js file will only be present if you or other software has created this file and normally won't be present.

You can check its content with a text editor (right-click: "Open with"; do not double-click). The user.js file is read each time Firefox is started and initializes preferences to the value specified in this file, so preferences set via user.js can only be changed temporarily for the current session.

You can delete the user.js file if you didn't create this file yourself.

more options

jscher2000 said

Ugh, third party "boosters" that do not document what they do... Orius said
For example, I am used to just typing "F" and then it will auto-complete facebook.com. But now when I type "F", it insists on doing a Google search for "F", with no suggestion for Facebook. It doesn't remember any of the websites I go to, even if I just went to them 5 minutes ago. ...
Things I have already tried: ...
2) The various about:config tweaks. None of them have visibly changed from before the conflict, unless I've overlooked something.

What tweaks? If the in-URL-bar autofill is not happening, check this one:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autoFill preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Any improvement?

THANK YOU! This worked.

Although none of the browser.urlbar.autofill entries were bolded, I found others in the long menu of adjacent functions that were. I took a risk and reset them all to default, and the URL bar history works now.

The "URLB" suggestion you mentioned, I have never seen anywhere else in my extensive google searches of this problem. Just a lot of endless repetition of the places.sqlite fix. So thank you for mentioning something unheard of for me to try!

more options

jscher2000 said

By the way, they have this on their support page:
Is it possible to roll back the changes made by BoostSpeed?

Yes, you can roll back all changes through Rescue Center which you can access through the program’s interface (go to Auslogics BoostSpeed -> at the lower left-hand corner find and click on Backups). Once Rescue Center is open, select a backup from the list and click the Restore button.

Sounds like a last resort since it isn't specific to Firefox.

I should've looked into that more. Instead, I got angry and uninstalled Boostspeed. It was running in the background and I was paranoid it was doing further unwanted tweaks to my PC. I didn't delete the folder though, so maybe the user preferences and history would still be there if I reinstalled it.

Anyway, the urlbar issue is fixed, and boostspeed did make my computer a lot faster. All is well that ends well. Thank you!