X
Tap here to go to the mobile version of the site.

Support Forum

How can I control Location Bar Autocomplete?

Posted

In my previous version of FF (52 ESR) Location Bar Autocomplete was controlled by [options > privacy > address bar suggestions]. in current FFv62 only seems to enable it, but not control it's settings. Specifically Location Bar Autocomplete ONLY works for addresses already visited that session rather than for bookmarks as set.

My current settings are

[options > search > search bar] = use address bar

[options > search > *] = all other options disabled

[options > privacy > forms and passwords > *] = all disabled

[options > privacy > history > custom > remember browsing] = enabled

[options > privacy > history > custom > clear on close ( enabled) > settings] = all enabled but cookies and data section

[options > privacy > address bar] = only bookmarks checked

[about:config > browser.urlbar.auto] = all true


is this bugged or what do I need to change to get it back to autocompleting bookmark urls?

In my previous version of FF (52 ESR) Location Bar Autocomplete was controlled by [options > privacy > address bar suggestions]. in current FFv62 only seems to enable it, but not control it's settings. Specifically Location Bar Autocomplete ONLY works for addresses already visited that session rather than for bookmarks as set. My current settings are [options > search > search bar] = use address bar [options > search > *] = all other options disabled [options > privacy > forms and passwords > *] = all disabled [options > privacy > history > custom > remember browsing] = enabled [options > privacy > history > custom > clear on close ( enabled) > settings] = all enabled but cookies and data section [options > privacy > address bar] = only bookmarks checked [about:config > browser.urlbar.auto] = all true is this bugged or what do I need to change to get it back to autocompleting bookmark urls?

Modified by Nox Ferocia

Chosen solution

Quote

Additional System Details

Installed Plug-ins

ABP Stylish TinEye Youtube Enhancer

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

Pkshadow 1072 solutions 14836 answers

Hi, 1 is Options --> Browsing --> Search for text when you start typing

https://support.mozilla.org/en-US/kb/awesome-bar-search-firefox-bookmarks-history-tabs

Hi, 1 is Options --> Browsing --> Search for text when you start typing https://support.mozilla.org/en-US/kb/awesome-bar-search-firefox-bookmarks-history-tabs
Was this helpful to you? 0
Quote

Question owner

That setting only appears to control searching in a page, not autocomplete of urls.

The linked article says how to turn the url autocomplete on and off, but not how to control it's behavior (current behavior = only visited this session. previous behavior = bookmarks included)

I guess it's a bug then since the article doesn't cover it.

That setting only appears to control searching in a page, not autocomplete of urls. The linked article says how to turn the url autocomplete on and off, but not how to control it's behavior (current behavior = only visited this session. previous behavior = bookmarks included) I guess it's a bug then since the article doesn't cover it.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
219 solutions 1888 answers

In the link that Pkshadow gave you, you may have overlooked the section  :

"How can I control what results the address bar shows me?"

In the link that Pkshadow gave you, you may have overlooked the section : "How can I control what results the address bar shows me?"
Was this helpful to you? 0
Quote

Question owner

There may be a small misunderstanding caused by how the article labels the features... the articles calls both the inline predictive text and the suggestions list below it "autocomplete".

For me, the suggestions list behaves as the settings say, but the inline predictive text does not. it's the latter I wish to control

There may be a small misunderstanding caused by how the article labels the features... the articles calls both the inline predictive text and the suggestions list below it "autocomplete". For me, the suggestions list behaves as the settings say, but the inline predictive text does not. it's the latter I wish to control
Was this helpful to you?
Quote
philipp
  • Top 25 Contributor
  • Moderator
5152 solutions 22821 answers

Chosen Solution

hi, we're tracking and fixing this problem in https://bugzilla.mozilla.org/show_bug.cgi?id=1488879

hi, we're tracking and fixing this problem in https://bugzilla.mozilla.org/show_bug.cgi?id=1488879
Was this helpful to you? 1
Quote

Question owner

Looks like it's already reported and fixed in beta, so I just need to wait on release. Thanks all.

Looks like it's already reported and fixed in beta, so I just need to wait on release. Thanks all.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.