X
Tap here to go to the mobile version of the site.

Support Forum

I've checked all the right boxes in the COntrol center, but why won't Firefox allow me to stay logged into websites I regularly visit?

Posted

I have checked and double-checked that all settings are such that I should be able to sign in automatically to certain websites, but each time I re-open Firefox the auto-log-in feature doesn't work. It is not the websites because I have tested with other browsers and I don't have this problem. What's going on?

Thanks,

I have checked and double-checked that all settings are such that I should be able to sign in automatically to certain websites, but each time I re-open Firefox the auto-log-in feature doesn't work. It is not the websites because I have tested with other browsers and I don't have this problem. What's going on? Thanks,

Chosen solution

Problem is finally solved, and I think what did it was to uncheck 'cookies' under Privacy/ Clear History When Firefox Closes/ settings.

Thanks everyone for the assistance with this!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

FredMcD
  • Top 10 Contributor
4308 solutions 60487 answers

Is the login problem with all sites, some?

Warning: There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the Mozilla Add-ons Web Page {web Link} (There’s a lot of good stuff here) you can find several add-ons that can override this, and give you better control of your password information. You can also try a Form Filling add-on.

Is the login problem with all sites, some? '''Warning: ''' There are some web pages that do not allow browsers to record or fill in the log-in information. But if you go to the [https://addons.mozilla.org/en-US/firefox/ Mozilla Add-ons Web Page] {web Link} (There’s a lot of good stuff here) you can find several add-ons that can override this, and give you better control of your password information. You can also try a '''Form Filling''' add-on.

Question owner

I haven't tested all sites where I may automatic log-ins, but for ones I visit frequently it seems like whenever I close Firefox and then re-open it the sites require me to log in even though both the website and Firefox settings indicate the log-in should fill automatically.

I haven't tested all sites where I may automatic log-ins, but for ones I visit frequently it seems like whenever I close Firefox and then re-open it the sites require me to log in even though both the website and Firefox settings indicate the log-in should fill automatically.
Beerbaron23 15 solutions 162 answers

Helpful Reply

Check your cookies settings, if there set to delete after each session you will loose your logins...

Check your cookies settings, if there set to delete after each session you will loose your logins...

Question owner

Cookies are not set to delete at end of each session

Cookies are not set to delete at end of each session
FredMcD
  • Top 10 Contributor
4308 solutions 60487 answers

What is the cookie setting?

What is the cookie setting?

Question owner

The cookie setting is "allow from visited sites" and keep them until they expire.

The cookie setting is "allow from visited sites" and keep them until they expire.
FredMcD
  • Top 10 Contributor
4308 solutions 60487 answers

Are you using cookie add-ons?

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Log into the site. Don't do anything. Just login.

Exit Firefox.

Start Firefox in Safe mode again. Go to the website. Is the problem still there?

Are you using cookie add-ons? [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Log into the site. Don't do anything. Just login. Exit Firefox. Start Firefox in Safe mode again. Go to the website. Is the problem still there?

Question owner

I followed these instructions but I still can't stay logged in to the New York Times (which has been my test case).

I followed these instructions but I still can't stay logged in to the New York Times (which has been my test case).
cor-el
  • Top 10 Contributor
  • Moderator
17687 solutions 160003 answers

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Try to create a cookie allow exception for websites you want to remember you.

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies" Try to create a cookie allow exception for websites you want to remember you.

Question owner

I followed your instructions but Firefox won't let me stay logged in on any website.

I followed your instructions but Firefox won't let me stay logged in on any website.
FredMcD
  • Top 10 Contributor
4308 solutions 60487 answers
Use these links to create a new profile. Use this new profile '''as is. ''' Is the problem still there? http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Could you check at Firefox startup -- before you visit the New York Times site -- whether you have any cookies for nytimes.com at all? You can call up the Cookies dialog either from the Options page (Privacy panel, Use custom settings for history, "Show Cookies" button) or any page's Page Info dialog (right-click a blank area, View Page Info, Security tab, View Cookies). You can use the search/filter box above the list to search for nytimes to drill down to the relevant cookies.

Could you check at Firefox startup -- before you visit the New York Times site -- whether you have any cookies for nytimes.com at all? You can call up the Cookies dialog either from the Options page (Privacy panel, Use custom settings for history, "Show Cookies" button) or any page's Page Info dialog (right-click a blank area, View Page Info, Security tab, View Cookies). You can use the search/filter box above the list to search for nytimes to drill down to the relevant cookies.

Chosen Solution

Problem is finally solved, and I think what did it was to uncheck 'cookies' under Privacy/ Clear History When Firefox Closes/ settings.

Thanks everyone for the assistance with this!

Problem is finally solved, and I think what did it was to uncheck 'cookies' under Privacy/ Clear History When Firefox Closes/ settings. Thanks everyone for the assistance with this!
FredMcD
  • Top 10 Contributor
4308 solutions 60487 answers

That was very good work. Well done.

That was very good work. Well done.