X
Tap here to go to the mobile version of the site.

Support Forum

Adobe Flash message - Sorry, Flash Player is either not installed or not enabled.

Posted

I normally have Adobe Flash in "ask to activate" status. When I want to see if I have the latest ve3rsion, I go to Add-ons Manager and change the setting to "Always activate". Then I go to https://helpx.adobe.com/flash-player.html to check if I have the latest version. Then I go back and reset to ":Ask to activate".

Recently, when I go to that Adobe page and click "Check", I get an error message "Sorry, Flash Player is either not installed or not enabled.." How do I get Flash enabled? I had this happen with Flash 26.0.0.151, and I recently upgraded to 27.0.0.130, and after the update the same error message appears. I am running Firefox 55.0.3 32-bit on Windows 7 Professional.

In the past, when I had "Ask to activate", the Adobe help/check page did not ask me to activate; I had to re-set the activate flag to get the help/check page to work. Is there something that FF has saved somewhere that tells FF never to activate Flash on the Adobe help/check web page?

Thanks.

--Barry Finkel

I normally have Adobe Flash in "ask to activate" status. When I want to see if I have the latest ve3rsion, I go to Add-ons Manager and change the setting to "Always activate". Then I go to https://helpx.adobe.com/flash-player.html to check if I have the latest version. Then I go back and reset to ":Ask to activate". Recently, when I go to that Adobe page and click "Check", I get an error message "Sorry, Flash Player is either not installed or not enabled.." How do I get Flash enabled? I had this happen with Flash 26.0.0.151, and I recently upgraded to 27.0.0.130, and after the update the same error message appears. I am running Firefox 55.0.3 32-bit on Windows 7 Professional. In the past, when I had "Ask to activate", the Adobe help/check page did not ask me to activate; I had to re-set the activate flag to get the help/check page to work. Is there something that FF has saved somewhere that tells FF never to activate Flash on the Adobe help/check web page? Thanks. --Barry Finkel

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

FredMcD
  • Top 10 Contributor
3666 solutions 50303 answers

Let's do a reinstall of flash.

Flash: Grab the uninstaller from here:

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows

http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Then reinstall the latest version.

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version 27.0.0.130

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only>


See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Let's do a reinstall of flash. Flash: Grab the uninstaller from here: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac Then reinstall the latest version. '''Note: Windows users''' should download the '''active_x''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the '''plugin only.''' Not the '''active_x.''' Flash Player '''Version 27.0.0.130''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> ------------- See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

I uninstalled Flash. I rebooted. In FF I installed the latest Flash. Then I restarted FF. In the Flash help/check page I get the same message.

--Barry Finkel

I uninstalled Flash. I rebooted. In FF I installed the latest Flash. Then I restarted FF. In the Flash help/check page I get the same message. --Barry Finkel
FredMcD
  • Top 10 Contributor
3666 solutions 50303 answers

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key;<Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager. ''' Hot key;'''<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins. ''' Make sure the ones you want to use are set to '''Ask''' or '''Allow. ''' ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and '''Left-click''' the icon. Select '''Permissions. ''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow. '''

Modified by FredMcD

jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

Helpful Reply

Hi Barry, you do not always get a notification in the page for Flash needing to be activated. When a page wants to use Flash, the plugin notification icon should appear toward the left end of the address bar. It looks somewhat like a small gray Lego block. When you click that, you should get the usual drop-down panel where you can give permission for the page to use Flash.

Hi Barry, you do not always get a notification in the page for Flash needing to be activated. When a page wants to use Flash, the plugin notification icon should appear toward the left end of the address bar. It looks somewhat like a small gray Lego block. When you click that, you should get the usual drop-down panel where you can give permission for the page to use Flash.
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

bsfinkel said

Is there something that FF has saved somewhere that tells FF never to activate Flash on the Adobe help/check web page?

Check the Permissions panel of the Page Info dialog. While on the Adobe help page, you can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

The top section should have the Flash permission. Usually it is "Use default" -- which follows the general setting on the Add-ons page -- but it may have changed to Allow or Block.

''bsfinkel [[#question-1176045|said]]'' <blockquote>Is there something that FF has saved somewhere that tells FF never to activate Flash on the Adobe help/check web page? </blockquote> Check the Permissions panel of the Page Info dialog. While on the Adobe help page, you can call that up using any of these: * right-click a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions The top section should have the Flash permission. Usually it is "Use default" -- which follows the general setting on the Add-ons page -- but it may have changed to Allow or Block.

Helpful Reply

I was able to left-click in an empty area in the page and set flash always to activate. Thanks.

But the page still tells me that either Flash is not installed or not enabled. The "View Page Info" says Allow Adobe Flash.

--Barry Finkel

I was able to left-click in an empty area in the page and set flash always to activate. Thanks. But the page still tells me that either Flash is not installed or not enabled. The "View Page Info" says Allow Adobe Flash. --Barry Finkel
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

I don't know why a site that has Allow permission would not be able to detect Flash but other sites can. Or is this a more general problem?

Do you have any Flash-related extensions, such as Flash Stop, Flash Control, etc.? You can view, disable, and often remove unwanted or unneeded extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that could interfere with sites using Flash? If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox before the change takes effect. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

I don't know why a site that has Allow permission would not be able to detect Flash but other sites can. Or is this a more general problem? Do you have any Flash-related extensions, such as Flash Stop, Flash Control, etc.? You can view, disable, and often remove unwanted or unneeded extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side. Any extensions that Firefox installs on its own are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that could interfere with sites using Flash? If in doubt, disable. Often a link will appear above at least one disabled extension to restart Firefox before the change takes effect. You can complete your work on the tab and click one of the links as the last step. Any improvement?

Question owner

i believe that this Adobe help/check page is the only one that has problems.

Note that I ALWAYS run in safe-mode to eliminate add-ons. With add-ons enabled, those add-ons cause FF to run slowly in my configuration.

I looked at the source of that page, but I do not understand that code; I have never attempted to write/design a web page. So, I do not know what test is being done on that page to make its determination. Should I also be contacting Adobe support? Thanks.

--Barry Finkel

i believe that this Adobe help/check page is the only one that has problems. Note that I ALWAYS run in safe-mode to eliminate add-ons. With add-ons enabled, those add-ons cause FF to run slowly in my configuration. I looked at the source of that page, but I do not understand that code; I have never attempted to write/design a web page. So, I do not know what test is being done on that page to make its determination. Should I also be contacting Adobe support? Thanks. --Barry Finkel

Question owner

Is there an update to this trouble ticket? I have an online meeting today, and it requires Flash. I installed the new Flash 27.0.0.183 (replacing 27.0.0.170), I changed my add-ons manager ALWAYS to enable Flash, and I then restarted FF (in safe mode). FF still thinks that Flash is not installed. I am running 56.0.3. For the meeting I am forced to use IE11, as Chrome is known not to work with the meeting application.

What steps do I need to do to debug this problem? Thanks.

--Barry Finkel

Is there an update to this trouble ticket? I have an online meeting today, and it requires Flash. I installed the new Flash 27.0.0.183 (replacing 27.0.0.170), I changed my add-ons manager ALWAYS to enable Flash, and I then restarted FF (in safe mode). FF still thinks that Flash is not installed. I am running 56.0.3. For the meeting I am forced to use IE11, as Chrome is known not to work with the meeting application. What steps do I need to do to debug this problem? Thanks. --Barry Finkel
guigs
  • Top 25 Contributor
  • Administrator
  • Moderator
1068 solutions 11635 answers

Hi bsfinkel, As you may be aware, Adobe Flash Technologies will eventually no longer be supported. Recently, Firefox users have been set to have Adobe Flash to click to activate. [[T:PluginSupportEOL]]

All recent versions of Firefox will require users to manually click to enable content that requires Flash. This requirement improves your security and stability while browsing because you are less likely to be affected by Flash security bugs or crashes.

For instructions and screenshots on how to click to activate Flash, see Why do I have to click to activate plugins?.

Adobe and Mozilla will continue to support Flash until 2020.

Hi bsfinkel, As you may be aware, Adobe Flash Technologies will eventually no longer be supported. Recently, Firefox users have been set to have Adobe Flash to click to activate. [[T:PluginSupportEOL]] All recent versions of Firefox will require users to manually click to enable content that requires Flash. This requirement improves your security and stability while browsing because you are less likely to be affected by Flash security bugs or crashes. For instructions and screenshots on how to click to activate Flash, see [[Why do I have to click to activate plugins?]]. Adobe and Mozilla will continue to support Flash until [https://developer.mozilla.org/docs/Plugins/Roadmap 2020].

Question owner

Even if I set Flash "always to activate", I still get the message that Flash is not installed. Last night I upgraded from 27.0.0.;183 to 27.0.0.187 . What do I have to do to

1) get Flash to run, or 2) debug this problem

I looked at the source of the page

    https://helpx.adobe.com/flash-player.html

but I do not know JS, so I do not know what test that page is running.

Thanks.

--Barry Finkel

Even if I set Flash "always to activate", I still get the message that Flash is not installed. Last night I upgraded from 27.0.0.;183 to 27.0.0.187 . What do I have to do to 1) get Flash to run, or 2) debug this problem I looked at the source of the page https://helpx.adobe.com/flash-player.html but I do not know JS, so I do not know what test that page is running. Thanks. --Barry Finkel
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

Hi Barry, it's hard to understand how just the one page could have a problem.

Could you double-check the following internal page. Type or paste about:plugins in the address bar and press Enter to load it.

Normally, that page will show one Shockwave Flash plugin (current version), OpenH264 and Widevine. The Shockwave Flash plugin will have "State: Enabled". Anything unusual here?

For Adobe's page, could you check whether anything is blocked from loading. Open Firefox's Network Monitor in the lower part of the tab (Ctrl+shift+e or menu > Developer > Network), and then reload the page bypassing cache (Ctrl+Shift+r or Shift+click the reload button). Do you get a green dot and 200 status for everything the page tries to load?

If you click the Console "tab" that's along the top bar of the developer tools, do you see any error messages that sound relevant? You can ignore the warnings that mention something being deprecated.

Hi Barry, it's hard to understand how just the one page could have a problem. Could you double-check the following internal page. Type or paste '''about:plugins''' in the address bar and press Enter to load it. Normally, that page will show one Shockwave Flash plugin (current version), OpenH264 and Widevine. The Shockwave Flash plugin will have "State: Enabled". Anything unusual here? For Adobe's page, could you check whether anything is blocked from loading. Open Firefox's Network Monitor in the lower part of the tab (Ctrl+shift+e or menu > Developer > Network), and then reload the page bypassing cache (Ctrl+Shift+r or Shift+click the reload button). Do you get a green dot and 200 status for everything the page tries to load? If you click the Console "tab" that's along the top bar of the developer tools, do you see any error messages that sound relevant? You can ignore the warnings that mention something being deprecated.
FredMcD
  • Top 10 Contributor
3666 solutions 50303 answers

bsfinkel said

https://helpx.adobe.com/flash-player.html

Did you check out Still having problems? At the bottom of the page?

''bsfinkel [[#answer-1046024|said]]'' <blockquote> https://helpx.adobe.com/flash-player.html </blockquote> Did you check out '''Still having problems?''' At the bottom of the page?

Question owner

In response to jscher2000 - it is not just one page that is having a problem. The web site geni.com uses flash to display family trees, and that site complains that Flash is not available. about:plugins says:


Shockwave Flash

   File: NPSWF32_27_0_0_183.dll
   Path: C:\Windows\system32\Macromed\Flash\NPSWF32_27_0_0_183.dll
   Version: 27.0.0.183
   State: Enabled
   Shockwave Flash 27.0 r0

Nothing abnormal. As for Firefox's Network Monitor. I did cntl-shift-e, and I see a blue highlighted box at the bottom of the page. I am not sure what this does. The bottom part of everything on that line appears to be hidden by the bottom of the window, I did a cntl-shift-reload, but I did not see any green dot. I am not sure where the Network Monitor will display its messages, if any, or where the green dot would appear.

To what console are you referring? Web console (cntl-shift-k) or Browser console (cntl-shift-j)? Browser console has lots of information, but I am not sure I can interpret what the contents are, and I do not know if the newer items are at the bottom or at the top. Web console just highlights a blue box at the bottom, and, as with the other blue box, I have no idea what that means.

In response to FredMcd - I did check "having problems" at the bottom of the page. I have no problems installing Flash. It installs, and then it opens an "ad" web page. And the resulting files are in the \windows\system32\macromed\flash directory. What I do after each install is to rename the old .ocx, .dll, and .exe files that the install process does not remove.

--Barry Finkel

In response to jscher2000 - it is not just one page that is having a problem. The web site geni.com uses flash to display family trees, and that site complains that Flash is not available. about:plugins says: ----- Shockwave Flash File: NPSWF32_27_0_0_183.dll Path: C:\Windows\system32\Macromed\Flash\NPSWF32_27_0_0_183.dll Version: 27.0.0.183 State: Enabled Shockwave Flash 27.0 r0 ----- Nothing abnormal. As for Firefox's Network Monitor. I did cntl-shift-e, and I see a blue highlighted box at the bottom of the page. I am not sure what this does. The bottom part of everything on that line appears to be hidden by the bottom of the window, I did a cntl-shift-reload, but I did not see any green dot. I am not sure where the Network Monitor will display its messages, if any, or where the green dot would appear. To what console are you referring? Web console (cntl-shift-k) or Browser console (cntl-shift-j)? Browser console has lots of information, but I am not sure I can interpret what the contents are, and I do not know if the newer items are at the bottom or at the top. Web console just highlights a blue box at the bottom, and, as with the other blue box, I have no idea what that means. In response to FredMcd - I did check "having problems" at the bottom of the page. I have no problems installing Flash. It installs, and then it opens an "ad" web page. And the resulting files are in the \windows\system32\macromed\flash directory. What I do after each install is to rename the old .ocx, .dll, and .exe files that the install process does not remove. --Barry Finkel
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

Hi Barry, here's a screenshot of the network monitor. Maybe yours is too short and you need to click and drag the top border of the developer tools up toward the top of the page to view more lines?

Hi Barry, here's a screenshot of the network monitor. Maybe yours is too short and you need to click and drag the top border of the developer tools up toward the top of the page to view more lines?

Question owner

What i had to do is this - I had to click on an icon on the right side of the bottom cntlp-shift-e bar to get the console display in a new window. Then I did a shift-reload. I do not see a way to capture all of the items in the console window. All are green, except for those in the attached screen capture. Then I clicked on the 'Check" button, and there were no new entries in the console window.


--

What i had to do is this - I had to click on an icon on the right side of the bottom cntlp-shift-e bar to get the console display in a new window. Then I did a shift-reload. I do not see a way to capture all of the items in the console window. All are green, except for those in the attached screen capture. Then I clicked on the 'Check" button, and there were no new entries in the console window. --
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

Hi Barry, a 302 isn't a problem, it indicates the site redirected Firefox to a different URL for that request.

Assuming Firefox is loading everything the page wants it to load, my guess is there is some reason that its scripts are not executing normally. Since you didn't find any error/failure messages, the problem may be simply trying to access plugins and not finding them.

Does my plugin lister page see Flash in your Firefox?

https://www.jeffersonscher.com/res/plugins.html

Hi Barry, a 302 isn't a problem, it indicates the site redirected Firefox to a different URL for that request. Assuming Firefox is loading everything the page wants it to load, my guess is there is some reason that its scripts are not executing normally. Since you didn't find any error/failure messages, the problem may be simply trying to access plugins and not finding them. Does my plugin lister page see Flash in your Firefox? https://www.jeffersonscher.com/res/plugins.html

Question owner

Plugin Lister

The navigator.plugins collection does not list any members. Enumeration of this collection is not possible in your browser.

The navigator.mimeTypes collection does not list any members. Enumeration of this collection is not possible in your browser

Copyright © 2016 Jefferson Scher. Updated 3/14/2016.

Does it matter that I am always running in safe mode?

--Barry Finkel

Plugin Lister The navigator.plugins collection does not list any members. Enumeration of this collection is not possible in your browser. The navigator.mimeTypes collection does not list any members. Enumeration of this collection is not possible in your browser Copyright © 2016 Jefferson Scher. Updated 3/14/2016. Does it matter that I am always running in safe mode? --Barry Finkel
jscher2000
  • Top 10 Contributor
7435 solutions 60683 answers

Safe mode does not disable plugins.

Did Firefox 55 have this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste finger and pause while the list is filtered

(3) If the privacy.resistFingerprinting preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Then test the https://www.jeffersonscher.com/res/plugins.html page again.

Safe mode does not disable plugins. Did Firefox 55 have this preference: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste '''finger''' and pause while the list is filtered (3) If the '''privacy.resistFingerprinting''' preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false Then test the https://www.jeffersonscher.com/res/plugins.html page again.

Question owner

The fingerprinting setting was "default boolean false", so I did not have to make any changes to that setting. Your plugins page gave the same response.

--Barry Finkel

The fingerprinting setting was "default boolean false", so I did not have to make any changes to that setting. Your plugins page gave the same response. --Barry Finkel