Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Adobe Flash message - Sorry, Flash Player is either not installed or not enabled.

  • 37 replies
  • 7 have this problem
  • Last reply by bsfinkel

more options

I normally have Adobe Flash in "ask to activate" status. When I want to see if I have the latest ve3rsion, I go to Add-ons Manager and change the setting to "Always activate". Then I go to to check if I have the latest version. Then I go back and reset to ":Ask to activate".

Recently, when I go to that Adobe page and click "Check", I get an error message "Sorry, Flash Player is either not installed or not enabled.." How do I get Flash enabled? I had this happen with Flash, and I recently upgraded to, and after the update the same error message appears. I am running Firefox 55.0.3 32-bit on Windows 7 Professional.

In the past, when I had "Ask to activate", the Adobe help/check page did not ask me to activate; I had to re-set the activate flag to get the help/check page to work. Is there something that FF has saved somewhere that tells FF never to activate Flash on the Adobe help/check web page?


--Barry Finkel

All Replies (17)

more options

I am not sure what bsfinkel is doing but using FF57.0.2 going to loads without problems.

I have flash and it goes the site without problems. What I think is going on is your using older Firefox 55.0.3 32-bit with newer flash which in itself is causing it's own problem. Maybe if you updated to Firefox 57.0.2 32-bit for Win7 that could be where part of the problem lies that one is update and the other isn't updated causing unforeseen problem between both of them where one is update and other isn't so one of them gets blocked. So til you update to Firefox 57.0.2 32-bit there will now real way to diagnosis where the problem is at.

more options

Can you go to and then try to view a chart view of a family tree there? Geni uses Flash to display the tree chart; Flash is not used for the Geni home page. I assume that if Flash loads on the Adobe test page, then it will load in Geni; if it fails on one it will fail on the other.

My log does not tell me when the problem first arose. It was a t least a few months, with an older version of Flash, and, I assume, an older version of Firefox. I cannot install Firefox 56.0 and test Flash, as with my configuration of windows and tabs, FF 56.0 does not let me do anything. All pages take forever to load.

--Barry Finkel

more options

Do you at least see the Lego block icon on the Navigation Toolbar when the web page uses the Flash plugin?

You would normally see this Lego block icon and you can click it to allow Flash. If you reload the tab then the Flash plugin should be activated.

more options

Here is a screenshot of the geni.,com web page. The previous page had a "View Tree" hyperlink, and when I clicked on it I got this error page. I have included screen shots of the network console (cntl-shift-e); the second image has entries that overlap those in the first image. I could not get the entire console entries in one screen shot. Is there a way to save the console entries?

--Barry Finkel

more options

Hi Barry, I haven't been able to think of any way to hide the availability of the Flash plugin from sites -- using only a built-in setting -- other than privacy.resistFingerprinting.

Even with that setting, if a site creates a Flash object in the page, Firefox will behave normally. I added a demo of that to my plugin lister page (button to Insert Sample Flash Movie -- very boring old SWF).

On your Firefox, does that trigger the plugin notification icon?

Have you ever tried...

New Profile Test

This takes about 3 minutes, plus the time to test your sites.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like Dec2017, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new.

Do your sites detect Flash any better in the new profile?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

more options

Before I report my test results, I need to know HOW I GET MY ORIGINAL PROFILE BACK. After the test, I set my "abn" profile as the default. Then I restarted in safe mode. Firefox automatically installed the update 57.0.2., and it started with one window and 4 tabs. It had the tabs from my FlashTest session. And "about:profiles" tells me:

Profile: default-user-abn Rename Remove Launch in a new browser


Profile: FlashTest This is the profile in use and it cannot be deleted. Rename Set as default profile

So, FF thinks that FlashTest is the profile in use. Whe4n I clicked on "Launch in a new browser", I did not get my old default profile with all its windows and tabs. What do I need to do to get my old profile back? Here is a listing of the profile directory:


Volume in drive C is Win7-BOOT
Volume Serial Number is 8CC2-2BB1
Directory of C:\Users\BarryFinkel\AppData\Roaming\Mozilla\Firefox\Profiles

12/12/2017 08:10 AM <DIR> . 12/12/2017 08:10 AM <DIR> .. 11/28/2017 08:18 PM <DIR> abn.bak 12/12/2017 08:14 AM <DIR> abnfpged.default 12/10/2017 09:26 PM <DIR> bpp5k478.Default User 12/12/2017 08:36 AM <DIR> eow9bh5y.FlashTest 12/10/2017 09:26 PM <DIR> gt7ajmfp.Default User

              0 File(s)              0 bytes
              7 Dir(s)  42,347,819,008 bytes free


more options

Hi Barry, please ignore the "Launch" button and use the method I described before: select a new default profile to start in, then click Restart normally.

However, if you can't use Firefox 57 for some reason, you may need to do it in 5 steps:

more options

Here is a log of the tests I ran this morning. Seven screen-shots are attached. I see that they have been changed from .jpg to .png; I hope that they are still legible.


09:40 56.0.2 09:40 Change profile to FlashTest; restart with add-ons disabled. 09:42 FF started with my regular (abn) profile. Why?? 09:44 About:profiles shows that

          Profile: default-usr-abn is in use and cannot be deleted.  WHY?
          Profile: FlashTest  Rename | Remove | Launch

09:48 About:Profiles Create a new profile - FlashTest171214 09:50 Set as default profile. 09:52 Restart Normally 09:57 09:58 A web page is slowing down your browser, what do you

           want to do?  [I have never seen this before.]
           I did not click anything.   Eventually ...

09:59 Page loaded 10:00 cntl-shift-e & Show in different window. 10:00 Click "Check Now" orange button ==> blank gray box under button.

          Nothing else happened; nothing in NetConsole

10:05 Reload web page ==> 144 requests in NetConsole 10:07 Click "Check Bar" ==> Still nothing happened & 144 requests. 10:10 Plugin Lister in new tab.


10:12 Close NetConsole. Start a new one. 10:15 Insert Sample Flash Movie ==> gray box

          Activate Adobe Flash  ==> Allow Now

10:16 Google window with green arrow displayed 10:18 PluginLister2.171214.jpg 10:19 Close NetConsole. 10:19 Start with add-ons disabled ==> Auto-update to 57.0.2


10:21 57.0.2 10:22 Flash Player Help 10:23 cntl-shift-e 10:23 Click orange "Check Now" button.

          "Sorry, Flash Player is either not installed or not
          enabled,  Go to step 2."   Nothing in NetConsole

10:26 FlashHelp1.171214,jpg 10:27 Start with addons enabled. 10:29 Restart witn addone disabled 10:30 Plugin Lister ==> "does not list any members" 10:32 PluginLister3.171214.jpg 10:33 Click "Insert Sample Flash Movie" ==> button vanishes.

          One entry in NetConsole

10:36 PluginLister4.171214.jpg 10:36 Close NetConsole 10:36 Start with addons enabled. 10:37 cntl-shift-e 10:38 Click on "Insert Sample Flash Movie". ==> gray window.

           One request in NetConsole
           Click Activate Adobe Flash ==> Allow Now

10:41 System runnning slowly. 10:43 Two entries in NetConsole 10:49 PluginLister5.171214.jpg 10:49 Close NetConsole 10:50 Reload page. 10:51 Click "Insert Sample Flash Movie" ==> movie window.

         One item in NetConsole.

10:52 Click green arrow ==> movie plays 10:53 Flash Player Help

      New NetConsole

10:54 Click orange "Check Now" button ==> Gran blank box.

          Nothing in NetConsole window

10:57 FlashHelp2.171214.jpg 11:00 About:profiles Set default-user-abn as default profile. 11:01 Exit Firefox (to re-install 56.0.2).

more options

Wow, that's a lot of testing.

First and second images, in Firefox 56; fifth image, in Firefox 57

These look normal. Because there is a video player rectangle, you got the prompt to enable Flash, and then the dark gray "Lego block" appears at the left end of the address bar. This is what is supposed to happen. Not sure about the slowness in Firefox 57; that could be a different issue.

Third and fourth images, sixth image, in Firefox 57

Flash seems to be disabled or blocked. The network monitor shows that Firefox found a cached copy of the SWF but it didn't set up Flash for some reason. This is the same problem you have in your normal profile, I think.

Seventh image, in Firefox 57

This looks normal. Because there's no player rectangle, you have to use the light-gray "Lego block" icon with the pulsing blue dot to activate Flash.

more options

I have learned from my many years as a Systems Programmer that problem testing needs to be complete; all options need to be tested in order to determine exactly what is happening.

You refer to a "light gray 'lego-block' icon with the pulsing blue dot". Where is that? I did not see a pulsing blue dot. And when you refer to my uploaded images, I am not sure of the numbering you use. I have 7 screen-shots, and I am not sure of your numbering. The images, as they appear above:

    PL1   PL2   PL3
    PL4   PL5   FH1

PL = PluginLister page FH = Flash Help page

In what image(s) is the icon that I have to click?

But what I conclude is this - Flash Player works in regular mode, but in safe-mode Firefox claims that Flash is not installed or not activated. But Flash is installed, and I have told FF "always to activate"/ I do not have records as to when this Flash problem first appeared, so I do not know in what release of FF the problem was introduced. It appears that both 56 and 57 have the problem.

--Barry Finkel

more options

bsfinkel said

In what image(s) is the icon that I have to click?

FH2, between the i-in-a-circle and the padlock in the address bar.

Flash Player works in regular mode, but in safe-mode Firefox claims that Flash is not installed or not activated.

Flash used to work in Firefox's Safe Mode. I can't test at the moment

more options

That "circle-i" icon is: Show site information Connection is not secure > Parts of this page are not secure (such as images)

Permissions Set Cookies Allowed X

I do not see it as doing what you think it does. And it is not flashing. If this is a bug, do I have to open a bug report?

--Barry Finkel

more options
more options

That image is "FH2". It is FF with add-ons enabled. I see the square icon. But when I run in safe3-mode, I do not see that icon. Without the icon, there is nothing to click.

--Barry Finkel

more options

Here is a quick update. I believe, but cannot yet prove, that the problem was introduced in some version of Firefox 56.0. The next time I have to uninstall FF I will re-install 55.0.3 and test it. I did not keep notes when the problem first surfaced. I have shown with 56 and 57 testing that Flash works fine in regular mode but not in safe-mode. I do not remember when the lz4-encoded restore files were introduced - with 55 or 56. A Google search implies 56.

--Barry Finkel

more options

bsfinkel said

I do not remember when the lz4-encoded restore files were introduced - with 55 or 56. A Google search implies 56.

Yes, it was 56.

more options

I just upgraded from 56.0.2 to 58.0.1, basically to see if the latest FF will work with my combination of windows and tabs. I checked Flash, and 58.0.2 in Safe Mode says that Flash is not installed . I still assume that, if I were to re-install 55.x, then Flash would work in safe mode. I really do not have the facility to re-install 55.x and test Flash. I assume that someone in FF the support group can test if Flash works in 55.x safe mode.

Or should I open a bug report without this confirmation test? Thanks.

--Barry Finkel

  1. 1
  2. 2