X
Tap here to go to the mobile version of the site.

Support Forum

Many pages are too wide; CTRL and + or - does not help

Posted

I finally uninstalled Chrome and put in Firefox. Haven't used it in years.

On my screen most pages are "wide" -- so a horizontal scroll bar appears at the bottom of the page, and to see the very right hand side of the page, I have to scroll over.

I have tried the CTRL and - but all that does is shrink the text on the page. It doesn't make everything actually fit on the page horizontally. See the uploaded images of a question I found on this topic on this forum. Even though I've shrunk the font size down in the second one, I still see the horizontal scroll bar at the bottom. Even if I shrink it all the way to the minimum (which results in a tiny font I can't see), some of the page appears off-screen and has to be scrolled over to be seen.

I have tried for an hour to fix this and there doesn't seem to be any way. HELP!

I finally uninstalled Chrome and put in Firefox. Haven't used it in years. On my screen most pages are "wide" -- so a horizontal scroll bar appears at the bottom of the page, and to see the very right hand side of the page, I have to scroll over. I have tried the CTRL and - but all that does is shrink the text on the page. It doesn't make everything actually fit on the page horizontally. See the uploaded images of a question I found on this topic on this forum. Even though I've shrunk the font size down in the second one, I still see the horizontal scroll bar at the bottom. Even if I shrink it all the way to the minimum (which results in a tiny font I can't see), some of the page appears off-screen and has to be scrolled over to be seen. I have tried for an hour to fix this and there doesn't seem to be any way. HELP!
Attached screenshots

Chosen solution

Yes, you can use Ctrl and scroll the wheel away from you to enlarge or toward you to reduce. Glad to hear that is working.

Or you should be able to hold down Ctrl and tap the + key to enlarge or the - key to reduce. If the keyboard shortcuts do not work normally, and the problem isn't an add-on, I don't think I can explain that.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • Firefox 55.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
  • Support URL: https://support.mozilla.org/1/firefox/55.0.3/WINNT/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI FirePro V5800 (FireGL)
  • adapterDescription2:
  • adapterDeviceID: 0x68a9
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 23061028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22082
  • driverDate: 6-2-2011
  • driverDate2:
  • driverVersion: 8.850.7.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'Direct2D 1.1', u'AzureContentBackend': u'Direct2D 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (ATI FirePro V5800 (FireGL) Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000008482) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl2Renderer: Google Inc. -- ANGLE (ATI FirePro V5800 (FireGL) Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000008482) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

Did you try to make the window itself wider?

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Did you try to make the window itself wider? Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. Type '''about:preferences'''<enter> in the address bar. * '''Cookies; ''' Select '''Privacy. ''' Under '''History, ''' select Firefox will '''Use Custom Settings. ''' Press the button on the right side called '''Show Cookies. ''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache; ''' Select '''Advanced > Network. ''' Across from '''Cached Web Content, ''' Press '''Clear Now. ''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]]

Question owner

Thanks for the reply, but unfortunately it doesn't help me.

1) The browser is maximized on a monitor. There's no way to make the browser window bigger. 2) It's not a cookie or cache issue. I did as you instructed, but it was a brand new installation and it happened on the very first site I visited. 3) The other fixes didn't help.

There must be some kind of glitch with my monitor driver. But I didn't have this problem with Chrome and don't with IE either. Very frustrating. I guess Firefox isn't for me.

Thanks for the reply, but unfortunately it doesn't help me. 1) The browser is maximized on a monitor. There's no way to make the browser window bigger. 2) It's not a cookie or cache issue. I did as you instructed, but it was a brand new installation and it happened on the very first site I visited. 3) The other fixes didn't help. There must be some kind of glitch with my monitor driver. But I didn't have this problem with Chrome and don't with IE either. Very frustrating. I guess Firefox isn't for me.
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

It might be a monitor setting. I called for more help.

It might be a monitor setting. I called for more help.
FredMcD
  • Top 10 Contributor
4254 solutions 59582 answers

Control Panel\All Control Panel Items\Display What are your settings?

Control Panel\All Control Panel Items\Display What are your settings?
Happy112 561 solutions 5694 answers

Would you give this a try :

Press the Alt key and in the upper left corner choose 'View'

Then click 'Zoom' => 'Zoom Reset' (Ctrl + 0)

Also see : http://kb.mozillazine.org/Zoom_text_of_web_pages

Would you give this a try : Press the Alt key and in the upper left corner choose 'View' Then click 'Zoom' => 'Zoom Reset' (Ctrl + 0) Also see : http://kb.mozillazine.org/Zoom_text_of_web_pages

Modified by Happy112

Question owner

Happy 112, thank you, that doesn't do anything. It just returns the text to the "normal" size but doesn't do anything about the width issue.

FredMcD -- you are right, my displays were set to 125% text size. When I change it to 100% text size, the problem goes away.

HOWEVER this means that _ALL_ my programs are affected. The text shrinks for literally everything., I had it set to 125% for a reason -- I use multiple, large displays that are set back on my desk, so having a slightly larger text size is very helpful. I know I can increase the size of the text on Firefox. But I'd have to do it for every single program, and also it makes my Desktop icons look really small.

There is some kind of bug in Firefox that doesn't allow it to properly handle it when people increase the text size setting on their Display. Other browsers seem to handle this fine.

I also note that not all websites are affected. Wikipedia loads fine, even with the 125% setting. Google does not -- the right 15% of the page gets cut off.

I hope someone has some ideas about how to fix this. Or can it be listed as a bug for a developer to fix? (I'd fix it, but would have to do 20 years of coding to know what I was doing lol.) You seem to have diagnosed the problem, but fixing the issue on Firefox unfortunately opens a can of worms for every other program on my computer.

Thanks a lot for the help though, at least I know what is going on!

Happy 112, thank you, that doesn't do anything. It just returns the text to the "normal" size but doesn't do anything about the width issue. FredMcD -- you are right, my displays were set to 125% text size. When I change it to 100% text size, the problem goes away. HOWEVER this means that _ALL_ my programs are affected. The text shrinks for literally everything., I had it set to 125% for a reason -- I use multiple, large displays that are set back on my desk, so having a slightly larger text size is very helpful. I know I can increase the size of the text on Firefox. But I'd have to do it for every single program, and also it makes my Desktop icons look really small. There is some kind of bug in Firefox that doesn't allow it to properly handle it when people increase the text size setting on their Display. Other browsers seem to handle this fine. I also note that not all websites are affected. Wikipedia loads fine, even with the 125% setting. Google does not -- the right 15% of the page gets cut off. I hope someone has some ideas about how to fix this. Or can it be listed as a bug for a developer to fix? (I'd fix it, but would have to do 20 years of coding to know what I was doing lol.) You seem to have diagnosed the problem, but fixing the issue on Firefox unfortunately opens a can of worms for every other program on my computer. Thanks a lot for the help though, at least I know what is going on!

Question owner

I set it back to 125% (because this is how I prefer my monitor to be). Note the difference between a Google search page and a Wikipedia page. The Google search page is cut off on the right, and you have to use the horizontal scroll bar to see the right hand side. (The way their page is set up, this is very annoying!)

Wikipedia, though, sizes itself correctly. The right hand boxes are not cut off, there is no horizontal scroll bar at all.

So apparently some webpages handle the 125% monitor setting, and some don't.

Again I appreciate the help and any ideas would be most appreciated. Thanks!

I set it back to 125% (because this is how I prefer my monitor to be). Note the difference between a Google search page and a Wikipedia page. The Google search page is cut off on the right, and you have to use the horizontal scroll bar to see the right hand side. (The way their page is set up, this is very annoying!) Wikipedia, though, sizes itself correctly. The right hand boxes are not cut off, there is no horizontal scroll bar at all. So apparently some webpages handle the 125% monitor setting, and some don't. Again I appreciate the help and any ideas would be most appreciated. Thanks!
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Do you use your monitor in a portrait orientation (pivot the screen from wide to tall)?

Normally when you reduce zoom the entire layout reduces proportionally. Since that does not appear to be happening on your Firefox, could you make sure your Firefox is set to "full zoom" and not "text only" zoom? There are two ways to check that, either:

(1) View menu on the classic menu bar

If you do not normally display the classic menu bar, tap the Alt key or the F10 key to activate it. Then

View > Zoom > uncheck Zoom Text Only

(2) about:config preferences editor

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(B) In the search box above the list, type or paste zoom and pause while the list is filtered

(C) If the browser.zoom.full preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Do you use your monitor in a portrait orientation (pivot the screen from wide to tall)? Normally when you reduce zoom the entire layout reduces proportionally. Since that does not appear to be happening on your Firefox, could you make sure your Firefox is set to "full zoom" and not "text only" zoom? There are two ways to check that, either: (1) View menu on the classic menu bar If you do not normally display the classic menu bar, tap the Alt key or the F10 key to activate it. Then View > Zoom > ''uncheck'' Zoom Text Only (2) about:config preferences editor (A) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (B) In the search box above the list, type or paste '''zoom''' and pause while the list is filtered (C) If the '''browser.zoom.full''' preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Question owner

Thanks jscher2000. Zoom Text Only was not selected. I selected and deselected it to make sure. It doesn't seem to affect the problem. I also tried to the about:config method just to make sure, and the boolean was set to true (and browser.zoom.full was not bolded).

Yes, my monitors are in portrait mode, not landscape.

Thanks. (I have been playing around with what websites seem to scale correctly and which don't. It really seems to be 50/50.)

Thanks jscher2000. Zoom Text Only was not selected. I selected and deselected it to make sure. It doesn't seem to affect the problem. I also tried to the about:config method just to make sure, and the boolean was set to true (and browser.zoom.full was not bolded). Yes, my monitors are in portrait mode, not landscape. Thanks. (I have been playing around with what websites seem to scale correctly and which don't. It really seems to be 50/50.)
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Helpful Reply

Let's say hypothetically you have a full HD monitor in portrait mode (1080 x 1920) at a base level of 125% zoom, based on the Windows Text Size setting. That allows only 1080/1.25 or 864 CSS pixels horizontally. By CSS pixels I mean the pixels specified by the design of the web page, which Firefox enlarges by 125% to use the 1080 available device pixels horizontally.

It's not uncommon for sites to have a minimum width built into their layout based on a classic VGA (1024x768) resolution. Since your effective resolution is lower than 1024, many such sites will be too wide and will cause a horizontal scrollbar. The Google search results page appears to have a minimum width without scrolling of 1100 CSS pixels.

For some sites, you can use Firefox's Reader View to extract the main content from the problematic layout, but if you need all of the features of that page, that won't help. More info: Firefox Reader View for clutter-free web pages.

Over the years, I think there have been some extensions which would modify layouts by making them fit the width of the "viewport" (the area between the left of the window and vertical scrollbar). However, I don't know whether any of those are still working today considering the migration to widescreen monitors. You could look on the Add-ons site.

https://addons.mozilla.org/firefox/extensions/

Let's say hypothetically you have a full HD monitor in portrait mode (1080 x 1920) at a base level of 125% zoom, based on the Windows Text Size setting. That allows only 1080/1.25 or 864 CSS pixels horizontally. By CSS pixels I mean the pixels specified by the design of the web page, which Firefox enlarges by 125% to use the 1080 available device pixels horizontally. It's not uncommon for sites to have a minimum width built into their layout based on a classic VGA (1024x768) resolution. Since your effective resolution is lower than 1024, many such sites will be too wide and will cause a horizontal scrollbar. The Google search results page appears to have a minimum width without scrolling of 1100 CSS pixels. For some sites, you can use Firefox's Reader View to extract the main content from the problematic layout, but if you need all of the features of that page, that won't help. More info: [[Firefox Reader View for clutter-free web pages]]. Over the years, I think there have been some extensions which would modify layouts by making them fit the width of the "viewport" (the area between the left of the window and vertical scrollbar). However, I don't know whether any of those are still working today considering the migration to widescreen monitors. You could look on the Add-ons site. https://addons.mozilla.org/firefox/extensions/

Question owner

Thanks jscher2000. This is really helpful. I think I understand what the problem is. My monitors are set to 1200 x 1920 resolution. So in portrait mode at 1.25, I'm only getting 960 pixels, and sites are set to 1024 or more. It was bugging me why the Google scroll bar was even longer than most, and you said Google is requiring at least 1100. Fascinating, and helpful.

Do you have any idea why I don't seem to have this problem in IE or Chrome? I currently don't have Chrome installed, but I used it for quite a while, and I don't remember having it. And I just tried it with IE. Google scales completely fine -- with smaller text than in Firefox. It appears to be adjusting the Google page to 83% (looking at the settings). I guess these other browsers have found workarounds for this problem that aren't currently available in Firefox?

Thanks again.

Thanks jscher2000. This is really helpful. I think I understand what the problem is. My monitors are set to 1200 x 1920 resolution. So in portrait mode at 1.25, I'm only getting 960 pixels, and sites are set to 1024 or more. It was bugging me why the Google scroll bar was even longer than most, and you said Google is requiring at least 1100. Fascinating, and helpful. Do you have any idea why I don't seem to have this problem in IE or Chrome? I currently don't have Chrome installed, but I used it for quite a while, and I don't remember having it. And I just tried it with IE. Google scales completely fine -- with smaller text than in Firefox. It appears to be adjusting the Google page to 83% (looking at the settings). I guess these other browsers have found workarounds for this problem that aren't currently available in Firefox? Thanks again.

Modified by ianchama

jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Hmm, if other browsers have a "shrink to fit" feature, that would be a nice addition to Firefox. However, the full zoom feature really should allow you to do that, so I don't know why that isn't working. ??

Hmm, if other browsers have a "shrink to fit" feature, that would be a nice addition to Firefox. However, the full zoom feature really should allow you to do that, so I don't know why that isn't working. ??

Question owner

What is the "full zoom" feature?

A friend of mine suggested hitting "Control" and using the scroll button on my mouse. That actually works.

What is the "full zoom" feature? A friend of mine suggested hitting "Control" and using the scroll button on my mouse. That actually works.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Chosen Solution

Yes, you can use Ctrl and scroll the wheel away from you to enlarge or toward you to reduce. Glad to hear that is working.

Or you should be able to hold down Ctrl and tap the + key to enlarge or the - key to reduce. If the keyboard shortcuts do not work normally, and the problem isn't an add-on, I don't think I can explain that.

Yes, you can use Ctrl and scroll the wheel away from you to enlarge or toward you to reduce. Glad to hear that is working. Or you should be able to hold down Ctrl and tap the + key to enlarge or the - key to reduce. If the keyboard shortcuts do not work normally, and the problem isn't an add-on, I don't think I can explain that.

Question owner

Yes, the issue seems resolved now. Ctrl and +/- do not just affect the text size, they also affect the horizontal scroll bar. I swear that it wasn't working yesterday -- the scroll bar would stay while the text would change in size. But something I did in trying to fix it -- must be one of your suggestions -- actually did fix it. Sorry I can't tell which one. But the scroll button on the mouse and the CTRL +/- do work now. And it seems like it remembers my last setting for each individual page.

Thanks so much for the help, sorry I can't tell you what actually fixed it!

Yes, the issue seems resolved now. Ctrl and +/- do not just affect the text size, they also affect the horizontal scroll bar. I swear that it wasn't working yesterday -- the scroll bar would stay while the text would change in size. But something I did in trying to fix it -- must be one of your suggestions -- actually did fix it. Sorry I can't tell which one. But the scroll button on the mouse and the CTRL +/- do work now. And it seems like it remembers my last setting for each individual page. Thanks so much for the help, sorry I can't tell you what actually fixed it!
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

No worries, these things can't always be explained. It's possible that even though Zoom Text Only appeared to be off, the user interface was out-of-sync with reality and turning it on and off cleared up the odd behavior.

No worries, these things can't always be explained. It's possible that even though Zoom Text Only appeared to be off, the user interface was out-of-sync with reality and turning it on and off cleared up the odd behavior.