X
Tap here to go to the mobile version of the site.

Support Forum

How do I install Firefox52.1esr.dmg

Posted

I have a web site which won't run a program under Firefox. It says I need to install an extension. When I downloaded it was "Firefox52.1esr.dmg". What do I do with this to update Firefox. I am running windows 7.

I have a web site which won't run a program under Firefox. It says I need to install an extension. When I downloaded it was "Firefox52.1esr.dmg". What do I do with this to update Firefox. I am running windows 7.

Chosen solution

A .dmg file is a program installer for Mac computers. I would step back from whatever site told you to install that as it doesn't sound trustworthy. Or if you want to give a link to volunteers can see what's going on, feel free to post one.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
3373 solutions 45603 answers

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

[https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]

Question owner

Thanks Fred. I still don't know what the .dmg extension (Firefox52.1esr.dmg) is and what I do with it. The site I went to said to download it to fix my problem but I can't do anything with it.

Thanks Fred. I still don't know what the .dmg extension (Firefox52.1esr.dmg) is and what I do with it. The site I went to said to download it to fix my problem but I can't do anything with it.
jscher2000
  • Top 10 Contributor
7044 solutions 57426 answers

Chosen Solution

A .dmg file is a program installer for Mac computers. I would step back from whatever site told you to install that as it doesn't sound trustworthy. Or if you want to give a link to volunteers can see what's going on, feel free to post one.

A .dmg file is a program installer for Mac computers. '''I would step back from whatever site told you to install that as it doesn't sound trustworthy.''' Or if you want to give a link to volunteers can see what's going on, feel free to post one.

Question owner

Thanks for the help. The file came from the Charles Schwab website. I'll call them.

Thanks for the help. The file came from the Charles Schwab website. I'll call them.
jscher2000
  • Top 10 Contributor
7044 solutions 57426 answers

Helpful Reply

Ah.

If they are suggesting you downgrade Firefox so you can run the Java plugin or another old plugin, please see this article for more background: Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work?

Ah. If they are suggesting you downgrade Firefox so you can run the Java plugin or another old plugin, please see this article for more background: [[Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work?]]