X
Tap here to go to the mobile version of the site.

Support Forum

ebay only site shows a mobile site

Posted

I have a problem with ebay it shows as a mobile site why? amazon shows fine and all other sites the only add-on i have installed us ublock nothing else.

I have tried clearing cookies,temp files, resting firefox even removing ublock reset firfox and even uninstalled firefox with iobit uninstaller and scanned for leftovers after removing it.

I'm on windows 10 pro running build 1703 and it happened in 1607 as well

Thanks for the help in advance

I have a problem with ebay it shows as a mobile site why? amazon shows fine and all other sites the only add-on i have installed us ublock nothing else. I have tried clearing cookies,temp files, resting firefox even removing ublock reset firfox and even uninstalled firefox with iobit uninstaller and scanned for leftovers after removing it. I'm on windows 10 pro running build 1703 and it happened in 1607 as well Thanks for the help in advance

Chosen solution

Do you see this extension on the about:addons page?

  • "3-bar" menu button or Tools -> Add-ons -> Extensions

You can find the install location of a specific extension in the extensions.json file in the profile folder. You can open the extensions.json file in the Scratchpad and search for this extension. The descriptor field should list its install location.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


Extensions that do not have a "Remove" button are installed globally by other software and are not under control of the Firefox extension manager. Globally installed extensions are usually found via a registry scan or are installed in a location that Firefox scans for installed extensions.

Extensions installed globally need to be removed via the settings (Options/Preferences) of the program that has added this extension or this program has to be uninstalled via "Control Panel -> Programs". In Firefox you can only disable such an extension.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (masking-agent; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?


https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. Type '''about:preferences'''<enter> in the address bar. * '''Cookies; ''' Select '''Privacy. ''' Under '''History, ''' select Firefox will '''Use Custom Settings. ''' Press the button on the right side called '''Show Cookies. ''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache; ''' Select '''Advanced > Network. ''' Across from '''Cached Web Content, ''' Press '''Clear Now. ''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''General. ''' Look for and turn off '''Use Hardware Acceleration. ''' Then restart. Poke around safe websites. Are there any problems? ------------------- https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

This is likely because you use an extension (masking-agent) to spoof the user agent:

  • User Agent: Mozilla/5.0 (masking-agent; rv:54.0) Gecko/20100101 Firefox/54.0

There is always a risk when you use extensions like these.

This is likely because you use an extension (masking-agent) to spoof the user agent: *User Agent: Mozilla/5.0 (masking-agent; rv:54.0) Gecko/20100101 Firefox/54.0 There is always a risk when you use extensions like these.

Question owner

none of those steps worked all i have is ublock installed but as for following all the steps nothing has worked still shows the mobile site and in chrome,internet explorer and edge it works fine but i hate those browsers

none of those steps worked all i have is ublock installed but as for following all the steps nothing has worked still shows the mobile site and in chrome,internet explorer and edge it works fine but i hate those browsers
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

Is your user agent now default?


Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.

Is your user agent now default? *http://browserspy.dk/browser.php *http://browserspy.dk/headers.php ---- Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies" You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History"). Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks and history and cookies and passwords and cache and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note. You can't recover from this 'forget' unless you have a backup of involved files. If you revisit a 'forgotten' website then data from that website will be saved once again. *https://support.mozilla.org/en-US/kb/delete-browsing-search-download-history-firefox

Question owner

still shows mobile site

still shows mobile site
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

Did you try "Forget About This Site"?

Are you possibly zooming the page or otherwise have increased the content of the Firefox window?

Try to reset (power off/on) the router.


Can you attach a screenshot?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

Did you try "Forget About This Site"? Are you possibly zooming the page or otherwise have increased the content of the Firefox window? Try to reset (power off/on) the router. ---- Can you attach a screenshot? *https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem *use a compressed image type like PNG or JPG to save the screenshot Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

Question owner

just a little more information to let you know what I have done i uninstalled firefox 55 x64 rebooted. Then I tried x86 version still the same so i uninstalled it went into regedit and removed all the firefox entries rebooted and still get the same. I have rebooted my router many times as well thanks in advance to everyone who has took the time to help me out.

just a little more information to let you know what I have done i uninstalled firefox 55 x64 rebooted. Then I tried x86 version still the same so i uninstalled it went into regedit and removed all the firefox entries rebooted and still get the same. I have rebooted my router many times as well thanks in advance to everyone who has took the time to help me out.
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

You can check out at the browserspy website how websites see you:

You can check out at the browserspy website how websites see you: *http://browserspy.dk/browser.php *http://browserspy.dk/headers.php

Question owner

what i found out from the last link is some add-on has been installed im guessing but its not showing as installed https://addons.mozilla.org/en-US/firefox/addon/masking-agent/

I have no idea what this was till now and its not in add-ons sho who do i remove it please thank you

what i found out from the last link is some add-on has been installed im guessing but its not showing as installed https://addons.mozilla.org/en-US/firefox/addon/masking-agent/ I have no idea what this was till now and its not in add-ons sho who do i remove it please thank you
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

Can you post the results of that the browserspy website shows?

You can see all extensions on the "Help -> Troubleshooting Information" page (about:support).

Can you post the results of that the browserspy website shows? You can see all extensions on the "Help -> Troubleshooting Information" page (about:support). *https://support.mozilla.org/en-US/kb/disable-or-remove-add-ons *https://support.mozilla.org/en-US/kb/uninstalling-toolbars

Question owner

i installed it and tried to remove it in safe mode with and without iobit uninstaller

i installed it and tried to remove it in safe mode with and without iobit uninstaller
Snoddingcreative 1 solutions 20 answers

Are you looking at it on your phone or a small screen that could be why. Sometimes the sites feature a desktop versian that you can select.

Are you looking at it on your phone or a small screen that could be why. Sometimes the sites feature a desktop versian that you can select.
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

I get the same mobile page with this masked user agent.

  • Mozilla/5.0 (masking-agent; rv:55.0) Gecko/20100101 Firefox/55.0
I get the same mobile page with this masked user agent. *Mozilla/5.0 (masking-agent; rv:55.0) Gecko/20100101 Firefox/55.0

Modified by cor-el

Question owner

no i am not unless a 22" screen is to small. If you would have looked at the last screen shot you would have seen that this making agent add-on is hiding my os so ebay is defaulting to the mobile site and like heck can i get this making agent to uninstall. As stated before i have tried a number of ways to uninstall it even in safe mode and it still is present there even after it says its been removed. Thanks for the response

no i am not unless a 22" screen is to small. If you would have looked at the last screen shot you would have seen that this making agent add-on is hiding my os so ebay is defaulting to the mobile site and like heck can i get this making agent to uninstall. As stated before i have tried a number of ways to uninstall it even in safe mode and it still is present there even after it says its been removed. Thanks for the response

Question owner

my question is how do i uninstall it from my system because going in to add-ons wont remove it even in safe mode

my question is how do i uninstall it from my system because going in to add-ons wont remove it even in safe mode
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158573 answers

Chosen Solution

Do you see this extension on the about:addons page?

  • "3-bar" menu button or Tools -> Add-ons -> Extensions

You can find the install location of a specific extension in the extensions.json file in the profile folder. You can open the extensions.json file in the Scratchpad and search for this extension. The descriptor field should list its install location.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.


Extensions that do not have a "Remove" button are installed globally by other software and are not under control of the Firefox extension manager. Globally installed extensions are usually found via a registry scan or are installed in a location that Firefox scans for installed extensions.

Extensions installed globally need to be removed via the settings (Options/Preferences) of the program that has added this extension or this program has to be uninstalled via "Control Panel -> Programs". In Firefox you can only disable such an extension.

Do you see this extension on the about:addons page? *"3-bar" menu button or Tools -> Add-ons -> Extensions You can find the install location of a specific extension in the extensions.json file in the profile folder. You can open the extensions.json file in the Scratchpad and search for this extension. The descriptor field should list its install location. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox ---- Extensions that do not have a "Remove" button are installed globally by other software and are not under control of the Firefox extension manager. Globally installed extensions are usually found via a registry scan or are installed in a location that Firefox scans for installed extensions. *https://developer.mozilla.org/Installing_extensions *https://developer.mozilla.org/Adding_Extensions_using_the_Windows_Registry Extensions installed globally need to be removed via the settings (Options/Preferences) of the program that has added this extension or this program has to be uninstalled via "Control Panel -> Programs". In Firefox you can only disable such an extension.

Question owner

ok i found out how to do it and it worked for me


       Go to about:config?filter=general.*.override.
       Reset the following preferences:
       general.appversion.override
       general.oscpu.override
       general.platform.override
       general.useragent.override

thank you so much for all your help and helping me find out what add-on it was you guys are awesome

ok i found out how to do it and it worked for me Go to about:config?filter=general.*.override. Reset the following preferences: general.appversion.override general.oscpu.override general.platform.override general.useragent.override thank you so much for all your help and helping me find out what add-on it was you guys are awesome