X
Tap here to go to the mobile version of the site.

Support Forum

website dropdown menu not working in firefox 32bit 52.0.1 windows xp pro sp3

Posted

I am using firefox 32bit 52.0.1 windows xp pro sp3, i visit a website page ( https://www.utransto.com/en/topup/number/ ) but when i try to click on drop down country selection menu ... it is not working. Even i can't enter any number in that field and NEXT button is also not working.

Please check and fix this problem.

Waiting for your positive reply.

Thanks

I am using firefox 32bit 52.0.1 windows xp pro sp3, i visit a website page ( https://www.utransto.com/en/topup/number/ ) but when i try to click on drop down country selection menu ... it is not working. Even i can't enter any number in that field and NEXT button is also not working. Please check and fix this problem. Waiting for your positive reply. Thanks

Chosen solution

Based on your screenshot, I think the site's scripts are running at least partially. If scripts are completely blocked for the main domain, then you get a message that JavaScript needs to be enabled. If scripts are completely blocked from jquery.com then you don't even get a triangle in the box. (The site seems to work even if I block Google Analytics.)

To try to get a little more insight, and without saying that we would necessarily understand the results, could you check for error messages in Firefox's Web Console? That's a tool you can open in the lower part of the tab to view errors, warnings, and other messages during the loading and use of a page.

You can open the Web Console using any of these methods:

  • Ctrl+Shift+k
  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console

See the first screenshot to get an idea of what that would look like.

Then reload the page and the console should fill with messages. To reduce the clutter, you can hide style warnings. Unlike style errors, these usually do not indicate a severe problem but are directed at web developers who may find the page isn't laying out as expected. The second screenshot shows where the filter is.

What kind of messages do you see after that?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.1.0 for Mozilla browsers
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 25.0 r0
  • Npdsplay dll
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Helpful Reply

I didn't see any dropdown menu, but the page seems to be working.

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?

I didn't see any dropdown menu, but the page seems to be working. Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. Type '''about:preferences'''<enter> in the address bar. * '''Cookies; ''' Select '''Privacy. ''' Under '''History, ''' select Firefox will '''Use Custom Settings. ''' Press the button on the right side called '''Show Cookies. ''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache; ''' Select '''Advanced > Network. ''' Across from '''Cached Web Content, ''' Press '''Clear Now. ''' If there is still a problem, '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode]''' {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). While you are in safe mode; Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''General. ''' Look for and turn off '''Use Hardware Acceleration. ''' Then restart. Poke around safe websites. Are there any problems?

Question owner

please go to this url and https://www.utransto.com/en/topup/number/

drop down menu is front of words ==>> " Choose country and type in number: "

it is not working on my side with windows xp 32bit firefox... but website owner said it is working perfectly. and i checked with windows 7 it is working.

also see the attach pic

please go to this url and https://www.utransto.com/en/topup/number/ drop down menu is front of words ==>> " Choose country and type in number: " it is not working on my side with windows xp 32bit firefox... but website owner said it is working perfectly. and i checked with windows 7 it is working. also see the attach pic
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Have you done what I said above?

Have you done what I said above?

Question owner

Yes i did all , Same as you describe.. but problem is still persist :(

Yes i did all , Same as you describe.. but problem is still persist :(
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Update your Flash Player Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 26.0.0.151

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Update your Flash Player '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 26.0.0.151 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

i just update my flash player to latest version but problem still persist.  :(

i just update my flash player to latest version but problem still persist. :(
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history

Remove History For One Site

Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right-click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings.

Question owner

Did it , Site removed from history... But problem still not solved :(

Did it , Site removed from history... But problem still not solved :(
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

I called for more help.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I called for more help. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?
Happy112 561 solutions 5694 answers

Hi   !

Did you also check to see if your graphics drivers need to be updated, like FredMcD suggested earlier :

https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

You could do this first :

3-bar menu (or 'Tools') => Options => Advanced => General tab : uncheck 'Use hardware acceleration when available'.

Hi &nbsp; ! Did you also check to see if your graphics drivers need to be updated, like FredMcD suggested earlier : https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration You could do this first : 3-bar menu (or 'Tools') => Options => Advanced => General tab : '''un'''check 'Use hardware acceleration when available'.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content. *make sure your extensions and filters are updated to the latest version ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies" Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems

Question owner

i restart in safe mode , also disable hardware acceleration and i use default firefox theme, and my graphics driver are up to date.

But problem is still persist. :(

i restart in safe mode , also disable hardware acceleration and i use default firefox theme, and my graphics driver are up to date. But problem is still persist. :(
Happy112 561 solutions 5694 answers

ffuserman said

i restart in safe mode , also disable hardware acceleration and i use default firefox theme, and my graphics driver are up to date. But problem is still persist. :(

What's your reaction to the first part of cor-el's post  ? This could very well be script related ......

''ffuserman [[#answer-1000087|said]]'' <blockquote> i restart in safe mode , also disable hardware acceleration and i use default firefox theme, and my graphics driver are up to date. But problem is still persist. :( </blockquote> What's your reaction to the first part of cor-el's post ? This could very well be script related ......
jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

Chosen Solution

Based on your screenshot, I think the site's scripts are running at least partially. If scripts are completely blocked for the main domain, then you get a message that JavaScript needs to be enabled. If scripts are completely blocked from jquery.com then you don't even get a triangle in the box. (The site seems to work even if I block Google Analytics.)

To try to get a little more insight, and without saying that we would necessarily understand the results, could you check for error messages in Firefox's Web Console? That's a tool you can open in the lower part of the tab to view errors, warnings, and other messages during the loading and use of a page.

You can open the Web Console using any of these methods:

  • Ctrl+Shift+k
  • "3-bar" menu button > Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console

See the first screenshot to get an idea of what that would look like.

Then reload the page and the console should fill with messages. To reduce the clutter, you can hide style warnings. Unlike style errors, these usually do not indicate a severe problem but are directed at web developers who may find the page isn't laying out as expected. The second screenshot shows where the filter is.

What kind of messages do you see after that?

Based on your screenshot, I think the site's scripts are running at least partially. If scripts are completely blocked for the main domain, then you get a message that JavaScript needs to be enabled. If scripts are completely blocked from jquery''.''com then you don't even get a triangle in the box. (The site seems to work even if I block Google Analytics.) To try to get a little more insight, and without saying that we would necessarily understand the results, could you check for error messages in Firefox's Web Console? That's a tool you can open in the lower part of the tab to view errors, warnings, and other messages during the loading and use of a page. You can open the Web Console using any of these methods: * Ctrl+Shift+k * "3-bar" menu button > Developer > Web Console * (menu bar) Tools > Web Developer > Web Console See the first screenshot to get an idea of what that would look like. Then reload the page and the console should fill with messages. To reduce the clutter, you can hide style warnings. Unlike style errors, these usually do not indicate a severe problem but are directed at web developers who may find the page isn't laying out as expected. The second screenshot shows where the filter is. What kind of messages do you see after that?

Modified by jscher2000

jscher2000
  • Top 10 Contributor
8688 solutions 71014 answers

One other thing. Could you double-check that you are on the "Extended Support Release" channel? It's an alternate version of Firefox 52 that is backwards compatible with Windows XP and Windows Vista. You should be able to confirm that from the " Application Basics" table on the Troubleshooting Information page. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, there should be a row for "Update Channel" and there may also be an "esr" after your version number.

The latest release in the series actually is 52.3.0esr, but I don't know if any important bug fixes were made between Firefox 52.0.1esr and 52.3.0esr (probably mostly security updates).

If you do need to update, the standard method is described in this article: Update Firefox to the latest release.

One other thing. Could you double-check that you are on the "Extended Support Release" channel? It's an alternate version of Firefox 52 that is backwards compatible with Windows XP and Windows Vista. You should be able to confirm that from the " Application Basics" table on the Troubleshooting Information page. Either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, there should be a row for "Update Channel" and there may also be an "esr" after your version number. The latest release in the series actually is 52.3.0esr, but I don't know if any important bug fixes were made between Firefox 52.0.1esr and 52.3.0esr (probably mostly security updates). If you do need to update, the standard method is described in this article: [[Update Firefox to the latest version]].
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

You can also see the update channel in the "Help -> About Firefox" window

You can also see the update channel in the "Help -> About Firefox" window

Question owner

wow finally jscher2000 solved the issue , when i inspects element and click on Console i saw a error message.

" Error: No country data for 'pk' "

it means menu not works for traffic from Pakistan. i clear cookies then i use online SSL proxy to visit same page then it works perfectly.

Many Many thanks for helping me in this issue....

Now i have to request with website owner to add Pakistan in there menu data.

Again Thanks Very much to all Contributors in this Post.

wow finally jscher2000 solved the issue , when i inspects element and click on Console i saw a error message. " Error: No country data for 'pk' " it means menu not works for traffic from Pakistan. i clear cookies then i use online SSL proxy to visit same page then it works perfectly. Many Many thanks for helping me in this issue.... Now i have to request with website owner to add Pakistan in there menu data. Again Thanks Very much to all Contributors in this Post.
cor-el
  • Top 10 Contributor
  • Moderator
17468 solutions 157853 answers

What is the order of the installed languages?

If 'pk' is the first in the list then try to set 'en' as the first.

You can check the order of the installed languages.

  • Options/Preferences -> Content -> Languages
What is the order of the installed languages? If 'pk' is the first in the list then try to set 'en' as the first. You can check the order of the installed languages. *Options/Preferences -> Content -> Languages