X
Tap here to go to the mobile version of the site.

Support Forum

Colors inconsistent/inaccurate

Posted

Weirdest thing. Suddenly noticed that colors are displaying incorrectly in Firefox (and Chrome FWIW) but fine in Microsoft Edge and other apps like Corel where created.

Screen cap is attached. Firefox display on the left, Edge display on the right. Might be hard to see on another monitor but using something like colorcop (colorcop.net) you'll note how the solid blue areas in Chrome are more purple than they should be.

To be exact, blue in Firefox is hex #25107E. In Edge it is #121D82 which is what it should be.

Any help or advice would be greatly appreciated.

Regards.

Weirdest thing. Suddenly noticed that colors are displaying incorrectly in Firefox (and Chrome FWIW) but fine in Microsoft Edge and other apps like Corel where created. Screen cap is attached. Firefox display on the left, Edge display on the right. Might be hard to see on another monitor but using something like colorcop (colorcop.net) you'll note how the solid blue areas in Chrome are more purple than they should be. To be exact, blue in Firefox is hex #25107E. In Edge it is #121D82 which is what it should be. Any help or advice would be greatly appreciated. Regards.
Attached screenshots

Chosen solution

In your Corel product, are you assigning a color space?

I think by default Firefox will use the sRGB color space for images, but if a color space is designated, it may behave somewhat differently.

You could try adjusting Firefox's color management settings. This is an old write-up, but I haven't heard about any changes since then:

By default, Firefox will try to color manage tagged images (JPEGs and PNGs). You can review and experiment with the following preferences to see whether one of them is causing the problem:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx.c and pause while the list is filtered

gfx.color_management.mode - governs application of color management to images

  • 0 = off
  • 1 = on for ALL images
  • 2 = on for TAGGED images (default)

I can't recall whether you need to quit/restart Firefox before this change, or changes to the below preferences, takes effect.

gfx.color_management.display_profile - if you have created a custom monitor profile and Firefox is not using it, you can enter the path to it here.

gfx.color_management.enablev4 - double-click to toggle to true if your custom monitor profile is an ICC v4 profile

gfx.color_management.rendering_intent - whether Firefox honors or overrides the intent flag in the ICC profile, by default, overrides to Perceptual

For details, see: https://developer.mozilla.org/Firefox/Releases/3.5/ICC_color_correction_in_Firefox

Can you find a combination of settings that gives you the colors you expect? Depending on your results, and whether you are publishing these images on the web, you might need to revise how Corel deals with color spaces.

Read this answer in context 2

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.101 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
7925 solutions 64688 answers

Chosen Solution

In your Corel product, are you assigning a color space?

I think by default Firefox will use the sRGB color space for images, but if a color space is designated, it may behave somewhat differently.

You could try adjusting Firefox's color management settings. This is an old write-up, but I haven't heard about any changes since then:

By default, Firefox will try to color manage tagged images (JPEGs and PNGs). You can review and experiment with the following preferences to see whether one of them is causing the problem:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste gfx.c and pause while the list is filtered

gfx.color_management.mode - governs application of color management to images

  • 0 = off
  • 1 = on for ALL images
  • 2 = on for TAGGED images (default)

I can't recall whether you need to quit/restart Firefox before this change, or changes to the below preferences, takes effect.

gfx.color_management.display_profile - if you have created a custom monitor profile and Firefox is not using it, you can enter the path to it here.

gfx.color_management.enablev4 - double-click to toggle to true if your custom monitor profile is an ICC v4 profile

gfx.color_management.rendering_intent - whether Firefox honors or overrides the intent flag in the ICC profile, by default, overrides to Perceptual

For details, see: https://developer.mozilla.org/Firefox/Releases/3.5/ICC_color_correction_in_Firefox

Can you find a combination of settings that gives you the colors you expect? Depending on your results, and whether you are publishing these images on the web, you might need to revise how Corel deals with color spaces.

In your Corel product, are you assigning a color space? I think by default Firefox will use the sRGB color space for images, but if a color space is designated, it may behave somewhat differently. You could try adjusting Firefox's color management settings. This is an old write-up, but I haven't heard about any changes since then: By default, Firefox will try to color manage tagged images (JPEGs and PNGs). You can review and experiment with the following preferences to see whether one of them is causing the problem: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''gfx.c''' and pause while the list is filtered '''gfx.color_management.mode''' - governs application of color management to images * 0 = off * 1 = on for ALL images * 2 = on for TAGGED images (default) ''I can't recall whether you need to quit/restart Firefox before this change, or changes to the below preferences, takes effect.'' '''gfx.color_management.display_profile''' - if you have created a custom monitor profile and Firefox is not using it, you can enter the path to it here. '''gfx.color_management.enablev4''' - double-click to toggle to true if your custom monitor profile is an ICC v4 profile '''gfx.color_management.rendering_intent''' - whether Firefox honors or overrides the intent flag in the ICC profile, by default, overrides to Perceptual ''For details, see:'' https://developer.mozilla.org/Firefox/Releases/3.5/ICC_color_correction_in_Firefox Can you find a combination of settings that gives you the colors you expect? Depending on your results, and whether you are publishing these images on the web, you might need to revise how Corel deals with color spaces.

Question owner

jscher2000 that was brilliant.

Turns out that I didn't have to change gfx.color_management.mode. But you got me checking color space things and found that I was exporting images out of CorelDRAW with "Embed color profile" activated. When I unchecked, the exported PNG file was the color it was supposed to be.

So, whether you like it or not, and certainly for the time being, you da man.

Thanks!

jscher2000 that was brilliant. Turns out that I didn't have to change gfx.color_management.mode. But you got me checking color space things and found that I was exporting images out of CorelDRAW with "Embed color profile" activated. When I unchecked, the exported PNG file was the color it was supposed to be. So, whether you like it or not, and certainly for the time being, you da man. Thanks!
211ssw 0 solutions 6 answers

I used 'Colorful tabs' but had an issue with my PC & they deleted that after saying that 'Colorful Tabs' couldn't be verified. How do I get setup with tabs that show-up as separate tabs & I assume set apart by color?

I need those immediately as I cannot easily tell one tab from another! Does a different add-on do a similar job? Naturally I need that information asap.

I used 'Colorful tabs' but had an issue with my PC & they deleted that after saying that 'Colorful Tabs' couldn't be verified. How do I get setup with tabs that show-up as separate tabs & I assume set apart by color? I need those immediately as I cannot easily tell one tab from another! Does a different add-on do a similar job? Naturally I need that information asap.
jscher2000
  • Top 10 Contributor
7925 solutions 64688 answers

Hi 211ssw, that sounds like a very different issue, so if this quick suggestion doesn't help, please start a new question. You can do that at the following link:

https://support.mozilla.org/questions/new/desktop/customize

Scroll down past the article suggestions to continue with the form.

What version of Firefox are you running? When I visit the page in Firefox 55, there's no indication of a problem: https://addons.mozilla.org/firefox/addon/colorfultabs/

Hi 211ssw, that sounds like a very different issue, so if this quick suggestion doesn't help, please start a new question. You can do that at the following link: https://support.mozilla.org/questions/new/desktop/customize Scroll down past the article suggestions to continue with the form. What version of Firefox are you running? When I visit the page in Firefox 55, there's no indication of a problem: https://addons.mozilla.org/firefox/addon/colorfultabs/