X
Tap here to go to the mobile version of the site.

Support Forum

Mozilla support website language fallback

Posted

Mozilla support website does not seem to respect the language preference order when a page is not available in the most preferred language and fallback to another language occurs.

I have configured the following order in my browser: Estonian [et], English [en], Russian [ru], German [de]. When I go to https://support.mozilla.org/et/kb/get-community-support?redirectlocale=et&redirectslug=K%C3%BCsimuse+postitamine, I get the page in Russian, not in English, though English is higher in my language preference list and the page does exist in English.

Even the note on the top of the Russian page shown advertises the English version "This page does not exist in eesti keel. You have been redirected to the Русский version instead. If you would like to localize it into eesti keel, click here. You can also see the English version of this page."

Mozilla support website does not seem to respect the language preference order when a page is not available in the most preferred language and fallback to another language occurs. I have configured the following order in my browser: Estonian [et], English [en], Russian [ru], German [de]. When I go to https://support.mozilla.org/et/kb/get-community-support?redirectlocale=et&redirectslug=K%C3%BCsimuse+postitamine, I get the page in Russian, not in English, though English is higher in my language preference list and the page does exist in English. Even the note on the top of the Russian page shown advertises the English version "This page does not exist in eesti keel. You have been redirected to the Русский version instead. If you would like to localize it into eesti keel, click here. You can also see the English version of this page."
Attached screenshots

Chosen solution

Try adding English/United States [en-US] and put that above [en]. The [en] locale setting is just skipped for this website, and possibly a number of others. It may also solve your other question.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

Pkshadow
  • Top 10 Contributor
228 solutions 2392 answers

Please combine this with your other post. https://support.mozilla.org/en-US/questions/1168916 Language of Wikipedia searches chosen seemingly at random

Do not post here. Flagged for deletion, duplicate question,

Please combine this with your other post. https://support.mozilla.org/en-US/questions/1168916 Language of Wikipedia searches chosen seemingly at random Do not post here. Flagged for deletion, duplicate question,
Was this helpful to you?
Quote

Question owner

I have no reason to think these are the same problem. If you do, can you outline your thinking?

As far as I can see, the support website issue is purely HTTP content-language negotiation between the browser and the web server, and the server for some reason preferring to serve the language of my third preference over my second preference. If there were such a category, I would have filed this question under "Mozilla website".

The Wikipedia search issue, on the other hand seems to me to be more within the browser, as going to Wikipedia's language-neutral front page (https://www.wikipedia.org/) and doing any searches there I seem to consistently get the Estonian version (my first preferred language).

I have no reason to think these are the same problem. If you do, can you outline your thinking? As far as I can see, the support website issue is purely HTTP content-language negotiation between the browser and the web server, and the server for some reason preferring to serve the language of my third preference over my second preference. If there were such a category, I would have filed this question under "Mozilla website". The Wikipedia search issue, on the other hand seems to me to be more within the browser, as going to Wikipedia's language-neutral front page (https://www.wikipedia.org/) and doing any searches there I seem to consistently get the Estonian version (my first preferred language).
Was this helpful to you?
Quote
Tonnes
  • Top 25 Contributor
  • Locale Leader
177 solutions 1025 answers

Chosen Solution

Try adding English/United States [en-US] and put that above [en]. The [en] locale setting is just skipped for this website, and possibly a number of others. It may also solve your other question.

Try adding ''English/United States [en-US]'' and put that above [en]. The [en] locale setting is just skipped for this website, and possibly a number of others. It may also solve your other question.
Was this helpful to you? 1
Quote

Question owner

Thank you, Tonnes. Adding "English/United States [en-US]" did the trick for the Mozilla website. No dice with the Wikipedia search, though.

Thank you, Tonnes. Adding "English/United States [en-US]" did the trick for the Mozilla website. No dice with the Wikipedia search, though.

Modified by ahto

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.