X
Tap here to go to the mobile version of the site.

Support Forum

Language of Wikipedia searches chosen seemingly at random

Posted

I have defined multiple languages in my Firefox content preferences. Now, when I use the !w keyword in the search bar for Wikipedia searches, the language version of Wikipedia is chosen seemingly at random. Observe the two screenshots attached where nothing was changed between the two searches except the word to search for. Still one of the searches was made in English Wikipedia and the other in Estonian Wikipedia. And, per Murphy's law, each of them went to the wrong version (the English query to the Estonian site and the Estonian query to the English site). I could live with the searches going either way as long as it's consistent (then I would know how to write my queries). As it stands now it's almost unusable. Firefox 54.0.1 (32-bit) with English UI. Windows 7 Pro SP1 (64-bit) with English UI, in case that matters.

I have defined multiple languages in my Firefox content preferences. Now, when I use the !w keyword in the search bar for Wikipedia searches, the language version of Wikipedia is chosen seemingly at random. Observe the two screenshots attached where nothing was changed between the two searches except the word to search for. Still one of the searches was made in English Wikipedia and the other in Estonian Wikipedia. And, per Murphy's law, each of them went to the wrong version (the English query to the Estonian site and the Estonian query to the English site). I could live with the searches going either way as long as it's consistent (then I would know how to write my queries). As it stands now it's almost unusable. Firefox 54.0.1 (32-bit) with English UI. Windows 7 Pro SP1 (64-bit) with English UI, in case that matters.
Attached screenshots

Chosen solution

On the "Options/Preferences -> Search" page you can double-click in the keyword column next to a specific search engine to set or modify this keyword.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
15592 solutions 141164 answers

Helpful Reply

What is the order of the installed languages?

  • Options/Preferences -> Content -> Languages

Do you only get languages that show in this list? Does this also happen if you only set one language?


You can save a backup of the intl.accept_languages pref that you can find on the about:config page if you want to be able to restore the installed languages list.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

What is the order of the installed languages? *Options/Preferences -> Content -> Languages Do you only get languages that show in this list? Does this also happen if you only set one language? ---- You can save a backup of the <b>intl.accept_languages</b> pref that you can find on the <b>about:config</b> page if you want to be able to restore the installed languages list. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you? 3
Quote

Question owner

Hi, the language preferences are Estonian [et], English [en], Russian [ru], German [de]. So far I have only seen Wikipedia in the two first languages, never the two last ones or any other. Will try reducing the list to just one language and get back to you with the results.

Hi, the language preferences are Estonian [et], English [en], Russian [ru], German [de]. So far I have only seen Wikipedia in the two first languages, never the two last ones or any other. Will try reducing the list to just one language and get back to you with the results.
Was this helpful to you?
Quote

Question owner

With English the only language in the accepted list, queries for both 'maa' and 'earth' went to English Wikipedia. However, with Estonian the only language, still the query for 'maa' went to English Wikipedia, so it seems in case of non-English preference, even reducing the list to one language does not guarantee stable results.

With English the only language in the accepted list, queries for both 'maa' and 'earth' went to English Wikipedia. However, with Estonian the only language, still the query for 'maa' went to English Wikipedia, so it seems in case of non-English preference, even reducing the list to one language does not guarantee stable results.
Was this helpful to you?
Quote

Question owner

It seems to me the issue is between the browser core and the search engine interface, as going to Wikipedia's language-neutral front page (https://www.wikipedia.org/) and doing any searches there I seem to consistently get the Estonian version (my first preferred language).

It seems to me the issue is between the browser core and the search engine interface, as going to Wikipedia's language-neutral front page (https://www.wikipedia.org/) and doing any searches there I seem to consistently get the Estonian version (my first preferred language).
Was this helpful to you?
Quote

Question owner

Is there a way to split the !w keyword into two, one for English and one for Estonian Wikipedia? I do have both of these defined as custom search engines and when using mouse to select one of them after typing the query, the results are consistent. However, I haven't found a way to define my own search bar keywords. Have looked in both Options -> Search and also in about:config.

Is there a way to split the !w keyword into two, one for English and one for Estonian Wikipedia? I do have both of these defined as custom search engines and when using mouse to select one of them after typing the query, the results are consistent. However, I haven't found a way to define my own search bar keywords. Have looked in both Options -> Search and also in about:config.
Was this helpful to you?
Quote
Josh Ross 12 solutions 143 answers

It could also be an issue with your system's language. If Localization settings are set to either Estonia or English, but your settings are set the opposite, you might have had issues this way. I know I had, especially when traveling to other places. It sets localization language to the native one and it becomes a mess to deal with. See if this helps you.

It could also be an issue with your system's language. If Localization settings are set to either Estonia or English, but your settings are set the opposite, you might have had issues this way. I know I had, especially when traveling to other places. It sets localization language to the native one and it becomes a mess to deal with. See if this helps you.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15592 solutions 141164 answers

Chosen Solution

On the "Options/Preferences -> Search" page you can double-click in the keyword column next to a specific search engine to set or modify this keyword.

On the "Options/Preferences -> Search" page you can double-click in the keyword column next to a specific search engine to set or modify this keyword.
Was this helpful to you? 1
Quote

Question owner

Thank you, cor-el, that helps some.

A heads-up to those reading the thread later: the keywords seem to work on the location bar, but not on the search bar. And the keyword needs to be used as-is on the location bar (that is, do not prefix it with the exclamation mark, like you would to switch between the built-in engines on the search bar).

Thank you, cor-el, that helps some. A heads-up to those reading the thread later: the keywords seem to work on the location bar, but not on the search bar. And the keyword needs to be used as-is on the location bar (that is, do not prefix it with the exclamation mark, like you would to switch between the built-in engines on the search bar).
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
15592 solutions 141164 answers

Helpful Reply

You can't use a keyword on the search bar, a keyword only works in the location/address bar because you want to open a web page and pass parameters to this website. The keyword is only an alias (shortcut) for this URL. For the search bar you will have to select the search engine in the list that shows in the drop-down list if you do not want to use the default search engine.

You can't use a keyword on the search bar, a keyword only works in the location/address bar because you want to open a web page and pass parameters to this website. The keyword is only an alias (shortcut) for this URL. For the search bar you will have to select the search engine in the list that shows in the drop-down list if you do not want to use the default search engine.
Was this helpful to you? 2
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.