X
Tap here to go to the mobile version of the site.

Support Forum

how to disable a adblock which is not showing in addons or extension

Posted

a website shows to disable adblock but the adblock i cant find in addons or in extension , how to find it . are there any other hidden extensions

a website shows to disable adblock but the adblock i cant find in addons or in extension , how to find it . are there any other hidden extensions

Additional System Details

Installed Plug-ins

  • Shockwave Flash 26.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

jscher2000
  • Top 10 Contributor
8632 solutions 70597 answers

Firefox doesn't automatically install any ad blocking extensions. Do you have kind of content filtering/blocking extensions on the Add-ons page? Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side... If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox before the change takes effect. You can complete your work on the tab and click one of the links as the last step.


Firefox's Tracking Protection feature may appear to websites to be similar to an ad blocker. This article has more information on where to spot the shield icon for this feature in the address bar, and how to manage it: What happened to Tracking Protection?.

Firefox doesn't automatically install any ad blocking extensions. Do you have kind of content filtering/blocking extensions on the Add-ons page? Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Extensions. Then cast a critical eye over the list on the right side... If in doubt, disable. Often a link will appear above at least one disabled extension to restart Firefox before the change takes effect. You can complete your work on the tab and click one of the links as the last step. ---- Firefox's Tracking Protection feature may appear to websites to be similar to an ad blocker. This article has more information on where to spot the shield icon for this feature in the address bar, and how to manage it: [[Tracking Protection in Private Browsing]].

Question owner

no i'm still not finding the adblock. how to locate i'm guessing to download a security addon. is it blocking ...im still cant find that also

no i'm still not finding the adblock. how to locate i'm guessing to download a security addon. is it blocking ...im still cant find that also
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

You can check the Web Console (Tools -> Web Developer) for error messages about blocked and unsafe and mixed content.

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

Use "Ctrl+F5" or "Ctrl+Shift+R" to reload the page and bypass the cache to generate a fresh log.

Note that this might be about blocked cookies or local storage, so maybe try to enable third-party cookies as a test.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
You can check the Web Console (Tools -> Web Developer) for error messages about blocked and unsafe and mixed content. *https://developer.mozilla.org/Tools/Web_Console You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/Tools/Network_Monitor Use "Ctrl+F5" or "Ctrl+Shift+R" to reload the page and bypass the cache to generate a fresh log. Note that this might be about blocked cookies or local storage, so maybe try to enable third-party cookies as a test. ---- You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies" Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Happy112 561 solutions 5694 answers

From your question I understand that a website is asking you to disable the adblocker that you don't even have installed.

If that's the case, removing cookies and clearing the cache, as suggested by 'cor-el', should solve the problem.

If you have an extension that turns off JavaScript, like NoScript (which is often used by advertisers to display ads), you could try and disable it and see if that makes a difference.

Make sure that JavaScript is enabled : Type in the address bar about:config (press Enter) (promise to be careful, if asked) Type and look for the preference : javascript.enabled the value should be set to true

From your question I understand that a website is asking you to disable the adblocker that you don't even have installed. If that's the case, removing cookies and clearing the cache, as suggested by 'cor-el', should solve the problem. If you have an extension that turns off JavaScript, like NoScript (which is often used by advertisers to display ads), you could try and disable it and see if that makes a difference. Make sure that JavaScript is enabled : Type in the address bar '''about:config''' (press Enter) (promise to be careful, if asked) Type and look for the preference : '''javascript.enabled''' the value should be set to '''true'''

Modified by Happy112

MonsterHunter189 0 solutions 1 answers

The newer versions of firefox have adblockers included (not listed), the only way i can think of disabling it is looking in about:config

The newer versions of firefox have adblockers included (not listed), the only way i can think of disabling it is looking in about:config
jscher2000
  • Top 10 Contributor
8632 solutions 70597 answers

Hi MonsterHunter189, the only built-in feature I can think of that may block ads is Tracking Protection. I posted more about that in your question here: https://support.mozilla.org/questions/1176020

Hi MonsterHunter189, the only built-in feature I can think of that may block ads is Tracking Protection. I posted more about that in your question here: https://support.mozilla.org/questions/1176020
dcfavero 0 solutions 1 answers

My problem was Kaspersky Anti-Banner. Firefox had no indication because the extension was disabled, nor did my PC (until you dig down as below). NOTE I am finding that this solves the problem on some sites, not all.

It can be fixed by partially or fully disabling Kaspersky Anti-Banner. --Windows 10 TO disable Anti Banner for a site in Kaspersky:

  • Settings > Protection > Anti Banner
  • Websites with Allowed Banners > Add
  • Add sites with issue

OR turn Kaspersky Anti-Banner completely off

  • Settings > Protection > Anti Banner > OFF

--IF Firefox Kaspersky Protection extension is enabled - green hexagon in Toolbar

  • Click on icon
  • Click on Anti-Banner drop down
  • Select Allow on this Website OR Disable Anti-Banner

If you do have an adblocker, you may have to both disable Kaspersky Anti Banner for the problem site AND disable the AdBlocker on the site to clear the site's request to disable your AdBlocker.

I tried a number of the proposed solutions before finding this fix. Listing those steps here for information. There are a large number of potential fixes with no easy way to know which will solve the problem.

  • disabled AdblockPlus & eventually uninstalled it along with accompanying refreshes, reboots - no help
  • installed Ublock Origin just in case it might illogically fix it - no help
  • cleared cache & cookies
  • disabled Firefox tracking

I will stay with Ublock Origin unless I run into a problem.

I also found a help article on the AdBlock site that lists all or most of the solutions here (but not Kaspersky) along with a few more potentials you might want to check out: link text

My problem was Kaspersky Anti-Banner. Firefox had no indication because the extension was disabled, nor did my PC (until you dig down as below). NOTE I am finding that this solves the problem on some sites, not all. It can be fixed by partially or fully disabling Kaspersky Anti-Banner. --Windows 10 TO disable Anti Banner for a site in Kaspersky: * Settings > Protection > Anti Banner * Websites with Allowed Banners > Add * Add sites with issue OR turn Kaspersky Anti-Banner completely off * Settings > Protection > Anti Banner > OFF --IF Firefox Kaspersky Protection extension is enabled - green hexagon in Toolbar * Click on icon * Click on Anti-Banner drop down * Select Allow on this Website OR Disable Anti-Banner If you do have an adblocker, you may have to both disable Kaspersky Anti Banner for the problem site AND disable the AdBlocker on the site to clear the site's request to disable your AdBlocker. I tried a number of the proposed solutions before finding this fix. Listing those steps here for information. There are a large number of potential fixes with no easy way to know which will solve the problem. * disabled AdblockPlus & eventually uninstalled it along with accompanying refreshes, reboots - no help * installed Ublock Origin just in case it might illogically fix it - no help * cleared cache & cookies * disabled Firefox tracking I will stay with Ublock Origin unless I run into a problem. I also found a help article on the AdBlock site that lists all or most of the solutions here (but not Kaspersky) along with a few more potentials you might want to check out: [https://help.getadblock.com/support/solutions/articles/6000161397-i-turned-off-adblock-but-a-site-still-asks-me-to-turn-off-my-ad-blocker link text]