Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open hyperlinks in firefox

  • 15 replies
  • 40 have this problem
  • 15596 views
  • Last reply by tlburnett

more options

My wife is using Windows 10 and Firefox 54.0. Three days ago I updated her Firefox from 32-bit to 64-bit. Apparently since then she has not been able to open hyperlinks.

Error message: "This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator."

Firefox is her default browser. Error message occurs with email hyperlinks as well as hyperlinks in standalone documents. Setting Internet Explorer as the default browser has no effect. Accessing a website using IE and clicking on a hyperlink does work.

Side note: For various reasons having to do with certain apps, I use Windows 8.1 on my desktop and laptop. Both have Firefox 54.0 64-bit. I updated to 64-bit about 2 months ago with no problems.

Is this a Firefox problem?

Chosen solution

Windows 10 definitely has an idiosyncratic way of handling default applications. The other thread was on Windows 7, though, so it might be good advice for all users.

Read this answer in context 👍 0

All Replies (15)

more options

Found the solution myself.

https://www.slipstick.com/problems/this-operation-has-been-cancelled-due-to-restrictions/#reg2

Problem is a combination of Windows 10, Chrome, Firefox and IE. As stated, "If you uninstalled Chrome (or Firefox) and then received the error, see Edit Registry, Part 2. Thanks to Adobe Flash and other application updates installing Chrome by default, this is by far the most common cause. "

Taking the steps from above, in order (I restarted between each step) and making the registry changes solved the problem.

I do believe that the instructions on how to switch from 32-bit to 64-bit Firefox (https://support.mozilla.org/t5/Install-and-Update/How-to-switch-from-32-bit-to-64-bit-Firefox/ta-p/36215) should be modified with a warning to include this problem.

more options

AIVAS1701 said

I do believe that the instructions on how to switch from 32-bit to 64-bit Firefox (https://support.mozilla.org/t5/Install-and-Update/How-to-switch-from-32-bit-to-64-bit-Firefox/ta-p/36215) should be modified with a warning to include this problem.

Yes, this just came up the other day from another user who encountered the same problem, so the time is right for an update. (Upgraded to latest 64bit. Now Hyperlinks from MS-Outlook blocked. How to unblock?)

The article has an "Editing Tools" list in the left column, but I don't know if it's available to all registered users or requires special permissions to edit. Instead of directly editing the article, you can post a suggestion on the article's discussion forum at https://support.mozilla.org/kb/switch-32-bit-64-bit/discuss.

Since you are familiar with this problem, what would you suggest for wording? Here's something to get you started:


Users of Microsoft Office Outlook: Before changing from 32-bit Firefox to 64-bit Firefox, it is recommended to temporarily change your default browser to Internet Explorer. You can change it back to Firefox after the change. This is important to avoid problems opening links from messages in Outlook.

See:

If you skipped this step and encounter errors along the lines of "This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator.", you can find a help page here: This operation has been cancelled due to restrictions.


(Note: If you quote this reply using the Quote link below this post, and delete the <blockquote> tags, you can more easily revise the text and keep the formatting.)

more options

I like what you wrote and would like to use it but I wonder if part of the problem is Windows 10.

As I said, I upgraded my desktop and laptop with no problems. Both are running Windows 8.1. My desktop and my wife's desktop are pretty much identical (ignoring the O/S and personal software/files). I'm responsible for maintaining everything here.

more options

Chosen Solution

Windows 10 definitely has an idiosyncratic way of handling default applications. The other thread was on Windows 7, though, so it might be good advice for all users.

more options

I approved a revision to the article How to switch from 32-bit to 64-bit Firefox to add a warning for users of Microsoft Outlook, using the wording and links suggested above by jscher2000.

more options

^: Wouldn't that be Edge for most Windows 10 users (is IE still available in Win10)?

(Edge or Internet Explorer)

more options

Internet Explorer is still available for Windows 10 but Edge is the default browser. I don't have Windows 10 but the article How to change your default browser in Windows 10 includes this screenshot:

firefox default 10
more options

To jscher2000 and AIVAS1701

The Make Firefox your default browser article's section, "Use the Settings app in Windows 10 to change your default browser" explains how to change the default browser on Windows 10. I'm wondering if we should point Windows 10 users to those instructions instead of linking to Microsoft's Make Internet Explorer your default browser article, which states at the bottom that it applies to Windows 7 and Windows 8.1.

See this answers.microsoft thread. I don't know if Windows 10 users would even know how to open Internet Explorer to set it as the default. We should probably continue this in the discussion thread I started at https://support.mozilla.org/en-US/kb/switch-32-bit-64-bit/discuss/7073

more options

The obvious change would be "...it is recommended to temporarily change your default browser to Internet Explorer or Edge."

I haven't tested this with Edge (I'm not a fan of Windows 10 or Edge). We do know this has happened with Windows 7 and Windows 8. Is this a problem with all versions of Windows? Does it require changing the default browser to something else? Or always to IE? Or just a Windows product (I'm leaning towards this)?

On the other hand, if a Windows 10 user can not find IE, could/would they be making the change to 64-bit? Or if the change goes south, could they make the registry changes?

more options

I made a new revision to the article How to switch from 32-bit to 64-bit Firefox to take Windows 10 users into account.

AIVAS1701, I don't understand your question, On the other hand, if a Windows 10 user can not find IE, could/would they be making the change to 64-bit?

more options

RE: "AIVAS1701, I don't understand your question, On the other hand, if a Windows 10 user can not find IE, could/would they be making the change to 64-bit?"

I simply questioned whether the average Windows 10 (or actually any version) user (emphasis on "user" would be looking to change from 32-bit to 64-bit, or would they have someone do it for them.

more options

Reinstalled crashing FF 54.0.1 twice since Friday, as I got the error today: "this operation has been canceled due to restrictions in effect on this computer."

Firefox is and has been my default browser for a decade. Is this version buggy? (As I said, I reinstalled it on Friday and twice more today because I cannot open links from Outlook 2010/Windows 10.)

Using another browser is not an acceptable solution.

After spending 45 precious minutes on this, I fixed it with suggested Registry fix and restart.

Thank you.

Modified by CiaoBella1

more options

I had the same problem. It involves Windows 10, Firefox and IE.

See: https://support.mozilla.org/en-US/kb/switch-32-bit-64-bit

more options

I also had this problem with one variation: I didn't get an error message. Some time in the last few days clicking on links in Outlook emails just would not open the relevant sites in Firefox. I'm running Outlook 2010 on Windows 10.

I assume it began after I installed Firefox V. 56.0.2 (64 bit) on October 27th but cannot swear to that since I didn't make note of the day it started. I found a very simple fix after shying away from some of the other suggestions. Here's what I did:

1. Closed Firefox. 2. In Windows Settings/Apps/Default Apps, changed the Web browser default to Microsoft Edge. 3. Closed all other programs and restarted my laptop. 4. Opened Outlook, chose an email with a link and clicked on the link. It opened in Microsoft Edge as expected. 5. Closed Microsoft Edge. 6. In Settings/Apps/Default Apps, changed the Web browser default back to Firefox. 7. Clicked on the same link in the same email and it opened in Firefox. 8. Just to be sure, I clicked on a couple of other links in other emails and they all opened in Firefox. Hope this helps some people!

more options

It's definitely a FIREFOX problem, thanks to a recent version 57 upgrade (which I don't like AT ALL). I quickly went back to version 56, but my Excel hyperlinks still malfunctioned. Today, I ran across this gem on YouTube, and it solved my problem marvelously: https://www.youtube.com/watch?v=YlLg6OpkjZc

For whatever reason, Firefox 57 apparently changed all my default html value data settings in the Windows registry to "FirefoxHTML", which Excel could not accept. The above video shows how to change them back to "htmlfile", which I did. I then restarted by computer, loaded an Excel document with hyperlinks, and was very pleased to see them working again without any error messages!