Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browswer window not rendered properly when moving between monitors

  • 4 replies
  • 8 have this problem
  • 766 views
  • Last reply by cor-el

more options

I have an issue where when I move my browser window from monitor A to monitor B, the window renders as just a large white rectangle where the menu bar and tabs used to be, and a large black rectangle, where the window normally would be. To reproduce this effect, simply perform the following steps:

1) Launch browser and have it show up on monitor A. Note that everything is fine. 2) Move browser window to monitor B. Note everything is fine. 3) Move browser back to monitor A. Note that it does not render properly, just two rectangles and the minimize/maximize/close buttons.

No attempt to minimize/maximize or force the window to redraw seems to help. Only closing and restarting the browser causes a change.

The specifics of my setup: Windows 10 Pro 1703 build 16199.1000 Firefox version 53.0.3 (32-bit) Monitor A has a resolution of 3440x1440 (scaling at 100%) Monitor B has a resolution of 3480x2160 (scaling at 150%) They are configured as an Extended monitor

I will play around with the various settings to see if it is related to different scaling modes, etc. but thought I would simply write this up as an FYI. The Microsoft Edge browser does not show the same behavior, and renders properly regardless of which monitor it is on.

Chosen solution

Such issues are possibly related to hardware acceleration.

You can test this by (temporarily) disable this feature.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

Read this answer in context 👍 4

All Replies (4)

more options

Chosen Solution

Such issues are possibly related to hardware acceleration.

You can test this by (temporarily) disable this feature.

  • Options/Preferences -> Advanced -> General -> Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

more options

Can you try launching Firefox in Safe Mode and see if the problem persists?

Safe Mode is a special Firefox mode that can be used to troubleshoot and fix problems. Safe Mode temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes) that might be causing problems. By comparing Firefox behavior in normal mode to its behavior in Safe Mode you may be able to pinpoint the cause of the problem.

How to launch Firefox in Safe Mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#w_how-to-start-firefox-in-safe-mode

Let us know what you find out

more options

Thank you both for your prompt responses. Both solutions seem to resolve the issue. I first tried simply disabling Acceleration when available, and that did the trick.

The issue is also resolved if you launch the browser in Safe Mode (but with the Acceleration when enabled check box checked) and that also seemed to work just fine. I am not sure if running in Safe Mode has the effect of disabling the hardware acceleration flows in the browser or some other mechanism may be at play here, but nice to have an option.

I will go hunt for update the graphics drivers for my laptop and see if that does not help the issue.

Again, thanks for your help. Cheers!

more options

You're welcome.

In Firefox Safe Mode hardware acceleration is disabled, so that explain your findings.

When the monitors have different screen dimensions/resolution then hardware acceleration can possibly cause issues.