X
Tap here to go to the mobile version of the site.

Support Forum

Firefox causes audio glitches in Windows 7

Posted

When playing audio from any source -- WInamp or mp3directcut or any audio source I've tried -- loading complex pages in Firefox ALMOST ALWAYS causes audio clicks and glitches. Searching for images in Startpage Image Search with FF is a good test; it never fails to cause glitching.

However, using Chrome or Avast Safezone browser or Internet Explorer NEVER causes audio glitches.

Using FF in safe mode makes no difference. Switching from FF 64-bit to FF 32-bit makes no difference.

I'd prefer to use FF, but since I work with audio daily, I have had to stop using it.

When playing audio from any source -- WInamp or mp3directcut or any audio source I've tried -- loading complex pages in Firefox ALMOST ALWAYS causes audio clicks and glitches. Searching for images in Startpage Image Search with FF is a good test; it never fails to cause glitching. However, using Chrome or Avast Safezone browser or Internet Explorer NEVER causes audio glitches. Using FF in safe mode makes no difference. Switching from FF 64-bit to FF 32-bit makes no difference. I'd prefer to use FF, but since I work with audio daily, I have had to stop using it.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/58.0.3029.110 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4306 solutions 60464 answers

What's your computer system and Firefox version?


Update your Flash Player Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: 25.0.0.171

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

What's your computer system and Firefox version? ---------------- Update your Flash Player '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''25.0.0.171 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

Windows 7 i5 8GB, onboard audio and video, latest (53.0.3) versions of both 64- and 32-bit Firefox. I should add that this problem began around the time I upgraded Firefox to 64-bit about a month or so ago, but reverting to 32-bit now doesn't seem to help at all.

I just tried setting the disk cache to 0 bytes and then to 3600 Mb and noticed little or no difference in the glitches.

Windows 7 i5 8GB, onboard audio and video, latest (53.0.3) versions of both 64- and 32-bit Firefox. I should add that this problem began around the time I upgraded Firefox to 64-bit about a month or so ago, but reverting to 32-bit now doesn't seem to help at all. I just tried setting the disk cache to 0 bytes and then to 3600 Mb and noticed little or no difference in the glitches.

Question owner

Another strange aspect of this problem: When FF is running, it seems to do something strange with audio buffering. Whenever any audio file is played by any program, even my top-of-the-hour clock chime, I hear a few milliseconds of buffered audio at the beginning that appears to be from the end of whatever previous audio file was playing. This does not happen if FF is not running. Very weird! (In case it is relevant, I use Voicemeeter Banana to route and control my audio.)

Another strange aspect of this problem: When FF is running, it seems to do something strange with audio buffering. Whenever any audio file is played by any program, even my top-of-the-hour clock chime, I hear a few milliseconds of buffered audio at the beginning that appears to be from the end of whatever previous audio file was playing. This does not happen if FF is not running. Very weird! (In case it is relevant, I use Voicemeeter Banana to route and control my audio.)
FredMcD
  • Top 10 Contributor
4306 solutions 60464 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

Yes, as I said in my original post, safe mode makes no difference in the problem.

Yes, as I said in my original post, safe mode makes no difference in the problem.
FredMcD
  • Top 10 Contributor
4306 solutions 60464 answers

Helpful Reply

I called for more help.

I called for more help.

Question owner

Thank you!

Thank you!