X
Tap here to go to the mobile version of the site.

Support Forum

how can i change the default search engine?

Posted

how can i change the default search engine?

I have repeatedly set Default Search Engine to Google but Yahoo! keeps coming back -- how can I make Google the permanent default?

how can i change the default search engine? I have repeatedly set Default Search Engine to Google but Yahoo! keeps coming back -- how can I make Google the permanent default?

Chosen solution

McAfee could be an issue. When you're on the Options page, Search panel, and you check the default search engine setting at the top of the page, does it switch to the search plugin with the McAfee "M on a shield" icon, or the Yahoo "Y in a box" icon?

After disabling McAfee, did you exit out of Firefox and restart it to make sure it was fully disabled? That may be necessary to prevent it from repeatedly taking over your search engine setting.

Evernote should not be a problem.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
15347 solutions 139148 answers

You can check for recently installed suspicious or unknown extensions.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can check in "Windows Control Panel > Programs" for recently installed programs to see if any suspicious software shows up.

  • Control Panel > Programs > Programs and Features > Uninstall or change a program
  • click the Installed column to sort by this heading
You can check for recently installed suspicious or unknown extensions. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check in "Windows Control Panel > Programs" for recently installed programs to see if any suspicious software shows up. *Control Panel > Programs > Programs and Features > Uninstall or change a program *click the Installed column to sort by this heading
Was this helpful to you? 0
Quote
kathbaines 0 solutions 1 answers

You need to first provide complete information about the system your using for example windows or mac etc. After that may be better able to provide you with effective solutions. Also are you using the latest firefox version?

You need to first provide complete information about the system your using for example windows or mac etc. After that may be better able to provide you with effective solutions. Also are you using the latest firefox version?

Modified by kathbaines

Was this helpful to you? 0
Quote

Question owner

cor-el said

You can check for recently installed suspicious or unknown extensions. Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
You can check in "Windows Control Panel > Programs" for recently installed programs to see if any suspicious software shows up.
  • Control Panel > Programs > Programs and Features > Uninstall or change a program
  • click the Installed column to sort by this heading
''cor-el [[#answer-972797|said]]'' <blockquote> You can check for recently installed suspicious or unknown extensions. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check in "Windows Control Panel > Programs" for recently installed programs to see if any suspicious software shows up. *Control Panel > Programs > Programs and Features > Uninstall or change a program *click the Installed column to sort by this heading </blockquote>
Was this helpful to you? 0
Quote

Question owner

Thanks but the problem continues.

I had two extensions -- Evernote and McAfee, both of which were disable, to no effect. I don't see any suspicious software in the control panel.

Thanks but the problem continues. I had two extensions -- Evernote and McAfee, both of which were disable, to no effect. I don't see any suspicious software in the control panel.
Was this helpful to you? 0
Quote

Question owner

kathbaines said

You need to first provide complete information about the system your using for example windows or mac etc. After that may be better able to provide you with effective solutions. Also are you using the latest firefox version?

W10 pro with firefox 54.0 (32-bit).

Thanks.

''kathbaines [[#answer-972798|said]]'' <blockquote> You need to first provide complete information about the system your using for example windows or mac etc. After that may be better able to provide you with effective solutions. Also are you using the latest firefox version? </blockquote> W10 pro with firefox 54.0 (32-bit). Thanks.
Was this helpful to you? 0
Quote

Question owner

HelpAsNeeded said

cor-el said
You can check for recently installed suspicious or unknown extensions. Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
You can check in "Windows Control Panel > Programs" for recently installed programs to see if any suspicious software shows up.
  • Control Panel > Programs > Programs and Features > Uninstall or change a program
  • click the Installed column to sort by this heading


Thanks but the problem continues.

I had two extensions -- Evernote and McAfee, both of which were disable, to no effect. I don't see any suspicious software in the control panel.

''HelpAsNeeded [[#answer-981493|said]]'' <blockquote> ''cor-el [[#answer-972797|said]]'' <blockquote> You can check for recently installed suspicious or unknown extensions. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check in "Windows Control Panel > Programs" for recently installed programs to see if any suspicious software shows up. *Control Panel > Programs > Programs and Features > Uninstall or change a program *click the Installed column to sort by this heading </blockquote> </blockquote> Thanks but the problem continues. I had two extensions -- Evernote and McAfee, both of which were disable, to no effect. I don't see any suspicious software in the control panel.
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
6323 solutions 51935 answers

Chosen Solution

McAfee could be an issue. When you're on the Options page, Search panel, and you check the default search engine setting at the top of the page, does it switch to the search plugin with the McAfee "M on a shield" icon, or the Yahoo "Y in a box" icon?

After disabling McAfee, did you exit out of Firefox and restart it to make sure it was fully disabled? That may be necessary to prevent it from repeatedly taking over your search engine setting.

Evernote should not be a problem.

McAfee could be an issue. When you're on the Options page, Search panel, and you check the default search engine setting at the top of the page, does it switch to the search plugin with the McAfee "M on a shield" icon, or the Yahoo "Y in a box" icon? After disabling McAfee, did you exit out of Firefox and restart it to make sure it was fully disabled? That may be necessary to prevent it from repeatedly taking over your search engine setting. Evernote should not be a problem.
Was this helpful to you? 1
Quote

Question owner

jscher2000 said

When you're on the Options page, Search panel, and you check the default search engine setting at the top of the page, does it switch to the search plugin with the McAfee "M on a shield" icon?

Yes, thanks!

Has disabled McAfee entirely on my laptop?

''jscher2000 [[#answer-981520|said]]'' <blockquote> When you're on the Options page, Search panel, and you check the default search engine setting at the top of the page, does it switch to the search plugin with the McAfee "M on a shield" icon? </blockquote> Yes, thanks! Has disabled McAfee entirely on my laptop?
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
6323 solutions 51935 answers

Disabling or removing a McAfee extension in Firefox does not disable other McAfee software on your system.

Disabling or removing a McAfee extension in Firefox does not disable other McAfee software on your system.
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.