Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox isn't allowing me to sign it to my Google Docs accounts, I get the login screen but when I enter my password, nothing happens.

  • 1 reply
  • 4 have this problem
  • 107 views
  • Last reply by FredMcD

more options

IF I use Safari, I can login to my Google Docs accounts, and I used to use Firefox. (I prefer to use Firefox but lately I have to switch to Safari to get in to several websites that I have to sign-in to access.) I had trouble with several bill pay sites the other night and had to open Safari to access them. Now I can't get into my Google Docs accounts at all. I logged out of my work account yesterday to log-in to my personal account and now I can't access any of them. Never had trouble with this before.

I can get to the attached login screen, but when I try and enter my password, nothing happens. It also won't do anything if I hit the next button or the drop down arrow for other accounts.

IF I use Safari, I can login to my Google Docs accounts, and I used to use Firefox. (I prefer to use Firefox but lately I have to switch to Safari to get in to several websites that I have to sign-in to access.) I had trouble with several bill pay sites the other night and had to open Safari to access them. Now I can't get into my Google Docs accounts at all. I logged out of my work account yesterday to log-in to my personal account and now I can't access any of them. Never had trouble with this before. I can get to the attached login screen, but when I try and enter my password, nothing happens. It also won't do anything if I hit the next button or the drop down arrow for other accounts.

Chosen solution

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?

Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network. Across from

Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). While you are in safe mode;

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Then restart. Poke around safe websites. Are there any problems?