Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I lost access to my profiles, help

  • 4 replies
  • 1 has this problem
  • 17 views
  • Last reply by OnlyOne

more options

Hi, I don't know how this happened but I reckon it was 10 minutes ago when I forcibly restarted my computer after everything froze. Everything froze seconds after I started up firefox. Upon restart, it no longer points me to my usual profile but asks me if I want to import anything from Safari and such as if I was starting all over again. Sure enough, everything is back to square one. My profile folders are still intact. How do I fix this? I have 3 profiles but one primary default profile with 10 years worth of settings, bookmarks and customizations. Please help.

Thanks.

All Replies (4)

more options

Your Firefox reported that it is version 41, which was released in October 2015. Does that sound correct??

Check the Profile Manager for Your Old Profile

External Method: Exit Firefox. In the Start menu search box, type or paste the following and press Enter to execute it:

firefox.exe -ProfileManager

Firefox should display a dialog with all the profiles recorded in the profiles.ini file so you can choose one to start up in. Is your old profile listed here so you can switch to it?

Internal Method (Firefox 47+): In Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it. To load any profile here, scroll down to it and click the "Set as default profile" button, then scroll back to the top and click the "Restart normally..." button to start up in that profile.

If Your Old Profile Is Not Listed

It probably needs to be added to the profiles.ini file. You'll find that in the Firefox folder, one level up from the Profiles folder.

(I'm looking for the steps and didn't immediately find them in a search...)

more options

If Your Old Profile Is Not Listed

It probably needs to be added to the profiles.ini file. You'll find that in the Firefox folder, one level up from the Profiles folder.

This worked, thank you. I guess the problem was my .ini file got corrupted. I'm glad that's all it was.

Yes, I am using Firefox 41, the reason is I hate the new format for the Options where I have to browse it like a web page.

more options

Maybe Classic Theme Restorer can help with the Options page. I'm attaching two screenshots showing its "Options in a dialog" features in Firefox 53. I don't know what it would look like in earlier versions of Firefox; presumably similar.

https://addons.mozilla.org/firefox/addon/classicthemerestorer/

For security reasons, you could consider using the last release of Firefox 45 ESR (extended support release) which is right around now, assuming you can live with the other changes. On the download page, there's a version switch above the column headings for Linux.

https://www.mozilla.org/firefox/organizations/all/

more options

Classic theme restorer doesn't help with that. I've tried from the very beginning. I'll eventually have to update anyway. I stuck with Firefox 2.0 for a long while because an important add-on was not available for 3.0, then I stuck with 3.0 for a long while because 5.0 took a ridiculous amount of RAM for no good reason. I hated having to get a new computer back in 2000 because the MIDIs didn't sound the same due to the new sound card. It wasn't until 2015 that I was able to find an emulator for that old OPL-3 sound card and enjoy the nostalgic magic again. One way or another, life finds a way to go on.