X
Tap here to go to the mobile version of the site.

Support Forum

Since firefox 53.0, the office web apps integration on sharepoint stopped working. What can I do to fix it?

Posted

Before the last Firefox update (53.0) I was able to check documents in and out from sharepoint directly from the office app (excel, power point, whatever) after having opened them through FireFox. Since the last update, that no longer works and firefox downloads the document and opens it rather than having office directly open the document from the clicked URL.

Note: in earlier versions; I had to activate the office web apps plugin before this actually worked. Firefox then asked whether I'd allow the office plugin to run, doing that gave me the desired solution.

The only thing I find related to this functionality is this plugin from microsoft: https://www.microsoft.com/en-us/download/details.aspx?id=27106. This is however an old plugin and in the last versions of FireFox I never had to install this, it "just worked".

I hope someone will be able to help, I don't want to switch to IE or Edge as my standard work browser.

Before the last Firefox update (53.0) I was able to check documents in and out from sharepoint directly from the office app (excel, power point, whatever) after having opened them through FireFox. Since the last update, that no longer works and firefox downloads the document and opens it rather than having office directly open the document from the clicked URL. Note: in earlier versions; I had to activate the office web apps plugin before this actually worked. Firefox then asked whether I'd allow the office plugin to run, doing that gave me the desired solution. The only thing I find related to this functionality is this plugin from microsoft: https://www.microsoft.com/en-us/download/details.aspx?id=27106. This is however an old plugin and in the last versions of FireFox I never had to install this, it "just worked". I hope someone will be able to help, I don't want to switch to IE or Edge as my standard work browser.

Chosen solution

Firefox v52+ disables all plugins except for Flash https://support.mozilla.org/t5/Common-Responses/Forum-Response-Firefox-no-longer-supports-NPAPI-Plugins/ta-p/1370454

https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no/ta-p/31069


https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release https://www.mozilla.org/en-US/firefox/organizations/

https://www.mozilla.org/en-US/firefox/organizations/notes/

https://www.mozilla.org/en-US/firefox/organizations/system-requirements/

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59885 answers

Chosen Solution

Firefox v52+ disables all plugins except for Flash https://support.mozilla.org/t5/Common-Responses/Forum-Response-Firefox-no-longer-supports-NPAPI-Plugins/ta-p/1370454

https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no/ta-p/31069


https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release https://www.mozilla.org/en-US/firefox/organizations/

https://www.mozilla.org/en-US/firefox/organizations/notes/

https://www.mozilla.org/en-US/firefox/organizations/system-requirements/

Firefox v52+ disables all plugins except for Flash https://support.mozilla.org/t5/Common-Responses/Forum-Response-Firefox-no-longer-supports-NPAPI-Plugins/ta-p/1370454 https://support.mozilla.org/t5/Problems-with-add-ons-plugins-or/Why-do-Java-Silverlight-Adobe-Acrobat-and-other-plugins-no/ta-p/31069 -------------------- https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out Firefox; Extended Support Release https://www.mozilla.org/en-US/firefox/organizations/ https://www.mozilla.org/en-US/firefox/organizations/notes/ https://www.mozilla.org/en-US/firefox/organizations/system-requirements/

Question owner

Thanks! Very clear reply!

Thanks! Very clear reply!
FredMcD
  • Top 10 Contributor
4269 solutions 59885 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.