X
Tap here to go to the mobile version of the site.

Support Forum

Touchscreen support Linux Firerox 52

Posted

Hi, I'm using firefox developer edition (52.0a2 (2016-11-21) (64-bit)). Installed Mozilla repo's (deb http://mozilla.debian.net/ experimental firefox-aurora)

I've read that the new versions of firefox, using GTK3+, handle natively touch support, provided you set a env variables, so that's what I tried, and even lauching firefox with;

MOZ_USE_XINPUT2=1 firefox

Firefox don't handle touchscreen, scrolling using touchscreen just select text, as mouse clicked scrolling would do...

I also tried to change "dom.w3c_touch_events.enabled" to 1 in about:config, but it didn't did the trick...

Is there something I'm missing ? I've also tried with the latest nightly builds of firefox but no support either.

Thank you for your help.

Hi, I'm using firefox developer edition (52.0a2 (2016-11-21) (64-bit)). Installed Mozilla repo's (deb http://mozilla.debian.net/ experimental firefox-aurora) I've read that the new versions of firefox, using GTK3+, handle natively touch support, provided you set a env variables, so that's what I tried, and even lauching firefox with; MOZ_USE_XINPUT2=1 firefox Firefox don't handle touchscreen, scrolling using touchscreen just select text, as mouse clicked scrolling would do... I also tried to change "dom.w3c_touch_events.enabled" to 1 in about:config, but it didn't did the trick... Is there something I'm missing ? I've also tried with the latest nightly builds of firefox but no support either. Thank you for your help.

Additional System Details

Application

  • Firefox 52.0a2
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.0a2/Linux/en-US/

Extensions

  • ADB Helper 0.9.2 (adbhelper@mozilla.org)
  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Beyond Australis 1.4.8 (thefoxonlybetter@quicksaver)
  • DuckDuckGo Plus 1.1.1 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • FireFTP 2.0.31 ({a7c6cf7f-112c-4500-a7ea-39801a327e5f})
  • FlyWeb 1.0.0 (flyweb@mozilla.org)
  • Form Autofill 1.0 (formautofill@mozilla.org)
  • Grab and Drag 3.2.9.9.1 ({477c4c36-24eb-11da-94d4-00e08161165f})
  • Greasemonkey 3.9 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Groupes d'Onglets 2.1.4 (tabgroups@quicksaver)
  • HTTPS Everywhere 5.2.10 (https-everywhere@eff.org)
  • Multi-process staged rollout 1.6 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Send to XBMC 2.3.0.1-signed.1-signed (jid0-YCM0p5WlCGjvBJcZhAusQ5h26wM@jetpack)
  • Tamper Data 11.0.1.1-signed.1-signed ({9c51bd27-6ed8-4000-a2bf-36cb95c0c947})
  • uBlock Origin 1.10.6 (uBlock0@raymondhill.net)
  • Valence 0.3.7 (fxdevtools-adapters@mozilla.org)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • WebSocket Monitor 0.6.4 (websocketmonitor@getfirebug.com)
  • Tree Style Tab 0.18.2016111701 (treestyletab@piro.sakura.ne.jp) (Inactive)
  • Web Developer 1.2.11 ({c45c406e-ab73-11d8-be73-000a95be3b12}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)
  • adapterDeviceID: Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 3.0 Mesa 12.0.4
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No
  • webgl2Renderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)
  • webglRenderer: Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Seburo
  • Top 10 Contributor
  • Moderator
746 solutions 5447 answers

Hi

The version of Firefox you have installed is one built by Debian, not Mozilla. I am not suggesting they have done anything wrong, but please can you try with a version from Mozilla from here.

Hi The version of Firefox you have installed is one built by Debian, not Mozilla. I am not suggesting they have done anything wrong, but please can you try with a version from Mozilla from [https://www.mozilla.org/en-US/firefox/developer/all/ here].

Question owner

I just tested with a recent binary downloaded from Mozilla, as you said, and I've tried using the env var, setting "dom.w3c_touch_events.enabled" to 1... But no, it still don't work.

May that bug be related with the fact that I don't use xinput driver for my touchscreen, but wacom ?

I just tested with a recent binary downloaded from Mozilla, as you said, and I've tried using the env var, setting "dom.w3c_touch_events.enabled" to 1... But no, it still don't work. May that bug be related with the fact that I don't use xinput driver for my touchscreen, but wacom ?