Search Support

Firefox 50.1.0 converts fully explicit img src= to data URI, Edge does not

  • 5 replies
  • 1 has this problem
  • 365 views
  • Last reply by Jerich0

more options

Extracted (show source, copy, paste) email as HTML contains fully explicit URIs for img src= tags. Loading this HTML into Firefox has 'Show Page Source' with correct URIs, but Firefox display doesn't show images. In Firefox 'copy image location' shows "data:image/gif;base64; ..." instead of the fully explicit URI from the HTML source, but no images are displayed. Fully explicit URI correctly loads (manually) into Firefox and displays correctly. Edge loads source HTML file and displays images without any problem.

Note that no CSS or Javascript is being used, just basic HTML.

What gives with FIrefox?

Chosen solution

Okay, given SafeMode worked, I tried settings for my Extensions. RequestPolicy was the culprit, and enabling my home page then allowed the HTML file to load/display normally. Thanks!

Read this answer in context 👍 0

All Replies (5)

more options

I can't think of a reason for Firefox to convert images to data URIs.

If you right-click and hold Ctrl while clicking View Image to load it into a separate tab, what are the image dimensions? Some security software may substitute a single-pixel (1 x 1) GIF for an image when it is perceived to be an advertisement.

Assuming that's not the problem:

  • Could you try bypassing any influence of cached files by reloading using Ctrl+Shift+r and then checking again?
  • Could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any difference?

more options

Ctl+Shift+r yields "0px × 0px (scaled to 254px × 83px)" GIF image (info), o/w HTML has no change (no images) SafeMode loads HTML file with images displayed normally

more options

Oh, BTW a prior version of Firefox (V48.xxx) loads HTML normally with images rendered.

more options

Jerich0 said

SafeMode loads HTML file with images displayed normally

Three effects of Safe Mode might be significant:

  • disabling extensions (you might want to check for extension updates using the "gear" button above the extension list on the Add-ons page)
  • disabling hardware acceleration of graphics
  • disabling the optional userContent.css file (most users do not create this file)

Of these, it's easiest to test disabling hardware acceleration:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Advanced. On the right side, with the "General" mini-tab active, uncheck the box for "Use hardware acceleration when available".

This takes effect the next time you exit Firefox and start it up again. Any difference?

Since hardware acceleration improves the appearance of fonts and animations, you may want to check whether graphics card/chipset driver updates are available for your system. This article suggests safe ways to do that: Upgrade your graphics drivers to use hardware acceleration and WebGL.

more options

Chosen Solution

Okay, given SafeMode worked, I tried settings for my Extensions. RequestPolicy was the culprit, and enabling my home page then allowed the HTML file to load/display normally. Thanks!