Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot download from Firefox

  • 13 replies
  • 5 have this problem
  • 1223 views
  • Last reply by FredMcD

more options

Every time I try to download something - it doesn't matter from where - the buttons in the download box do not work. They show up simply as two lines. Cannot figure out what is causing this and it just started.

Oh, and I just noticed this occurs in any sort of prompt box - downloads, errors, anything that has one of those cues that as for an action on my part.

Chosen solution

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Read this answer in context 👍 1

All Replies (13)

more options

Is this on any website or only specific websites?

more options

It's on every website I've tried to download from, including my email account.

more options

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Here is the screen shot if the issue, if you need more I can bring them up on her sites. This is just the first one that came to mind.

more options

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Tried to do this, but the action box came up with those bars in it and was unable to click on any of them to do the action required.

So no, sorry....that did not work.

Modified by Milady Dragon

more options

What is it you are trying to download? A program? Have you tried Save File?

more options

FredMcD said

What is it you are trying to download? A program? Have you tried Save File?


Yes, I have tried that. It doesn't change.

Programs...files, it doesn't matter what it is.

Modified by Milady Dragon

more options

Those buttons are the circles to the left of the choices.

more options

FredMcD said

Those buttons are the circles to the left of the choices.

I know *sigh*

It doesn't matter if I choose any of those circles...the action buttons (or whatever they're called!) don't appear, so I cannot do the chosen action.

Believe me when I say I have tried everything, and nothing I do makes those "run" or "save" or whatever buttons that are supposed to be there appear. I literally cannot perform any action that requires the clicking on those buttons. It does not matter if I choose "open" or "save" or anything that has a circle in front of it.

I'll be honest...I'm a bit frustrated with the whole thing. This affects attachments to emails, downloads from any sort of site, even errors and crashes that require me to perform a specific action by clicking on something to initiate it. Those buttons are gone. I can't even put Firefox into Safe Mode.

In case you didn't see it, I did attach a screen grab in one of the above posts so you can see what I mean.

If you come up with something else to try, I'll be glad to try it!

more options

Chosen Solution

Deleting the mimeTypes.rdf will reset all download actions to the default settings.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.


Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

FredMcD said

Deleting the mimeTypes.rdf will reset all download actions to the default settings. Type about:support in the address bar and press enter. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Locate the above file. Then rename or delete it. Restart Firefox.

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


That did it!

Thanks, and sorry for being so sharp in my last response.

more options

Glad to help. Safe Surfing.