Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can't change the language of the user interface with "general.useragent.locale" after auto update Nov 18

  • 4 replies
  • 1 has this problem
  • 12230 views
  • Last reply by cor-el

more options

I tried https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack

In the address bar, type about:config and press Enter.

In the Search field, type intl.locale.matchOS.

If the intl.locale.matchOS preference has a value of true, double-click it to toggle its value to false.

Clear the Search field, and type general.useragent.locale.

Double-click the general.useragent.locale preference, and enter the code of the language you want to use. This page lists most of the language codes used for Mozilla localizations.

Click the menu button New Fx Menu and then click Exit Close 29 .

Language does not change from en to de

edited by a moderator to get rid of the horizontal scrollbar inside the message - triggered in this forum software by leading line spaces.

Modified by the-edmeister

Chosen solution

Glad it worked in the end {Use Firefox in another language} & thanks for letting us know.

Note if you want only one specific language it is often best just to pick that Firefox version and install it. (Pick from https://www.mozilla.org/firefox/all/ no need to explicitly uninstall the original version, and certainly avoid using any third party uninstaller)

If you change over frequently then find a suitable language manager add-on, or possibly consider setting up separate Windows accounts, or separate Firefox profiles for other users.


Update: also see cor-el said

Note that you can also use a command line switch to start Firefox with a specific locale if you have multiple locales installed. You can create a desktop shortcut with the "-UILocale xx-xx" switch appended to the command line to start Firefox with a specific locale.
  • Start > Run: firefox.exe -UILocale en-US
Read this answer in context 👍 0

All Replies (4)

more options

Hi gertr, Firefox switches languages ok for me. So a few questions to see if I can figure out what is happening

  • Did this work previously has it just stopped working now ?
  • Do you have an English? German? or some other Firefox installed ?
  • Which language is the Firefox interface using at present ?
  • Have you got language packs installed (Which ones ?) & can you see them in about:addons languages tab ?
more options

John 99 thanks for your your comment.

I have the german firefox and language packs version installed.

After numerous trials following https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack it worked to change from en to de. Why ??? I don't know

more options

Chosen Solution

Glad it worked in the end {Use Firefox in another language} & thanks for letting us know.

Note if you want only one specific language it is often best just to pick that Firefox version and install it. (Pick from https://www.mozilla.org/firefox/all/ no need to explicitly uninstall the original version, and certainly avoid using any third party uninstaller)

If you change over frequently then find a suitable language manager add-on, or possibly consider setting up separate Windows accounts, or separate Firefox profiles for other users.


Update: also see cor-el said

Note that you can also use a command line switch to start Firefox with a specific locale if you have multiple locales installed. You can create a desktop shortcut with the "-UILocale xx-xx" switch appended to the command line to start Firefox with a specific locale.
  • Start > Run: firefox.exe -UILocale en-US

Modified by John99

more options

Note that you can also use a command line switch to start Firefox with a specific locale if you have multiple locales installed.

You can create a desktop shortcut with the "-UILocale xx-xx" switch appended to the command line to start Firefox with a specific locale.

  • Start > Run: firefox.exe -UILocale en-US