X
Tap here to go to the mobile version of the site.

Support Forum

Firefox runs in two instances in task manager

Posted

The other day due to the huge amount of CPU my Firefox was using I removed the software from my computer and tried to update to the latest 5.0 version. After the new installation I noticed that instead of a plugin container, there were two instances of Firefox running in task manager. After some research I thought that the issue was malware so I took the usual precautions (got antimalware software and did a complete system check only to find nothing) and eventually ended up resetting my computer. My computer is now factory reset, but when I again downloaded Firefox this instance occurred again. The two instances seem to be linked. I cannot close out of one without Firefox shutting down. The download didn't seem to work correctly as Firefox never launched upon full download and I was forced to restart my computer to get it to work at all. This does NOT occur when I use internet explorer as it shows a plugin container working with the process.

This second instance of Firefox is eating my CPU like the plugin container used to. I DO have antimalware software as well as an antivirus and neither are detecting issues on my computer. What can I do to fix this problem? I was considering reinstalling Firefox again but since it didn't download properly either time, I was wondering if there was a link to a version other than 5.0 out there that is more functional.

The other day due to the huge amount of CPU my Firefox was using I removed the software from my computer and tried to update to the latest 5.0 version. After the new installation I noticed that instead of a plugin container, there were two instances of Firefox running in task manager. After some research I thought that the issue was malware so I took the usual precautions (got antimalware software and did a complete system check only to find nothing) and eventually ended up resetting my computer. My computer is now factory reset, but when I again downloaded Firefox this instance occurred again. The two instances seem to be linked. I cannot close out of one without Firefox shutting down. The download didn't seem to work correctly as Firefox never launched upon full download and I was forced to restart my computer to get it to work at all. This does NOT occur when I use internet explorer as it shows a plugin container working with the process. This second instance of Firefox is eating my CPU like the plugin container used to. I DO have antimalware software as well as an antivirus and neither are detecting issues on my computer. What can I do to fix this problem? I was considering reinstalling Firefox again but since it didn't download properly either time, I was wondering if there was a link to a version other than 5.0 out there that is more functional.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape
  • Google Update
  • 2.0.31005.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5306 solutions 23424 answers

hello, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

hello, could you go to the firefox ''menu ≡ > help ? > troubleshooting information'', copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...
John99 971 solutions 13138 answers

This could be the new multi process Firefox. A big question is does the extra CPU usage speed Firefox up ? if so it may be doing what is intended.

That is not given to everyone yet, and not fully tested & complete. It does have some compatibility issues. It is if I recall correctly expected to increase security and drasticaly speed up Firefox but it will increase slightly the RAM requirements, and gets the increased speed from using more processing and will therefore likely increase CPU usage.

I think this gets turned off in Firefox's safe mode. There are methods of turning it off if it causes problems. Try safe mode first of all does that help & do you still get two instances of Firefox ?

Please paste your troubleshooting info in to a reply. Do not include anything else in that reply & to save space delete any print related information from the reply. Use a further separate reply for any comments or answers


To the correct solution to your problem, we need some more non-personal information from you. Please do the following:

  1. Use ONE of these methods to open the Firefox Troubleshooting Information page:
    • Click the menu button New Fx Menu , click on help Help-29 and select Troubleshooting Information.
    • Type about:support into the Firefox address bar and press the enter key.
  2. At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it.
  3. Now, go back to your forum post, right-click in the reply box and select Paste from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post.

If you need further information about the Troubleshooting information page, please read the article Use the Troubleshooting Information page to help fix Firefox issues.

Thanks in advance for your help!


For technically inclined readers of this thread wanting more information please see

For more user friendly information also see Mozilla Blogs

This could be the new multi process Firefox. A big question is does the extra CPU usage speed Firefox up ? if so it may be doing what is intended. That is not given to everyone yet, and not fully tested & complete. It does have some compatibility issues. It is if I recall correctly expected to increase security and drasticaly speed up Firefox but it will increase slightly the RAM requirements, and gets the increased speed from using more processing and will therefore likely increase CPU usage. I think this gets turned off in Firefox's safe mode. There are methods of turning it off if it causes problems. Try safe mode first of all does that help & do you still get two instances of Firefox ? * [[Troubleshoot Firefox issues using Safe Mode]] Please paste your troubleshooting info in to a reply. Do not include anything else in that reply & to save space delete any print related information from the reply. Use a further separate reply for any comments or answers ------ To the correct solution to your problem, we need some more non-personal information from you. Please do the following: # Use ONE of these methods to open the Firefox Troubleshooting Information page: #* Click the menu button [[Image:New Fx Menu]], click on help [[Image:Help-29]] and select ''Troubleshooting Information''. #* Type '''about:support''' into the Firefox address bar and press the enter key. # At the top of the Troubleshooting Information page that comes up, you should see a button that says "Copy text to clipboard". Click it. #Now, go back to your forum post, right-click in the reply box and select '''Paste''' from the context menu (or else click inside the reply box and press the Ctrl+V keys) to paste all the information you copied into the forum post. If you need further information about the Troubleshooting information page, please read the article [[Use the Troubleshooting Information page to help fix Firefox issues]]. Thanks in advance for your help! ------------ For technically inclined readers of this thread wanting more information please see * https://wiki.mozilla.org/Electrolysis For more user friendly information also see Mozilla Blogs * The “Why” of Electrolysis <br/> https://blog.mozilla.org/addons/2016/04/11/the-why-of-electrolysis/ * What’s Next for Multi-process Firefox <br/> https://blog.mozilla.org/futurereleases/2016/08/02/whats-next-for-multi-process-firefox/

Question owner

philipp said

hello, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

Here is what I found...


Application Basics


Name: Firefox Version: 50.0 Build ID: 20161104212021 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 OS: Windows_NT 6.1 Multiprocess Windows: 1/1 (Enabled by default) Safe Mode: false

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Adblock Plus Version: 2.8.1 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Application Update Service Helper Version: 1.0 Enabled: true ID: aushelper@mozilla.org

Name: Multi-process staged rollout Version: 1.5 Enabled: true ID: e10srollout@mozilla.org

Name: Pocket Version: 1.0.5 Enabled: true ID: firefox@getpocket.com

Name: Web Compat Version: 1.0 Enabled: true ID: webcompat@mozilla.org

Name: Avast Online Security Version: 12.0.88 Enabled: false ID: wrc@avast.com

Name: Avast SafePrice Version: 10.3.5.39 Enabled: false ID: sp@avast.com

Name: HP Smart Web Printing Version: 4.51 Enabled: false ID: smartwebprinting@hp.com

Graphics


Features Compositing: Basic Asynchronous Pan/Zoom: wheel input enabled WebGL Renderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0) WebGL2 Renderer: (no info) Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted Audio Backend: wasapi Direct2D: Blocked for your graphics driver version. DirectWrite: false (6.1.7600.16385) GPU #1 Active: Yes Description: Mobile Intel(R) 4 Series Express Chipset Family Vendor ID: 0x8086 Device ID: 0x2a42 Driver Version: 8.15.10.1808 Driver Date: 6-3-2009 Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32 Subsys ID: 360b103c RAM: Unknown

Diagnostics AzureCanvasAccelerated: 0 AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo failures: [GFX1-]: D3D11 layers disabled due to a prior crash. Decision Log HW_COMPOSITING: crashed_on_startup by runtime: Crashed during startup in a previous session D3D11_COMPOSITING: crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D9_COMPOSITING: disabled by default: Disabled by default DIRECT2D: Blocklisted; failure code BLOCKLIST_FEATURE_FAILURE_DL_BLACKLIST_g984 crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D11_HW_ANGLE: disabled by env: D3D11 compositing is disabled Crash Guard Disabled Features D3D11 Compositor: Reset on Next Restart

Failure Log (#0) Error: D3D11 layers disabled due to a prior crash.

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 3 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 8 browser.sessionstore.upgradeBackup.latestBuildID: 20161104212021 browser.startup.homepage_override.buildID: 20161104212021 browser.startup.homepage_override.mstone: 50.0 browser.tabs.remote.autostart.2: true browser.urlbar.daysBeforeHidingSuggestionsPrompt: 2 browser.urlbar.lastSuggestionsPromptDate: 20161117 extensions.lastAppVersion: 50.0 gfx.blacklist.direct2d: 3 gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984 gfx.crash-guard.d3d11layers.appVersion: 50.0 gfx.crash-guard.d3d11layers.deviceID: 0x2a42 gfx.crash-guard.d3d11layers.driverVersion: 8.15.10.1808 gfx.crash-guard.d3d11layers.feature-d2d: false gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.status.d3d11layers: 3 media.gmp-eme-adobe.abi: x86-msvc-x64 media.gmp-eme-adobe.lastUpdate: 1479356167 media.gmp-eme-adobe.version: 17 media.gmp-gmpopenh264.abi: x86-msvc-x64 media.gmp-gmpopenh264.lastUpdate: 1479356168 media.gmp-gmpopenh264.version: 1.6 media.gmp-manager.buildID: 20161104212021 media.gmp-manager.lastCheck: 1479356164 media.gmp-widevinecdm.abi: x86-msvc-x64 media.gmp-widevinecdm.lastUpdate: 1479356171 media.gmp-widevinecdm.version: 1.4.8.903 media.gmp.storage.version.observed: 1 media.hardware-video-decoding.failed: true network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1479357383 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true security.sandbox.content.tempDirSuffix: {8c4b0921-b550-48af-8fff-5cd66936e243} storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1479357383

Important Locked Preferences


Places Database


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.12 Version in use: 4.12

NSS Expected minimum version: 3.26.2 Version in use: 3.26.2

NSSSMIME Expected minimum version: 3.26.2 Version in use: 3.26.2

NSSSSL Expected minimum version: 3.26.2 Version in use: 3.26.2

NSSUTIL Expected minimum version: 3.26.2 Version in use: 3.26.2

Experimental Features


Sandbox


Content Process Sandbox Level: 1

''philipp [[#answer-936212|said]]'' <blockquote> hello, could you go to the firefox ''menu ≡ > help ? > troubleshooting information'', copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on... </blockquote> Here is what I found... Application Basics ------------------ Name: Firefox Version: 50.0 Build ID: 20161104212021 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 OS: Windows_NT 6.1 Multiprocess Windows: 1/1 (Enabled by default) Safe Mode: false Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: Adblock Plus Version: 2.8.1 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Name: Application Update Service Helper Version: 1.0 Enabled: true ID: aushelper@mozilla.org Name: Multi-process staged rollout Version: 1.5 Enabled: true ID: e10srollout@mozilla.org Name: Pocket Version: 1.0.5 Enabled: true ID: firefox@getpocket.com Name: Web Compat Version: 1.0 Enabled: true ID: webcompat@mozilla.org Name: Avast Online Security Version: 12.0.88 Enabled: false ID: wrc@avast.com Name: Avast SafePrice Version: 10.3.5.39 Enabled: false ID: sp@avast.com Name: HP Smart Web Printing Version: 4.51 Enabled: false ID: smartwebprinting@hp.com Graphics -------- Features Compositing: Basic Asynchronous Pan/Zoom: wheel input enabled WebGL Renderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0) WebGL2 Renderer: (no info) Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted Audio Backend: wasapi Direct2D: Blocked for your graphics driver version. DirectWrite: false (6.1.7600.16385) GPU #1 Active: Yes Description: Mobile Intel(R) 4 Series Express Chipset Family Vendor ID: 0x8086 Device ID: 0x2a42 Driver Version: 8.15.10.1808 Driver Date: 6-3-2009 Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32 Subsys ID: 360b103c RAM: Unknown Diagnostics AzureCanvasAccelerated: 0 AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo failures: [GFX1-]: D3D11 layers disabled due to a prior crash. Decision Log HW_COMPOSITING: crashed_on_startup by runtime: Crashed during startup in a previous session D3D11_COMPOSITING: crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D9_COMPOSITING: disabled by default: Disabled by default DIRECT2D: Blocklisted; failure code BLOCKLIST_FEATURE_FAILURE_DL_BLACKLIST_g984 crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D11_HW_ANGLE: disabled by env: D3D11 compositing is disabled Crash Guard Disabled Features D3D11 Compositor: Reset on Next Restart Failure Log (#0) Error: D3D11 layers disabled due to a prior crash. Important Modified Preferences ------------------------------ browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 3 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 8 browser.sessionstore.upgradeBackup.latestBuildID: 20161104212021 browser.startup.homepage_override.buildID: 20161104212021 browser.startup.homepage_override.mstone: 50.0 browser.tabs.remote.autostart.2: true browser.urlbar.daysBeforeHidingSuggestionsPrompt: 2 browser.urlbar.lastSuggestionsPromptDate: 20161117 extensions.lastAppVersion: 50.0 gfx.blacklist.direct2d: 3 gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984 gfx.crash-guard.d3d11layers.appVersion: 50.0 gfx.crash-guard.d3d11layers.deviceID: 0x2a42 gfx.crash-guard.d3d11layers.driverVersion: 8.15.10.1808 gfx.crash-guard.d3d11layers.feature-d2d: false gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.status.d3d11layers: 3 media.gmp-eme-adobe.abi: x86-msvc-x64 media.gmp-eme-adobe.lastUpdate: 1479356167 media.gmp-eme-adobe.version: 17 media.gmp-gmpopenh264.abi: x86-msvc-x64 media.gmp-gmpopenh264.lastUpdate: 1479356168 media.gmp-gmpopenh264.version: 1.6 media.gmp-manager.buildID: 20161104212021 media.gmp-manager.lastCheck: 1479356164 media.gmp-widevinecdm.abi: x86-msvc-x64 media.gmp-widevinecdm.lastUpdate: 1479356171 media.gmp-widevinecdm.version: 1.4.8.903 media.gmp.storage.version.observed: 1 media.hardware-video-decoding.failed: true network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1479357383 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true security.sandbox.content.tempDirSuffix: {8c4b0921-b550-48af-8fff-5cd66936e243} storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1479357383 Important Locked Preferences ---------------------------- Places Database --------------- JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.12 Version in use: 4.12 NSS Expected minimum version: 3.26.2 Version in use: 3.26.2 NSSSMIME Expected minimum version: 3.26.2 Version in use: 3.26.2 NSSSSL Expected minimum version: 3.26.2 Version in use: 3.26.2 NSSUTIL Expected minimum version: 3.26.2 Version in use: 3.26.2 Experimental Features --------------------- Sandbox ------- Content Process Sandbox Level: 1

Question owner

John99 said

I restarted Firefox in safe mode, but the second instance still occurs. It does not make Firefox run faster as it is forcing my computer to use almost 100% of the CPU every time I open a new page. Watching youtube is almost impossible and I cannot have multiple tabs open for research.

Here are the logistics

Application Basics


Name: Firefox Version: 50.0 Build ID: 20161104212021 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 OS: Windows_NT 6.1 Multiprocess Windows: 1/1 (Enabled by default) Safe Mode: false

Crash Reports for the Last 3 Days


All Crash Reports

Extensions


Name: Adblock Plus Version: 2.8.1 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Application Update Service Helper Version: 1.0 Enabled: true ID: aushelper@mozilla.org

Name: Multi-process staged rollout Version: 1.5 Enabled: true ID: e10srollout@mozilla.org

Name: Pocket Version: 1.0.5 Enabled: true ID: firefox@getpocket.com

Name: Web Compat Version: 1.0 Enabled: true ID: webcompat@mozilla.org

Name: Avast Online Security Version: 12.0.88 Enabled: false ID: wrc@avast.com

Name: Avast SafePrice Version: 10.3.5.39 Enabled: false ID: sp@avast.com

Name: HP Smart Web Printing Version: 4.51 Enabled: false ID: smartwebprinting@hp.com

Graphics


Features Compositing: Basic Asynchronous Pan/Zoom: wheel input enabled WebGL Renderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0) WebGL2 Renderer: (no info) Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted Audio Backend: wasapi Direct2D: Blocked for your graphics driver version. DirectWrite: false (6.1.7600.16385) GPU #1 Active: Yes Description: Mobile Intel(R) 4 Series Express Chipset Family Vendor ID: 0x8086 Device ID: 0x2a42 Driver Version: 8.15.10.1808 Driver Date: 6-3-2009 Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32 Subsys ID: 360b103c RAM: Unknown

Diagnostics AzureCanvasAccelerated: 0 AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo failures: [GFX1-]: D3D11 layers disabled due to a prior crash. Decision Log HW_COMPOSITING: crashed_on_startup by runtime: Crashed during startup in a previous session D3D11_COMPOSITING: crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D9_COMPOSITING: disabled by default: Disabled by default DIRECT2D: Blocklisted; failure code BLOCKLIST_FEATURE_FAILURE_DL_BLACKLIST_g984 crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D11_HW_ANGLE: disabled by env: D3D11 compositing is disabled Crash Guard Disabled Features D3D11 Compositor: Reset on Next Restart

Failure Log (#0) Error: D3D11 layers disabled due to a prior crash.

Important Modified Preferences


browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 3 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 8 browser.sessionstore.upgradeBackup.latestBuildID: 20161104212021 browser.startup.homepage_override.buildID: 20161104212021 browser.startup.homepage_override.mstone: 50.0 browser.tabs.remote.autostart.2: true browser.urlbar.daysBeforeHidingSuggestionsPrompt: 2 browser.urlbar.lastSuggestionsPromptDate: 20161117 extensions.lastAppVersion: 50.0 gfx.blacklist.direct2d: 3 gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984 gfx.crash-guard.d3d11layers.appVersion: 50.0 gfx.crash-guard.d3d11layers.deviceID: 0x2a42 gfx.crash-guard.d3d11layers.driverVersion: 8.15.10.1808 gfx.crash-guard.d3d11layers.feature-d2d: false gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.status.d3d11layers: 3 media.gmp-eme-adobe.abi: x86-msvc-x64 media.gmp-eme-adobe.lastUpdate: 1479356167 media.gmp-eme-adobe.version: 17 media.gmp-gmpopenh264.abi: x86-msvc-x64 media.gmp-gmpopenh264.lastUpdate: 1479356168 media.gmp-gmpopenh264.version: 1.6 media.gmp-manager.buildID: 20161104212021 media.gmp-manager.lastCheck: 1479356164 media.gmp-widevinecdm.abi: x86-msvc-x64 media.gmp-widevinecdm.lastUpdate: 1479356171 media.gmp-widevinecdm.version: 1.4.8.903 media.gmp.storage.version.observed: 1 media.hardware-video-decoding.failed: true network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1479357383 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true security.sandbox.content.tempDirSuffix: {8c4b0921-b550-48af-8fff-5cd66936e243} storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1479357383

Important Locked Preferences


Places Database


JavaScript


Incremental GC: true

Accessibility


Activated: false Prevent Accessibility: 0

Library Versions


NSPR Expected minimum version: 4.12 Version in use: 4.12

NSS Expected minimum version: 3.26.2 Version in use: 3.26.2

NSSSMIME Expected minimum version: 3.26.2 Version in use: 3.26.2

NSSSSL Expected minimum version: 3.26.2 Version in use: 3.26.2

NSSUTIL Expected minimum version: 3.26.2 Version in use: 3.26.2

Experimental Features


Sandbox


Content Process Sandbox Level: 1

''John99 [[#answer-936213|said]]'' I restarted Firefox in safe mode, but the second instance still occurs. It does not make Firefox run faster as it is forcing my computer to use almost 100% of the CPU every time I open a new page. Watching youtube is almost impossible and I cannot have multiple tabs open for research. Here are the logistics Application Basics ------------------ Name: Firefox Version: 50.0 Build ID: 20161104212021 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0 OS: Windows_NT 6.1 Multiprocess Windows: 1/1 (Enabled by default) Safe Mode: false Crash Reports for the Last 3 Days --------------------------------- All Crash Reports Extensions ---------- Name: Adblock Plus Version: 2.8.1 Enabled: true ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d} Name: Application Update Service Helper Version: 1.0 Enabled: true ID: aushelper@mozilla.org Name: Multi-process staged rollout Version: 1.5 Enabled: true ID: e10srollout@mozilla.org Name: Pocket Version: 1.0.5 Enabled: true ID: firefox@getpocket.com Name: Web Compat Version: 1.0 Enabled: true ID: webcompat@mozilla.org Name: Avast Online Security Version: 12.0.88 Enabled: false ID: wrc@avast.com Name: Avast SafePrice Version: 10.3.5.39 Enabled: false ID: sp@avast.com Name: HP Smart Web Printing Version: 4.51 Enabled: false ID: smartwebprinting@hp.com Graphics -------- Features Compositing: Basic Asynchronous Pan/Zoom: wheel input enabled WebGL Renderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family Direct3D9Ex vs_3_0 ps_3_0) WebGL2 Renderer: (no info) Hardware H264 Decoding: No; Hardware video decoding disabled or blacklisted Audio Backend: wasapi Direct2D: Blocked for your graphics driver version. DirectWrite: false (6.1.7600.16385) GPU #1 Active: Yes Description: Mobile Intel(R) 4 Series Express Chipset Family Vendor ID: 0x8086 Device ID: 0x2a42 Driver Version: 8.15.10.1808 Driver Date: 6-3-2009 Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32 Subsys ID: 360b103c RAM: Unknown Diagnostics AzureCanvasAccelerated: 0 AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo failures: [GFX1-]: D3D11 layers disabled due to a prior crash. Decision Log HW_COMPOSITING: crashed_on_startup by runtime: Crashed during startup in a previous session D3D11_COMPOSITING: crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D9_COMPOSITING: disabled by default: Disabled by default DIRECT2D: Blocklisted; failure code BLOCKLIST_FEATURE_FAILURE_DL_BLACKLIST_g984 crashed_on_startup by runtime: Harware acceleration crashed during startup in a previous sessi D3D11_HW_ANGLE: disabled by env: D3D11 compositing is disabled Crash Guard Disabled Features D3D11 Compositor: Reset on Next Restart Failure Log (#0) Error: D3D11 layers disabled due to a prior crash. Important Modified Preferences ------------------------------ browser.cache.disk.capacity: 358400 browser.cache.disk.filesystem_reported: 1 browser.cache.disk.smart_size.first_run: false browser.cache.frecency_experiment: 3 browser.download.importedFromSqlite: true browser.places.smartBookmarksVersion: 8 browser.sessionstore.upgradeBackup.latestBuildID: 20161104212021 browser.startup.homepage_override.buildID: 20161104212021 browser.startup.homepage_override.mstone: 50.0 browser.tabs.remote.autostart.2: true browser.urlbar.daysBeforeHidingSuggestionsPrompt: 2 browser.urlbar.lastSuggestionsPromptDate: 20161117 extensions.lastAppVersion: 50.0 gfx.blacklist.direct2d: 3 gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984 gfx.crash-guard.d3d11layers.appVersion: 50.0 gfx.crash-guard.d3d11layers.deviceID: 0x2a42 gfx.crash-guard.d3d11layers.driverVersion: 8.15.10.1808 gfx.crash-guard.d3d11layers.feature-d2d: false gfx.crash-guard.d3d11layers.feature-d3d11: true gfx.crash-guard.status.d3d11layers: 3 media.gmp-eme-adobe.abi: x86-msvc-x64 media.gmp-eme-adobe.lastUpdate: 1479356167 media.gmp-eme-adobe.version: 17 media.gmp-gmpopenh264.abi: x86-msvc-x64 media.gmp-gmpopenh264.lastUpdate: 1479356168 media.gmp-gmpopenh264.version: 1.6 media.gmp-manager.buildID: 20161104212021 media.gmp-manager.lastCheck: 1479356164 media.gmp-widevinecdm.abi: x86-msvc-x64 media.gmp-widevinecdm.lastUpdate: 1479356171 media.gmp-widevinecdm.version: 1.4.8.903 media.gmp.storage.version.observed: 1 media.hardware-video-decoding.failed: true network.cookie.prefsMigrated: true network.predictor.cleaned-up: true places.database.lastMaintenance: 1479357383 places.history.expiration.transient_current_max_pages: 104858 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true security.sandbox.content.tempDirSuffix: {8c4b0921-b550-48af-8fff-5cd66936e243} storage.vacuum.last.index: 0 storage.vacuum.last.places.sqlite: 1479357383 Important Locked Preferences ---------------------------- Places Database --------------- JavaScript ---------- Incremental GC: true Accessibility ------------- Activated: false Prevent Accessibility: 0 Library Versions ---------------- NSPR Expected minimum version: 4.12 Version in use: 4.12 NSS Expected minimum version: 3.26.2 Version in use: 3.26.2 NSSSMIME Expected minimum version: 3.26.2 Version in use: 3.26.2 NSSSSL Expected minimum version: 3.26.2 Version in use: 3.26.2 NSSUTIL Expected minimum version: 3.26.2 Version in use: 3.26.2 Experimental Features --------------------- Sandbox ------- Content Process Sandbox Level: 1
philipp
  • Top 25 Contributor
  • Moderator
5306 solutions 23424 answers

thank you, so as john99 already suspected your firefox is already using the new multi-process architecture (refer to the links at the bottom of his reply) - this is normal and no sign of malware. please also note that the plugin-container.exe now got renamed to firefox.exe as well...

thank you, so as john99 already suspected your firefox is already using the new multi-process architecture (refer to the links at the bottom of his reply) - this is normal and no sign of malware. please also note that the plugin-container.exe now got renamed to firefox.exe as well...

Question owner

philipp said

thank you, so as john99 already suspected your firefox is already using the new multi-process architecture (refer to the links at the bottom of his reply) - this is normal and no sign of malware. please also note that the plugin-container.exe now got renamed to firefox.exe as well...

Philipp,

Is there any way to revert to an earlier version of Firefox or are there any steps I can take to prevent it from eating my CPU (upwards of 100% usage at a time)? I enjoy using Firefox, but in truth this new update is killing it's usability for me.

''philipp [[#answer-936220|said]]'' <blockquote> thank you, so as john99 already suspected your firefox is already using the new multi-process architecture (refer to the links at the bottom of his reply) - this is normal and no sign of malware. please also note that the plugin-container.exe now got renamed to firefox.exe as well... </blockquote> Philipp, Is there any way to revert to an earlier version of Firefox or are there any steps I can take to prevent it from eating my CPU (upwards of 100% usage at a time)? I enjoy using Firefox, but in truth this new update is killing it's usability for me.
John99 971 solutions 13138 answers

Did you try safe mode that probably stops multi process Firefox. It is only a temporary troubleshooting step rather than a solution - & I still need to check it does stop multi process.

I think there will be prefs that can be flipped to stop multi process. Philipp probably knows which they are, I would need to look them up.

The question is why are you seeing such poor performance, with only a handful of add-ons installed. The multi process change is intended to be an improvement.

Did you try safe mode that probably stops multi process Firefox. It is only a temporary troubleshooting step rather than a solution - & I still need to check it does stop multi process. I think there will be prefs that can be flipped to stop multi process. Philipp probably knows which they are, I would need to look them up. The question is why are you seeing such poor performance, with only a handful of add-ons installed. The multi process change is intended to be an improvement.

Question owner

John99 said

Yes, safe mode is currently active. The problem still occurs. Looking at which programs are eating my CPU the top two are almost always Firefox.exe . I'm not sure why it jumps from 8% to 60% usage while the second instance of Firefox.exe goes from 0% to 30%. I'm used to the jump occurring when I load up a new page, but not to the point where it stops all processes on my computer and causes Firefox to freeze for five minutes or more while it retrieves data. Again, I just restarted my computer so there is little to nothing on it and I've gone through to take off unnecessary background processes to speed it up. Hopefully there is a way to trouble shoot the problem.

Thank you for answering my inquiry. You've been very helpful!

''John99 [[#answer-936247|said]]'' Yes, safe mode is currently active. The problem still occurs. Looking at which programs are eating my CPU the top two are almost always Firefox.exe . I'm not sure why it jumps from 8% to 60% usage while the second instance of Firefox.exe goes from 0% to 30%. I'm used to the jump occurring when I load up a new page, but not to the point where it stops all processes on my computer and causes Firefox to freeze for five minutes or more while it retrieves data. Again, I just restarted my computer so there is little to nothing on it and I've gone through to take off unnecessary background processes to speed it up. Hopefully there is a way to trouble shoot the problem. Thank you for answering my inquiry. You've been very helpful!
John99 971 solutions 13138 answers

Helpful Reply

OK I am not certain of the correct exact method of disabling multi process Firefox but this is safe and works for me.

Back up the file prefs.js by making a copy and call it prefs.js.vo1 This is to make sure if anything goes wrong you have a simple method of reverting to the prior configuration. Key in to the address bar about:profiles press Enter key. Use the button [show profiles] to open your profile folder. Close Firefox and make a copy of the file prefs.js rename that copy prefs.js.v01

Toggle the ...tabs.remote... prefs to false Re open Firefox. Key in about:config press Enter key Look for the prefs that need changing. Key in on the search line bs.r wait a while for it to filter them. I see

browser.tabs.remote.autostart 
browser.tabs.remote.autostart.2
browser.tabs.remote.desktopbehavior;false

Right click each one in turn, and use the Toggle option to set each to false Restart Firefox so the change takes place.

You should then be in ordinary Firefox without multi process. Use about:troubleshooting to check. The Multiprocess Windows entry should start with a zero e.g.

Multiprocess Windows 	0/1 (Disabled)
OK I am not certain of the correct exact method of disabling multi process Firefox but this is safe and works for me. <u>Back up the file prefs.js by making a copy and call it prefs.js.vo1 </u> This is to make sure if anything goes wrong you have a simple method of reverting to the prior configuration. Key in to the address bar ''about:profiles'' press ''Enter'' key. Use the button [''show profiles''] to open your profile folder. Close Firefox and make a copy of the file prefs.js rename that copy prefs.js.v01 <u>Toggle the ...tabs.remote... prefs to false </u> Re open Firefox. Key in ''about:config'' press ''Enter'' key Look for the prefs that need changing. Key in on the search line ''bs.r'' wait a while for it to filter them. I see browser.tabs.remote.autostart browser.tabs.remote.autostart.2 browser.tabs.remote.desktopbehavior;false Right click each one in turn, and use the ''Toggle'' option to set each to ''false'' Restart Firefox so the change takes place. You should then be in ordinary Firefox without multi process. Use about:troubleshooting to check. The Multiprocess Windows entry should start with a zero e.g. Multiprocess Windows 0/1 (Disabled)
John99 971 solutions 13138 answers

Did the steps in my last post successfully turn off multi process Firefox for you, and did that solve the immediate problems ?

If you have the time and inclination there is some troubleshooting you could do to try to figure out what causes this issue for you. If you have the time to help us further please let me know.

That however is more for the benefits of others, or for you in the future. Thanks for the troubleshooting information, that in itself should help us when combined with other reports.

Did the steps in my last post successfully turn off multi process Firefox for you, and did that solve the immediate problems ? If you have the time and inclination there is some troubleshooting you could do to try to figure out what causes this issue for you. If you have the time to help us further please let me know. That however is more for the benefits of others, or for you in the future. Thanks for the troubleshooting information, that in itself should help us when combined with other reports.

Helpful Reply

John99 said

John99, Yes, I successfully turned off the process. I still notice that Firefox is using a LOT of CPU (still almost 100%), but without the multiprocess I'm finding loading pages, emails, and videos to be going much faster. I'd still like to speed up Firefox and prevent it from using so much CPU. Maybe if we go through the other troubleshooting steps we can figure out what went wrong with the multiprocess and hopefully I'll be able to figure out how to improve Firefox's CPU usage as well. It might take me some time due to work during the day, but if the trial an error helps someone else out and gives me more tools to help me troubleshoot in the future I'm willing to give it a shot.
''John99 [[#answer-936261|said]]'' <blockquote> John99, Yes, I successfully turned off the process. I still notice that Firefox is using a LOT of CPU (still almost 100%), but without the multiprocess I'm finding loading pages, emails, and videos to be going much faster. I'd still like to speed up Firefox and prevent it from using so much CPU. Maybe if we go through the other troubleshooting steps we can figure out what went wrong with the multiprocess and hopefully I'll be able to figure out how to improve Firefox's CPU usage as well. It might take me some time due to work during the day, but if the trial an error helps someone else out and gives me more tools to help me troubleshoot in the future I'm willing to give it a shot.
angusm43 0 solutions 1 answers

I just upgraded today to 51.0.1, had same issue.

Likewise solved by turning off this feature (after previously uninstalling/reinstalling, resetting, safe mode, check graphics driver, turning off webgl....none of which helped)

so thanks!

I just upgraded today to 51.0.1, had same issue. Likewise solved by turning off this feature (after previously uninstalling/reinstalling, resetting, safe mode, check graphics driver, turning off webgl....none of which helped) so thanks!

Modified by angusm43