X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The plugin-container.exe is using 100% cpu usage???

Posted

After I open a few different pages or tabs within the pages, the plugin-container.exe max's my cpu usage and the system hangs horribly. It comes back and then hangs again. The plugin-container is reasonable new, because I don't recall seeing it in the Task Manager. Is there a way to fix this?? I know it's related to some apple piece of garbage software that I could totally do without if that helps.

Thanks

Additional System Details

Installed Plug-ins

  • -Next Generation Java Plug-in 1.6.0_21 for Mozilla browsers
  • Shockwave Flash 10.1 r53
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Default Plug-in
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Adobe Shockwave for Director Netscape plug-in, version 11.0
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50524.0
  • Office Live Update v1.4
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Panda ActiveScan 2.0 Plugin for Firefox
  • 6.0.11.3006
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 ( )

More Information

Extensions:
IDM CC 698 Internet Download Manager
Java Consoe 6.0.21
Java Quick Starter 1.0
Kaspersky URL Advisor 9.0.0.736
Microsoft .net Framework Assistant 1.2.1
RealPlayer Browser Record Plugin 1.9
Yahoo! Toolbar 21.2.20100310105313
and that's it.

AnonymousUser 406 solutions 14878 answers

I have same issue.. just started the last few days.

AnonymousUser 406 solutions 14878 answers

Same here...

AnonymousUser 406 solutions 14878 answers

Same problem here, was hoping for a cure.

TXGuy 87 solutions 861 answers

Helpful Reply

Plugin-container was introduced in Firefox 3.6.4 to run certain plugins in isolation from the browser, so that when an offending plugin crashes, it does not crash the entire browser, just the tab with the offending plugin. There is information about plugin-container and a method to disable plugin-container in the following article: http://kb.mozillazine.org/Plugin-container_and_out-of-process_plugins

If you disable plugin-container, your entire browser will crash if a plugin crashes. If you choose to disable plugin-container, restart Firefox to be sure that plugin-container closes; once started, plugin-container remains open until you restart Firefox.

Morbus 134 solutions 2338 answers

Helpful Reply

Issues of this sort are, unfortunately, more common and the we'd like them to be. However, they tend not to be cause by Firefox itself, but rather by software that is running either inside or alongside it, such as add-ons or firewalls. Since these issues have a broad span of possible causes, you need to diagnose your problems before fixing them. Follow these instructions to the line, as they'll probably help you diagnose and fix the problems you're having.

  1. run Firefox in safe-mode to disable all extensions, themes and plugins. If this fixes your problem, be it with RAM or CPU usage, then you know it's a problem with add-ons (plugins, themes or extensions). Proceed to number 2. If safe-mode doesn't fix your problem, then read bellow, after this list;
  2. update all extensions (go into Tools > Add-ons > Extensions > Find Updates), themes and plugins (see this page in your Firefox. If this doesn't solve the issues, proceed to the following number;
  3. disable all extensions, themes and plugins in your Firefox (not running safe-mode). This is temporary and for diagnostic purposes only. Being certain that, as in safe-mode, the problems you're having have gone away, enable one plugin at a time. You should be certain that you actually want that plugin to be enabled. It's best to keep the overall number of enabled plugins as low as possible. When you encounter problems, you know you've found a problematic plugin, so disable it for good. Keep enabling all plugins (except problematic ones) until you've gone through them all. If you need support for a problematic plugin, you need to contact its author for support;
  4. enable one extension at a time. Again, be certain that you actually want that extension to be enabled. As with plguins, it's best to keep the overall number of enabled extensions as low as possible. Also, try the theme you want to have installed so see if that is what's causing the problem. When you encounter problems, you know you've found a problematic extension/theme, so disable it for good. Keep enabling all your extensions (except problematic ones) until you've gone through them all. Just the same as with plugins, if you need support for a problematic extension/plugin, you need to contact its author;
  5. if you've followed my instructions above, you're done! You've fixed your problems with problematic add-ons. If you want to keep using those problematic add-ons, please contant their authors for support.

Ok, now... If disabling all extensions and plugins through safe-mode didn't work to fix your problems (or, in other words, if you've just read number 1 on the list above and come straight here), then you have different issue. The most likely scenario is that you have a third party software running on your computer that is messing with Firefox. Detecting which program it is may be tricky, but the following list should help you. Make sure you follow it carefully. Don't forget to answer the question on the last point, if nothing else helps.

  1. try reinstalling Firefox. No data will be lost. You can get the latest version (for free, as always) at getfirefox.com. Make sure you uninstall Firefox prior to reinstalling it. For help installing Firefox, see this support article. If that doesn't fix the problem, proceed;
  2. do a virus/malware check on your computer. See this support article for help on this point. This is a very important step, so please pay attention to it. If your problem is not due to viruses/malware, proceed;
  3. disable all software running in the background that you don't want to have running in the background (in Windows operating systems, this is done by pressing WINDOWS+R in your keyboard, typing msconfig and pressing Enter; now, under the Startup tab, you can uncheck the software you don't want, and reboot your system for changes to take effect; if you're unsure of what software you want running, ask someone with more experience). If this doesn't fix your issues with Firefox, proceed;
  4. check if your firewall/antivirus/security suite is conflicting in any way with Firefox's normal behavior. Check for enabled functions/features that you don't want and/or may be causing problems with Firefox. You'll find that these features are most likely tied to Internet Security features, such as link scanners or URL checkers and the like. If you're not sure they are conflicting with Firefox, simply try to disable them temporarily to see whether or not that's true. If this doesn't solve the issues, proceed to the following number;
  5. check your operating system security options, mainly advanced options that are not configured by default. While it's very unlikely that this may be the cause of the problem, it's remotely possible. If this doesn't work, proceed to the following point;
  6. update your modem/router software. There have been some reports that some modem/router software may cause Firefox and other browsers to loose performance and/or stability. If updating doesn't fix your issue, try other versions of the software, if possible. If you need support with this, contact your modem/router manufacturer. If this doesn't help, proceed;
  7. if you are using a Windows operating system, clean up your OS registry using appropriate software. There have been reports that badly maintained Windows Registries may case problems with Firefox. If this doesn't help, see the following point;
  8. please try creating a new temporary Firefox profile (managing profiles) and see if the issues persist. Please report the results, so we can help you further.
bob300smith 0 solutions 1 answers

Firstly, Of course it's Firefox's problem What an apologist!

Secondly rather wade through that ridiculous check list, you tech dweebs must real have too much time on your hands, simply switch to another browser such as Chrome, Opera or even the new IE9 - that going to be vastly superior to Firefox anyway.

Morbus 134 solutions 2338 answers

If you have a problem with Google Chrome, you need to contact Google, since they are the ones that develop it. Be mindful that the big amounts of RAM it uses up when browsing multiple tabs is not a bug, but rather a "feature" of Chrome. Also, be mindful that the impossibility of having many tabs in the same window is not a bug, but rather a "feature" of Chrome. Bear in mind, in addition, that the relatively poverty of add-ons for Google Chrome is not as much due to its age as it is to the impossibility of developing add-ons for it that are as rich as those for Firefox. Don't forget either that the fact that Chrome will send, by default, potentially private information to Google is not a bug, but rather a "feature" of Chrome. You may also end up finding the very same problems you found in Firefox, if those were due to careless usage of add-ons or an infected system. For any usability problems, you will need to contact Google directly, too.

Also, if you are using another browser out of spite or because you can't fix your problem with Firefox, I will remind you that Mozilla is a non-profit, public service organization, and, as such, doesn't have the same financial interests Google (or any other company developing a major web browser) does. Mozilla's objective is that you, the user, use the browser you want, be if Firefox or any other browser. If you want to use Firefox but can't, due to a problem, I'm glad to work with you the best I know and can to fix it. If you actually want to use another browser, then I'm happy that you finally found your "home", and my job is successfully done.

DGPickett 0 solutions 10 answers

Firefox went in a good direction, but should have found a way to segregate the plugins each in a separate process, so we know what is running. Maybe name the executables after the window and tabe they are running from. We cannot tell why it is running 100%, maybe a rogue plugin doing hacker-bot service. Thus, it smells really bad!

DGPickett 0 solutions 10 answers

Someone said this was optional, but what is the advantage of other options, and which option where controls this?

glib 0 solutions 1 answers

Using FF5.0 on 32-bit Vista, I see the same problem, even running in safe mode (that is, restarting using Help: Restart with Add-ons Disabled, and checking the Disable Add-ons box upon restart).

However, this restart method seems to disable add-ons only, not plugins. Is safe mode supposed to disable both add-ons and plugins? If so, then how to run in safe mode with FF5.0?

While plugin-container is consuming most of the CPU time, Process Explorer shows the command line for the errant plugin-container process as

"C:\Program Files\Mozilla Firefox\plugin-container.exe" --channel=5464.2689d820.642673042 "c:\Program Files\Microsoft Silverlight\4.0.60531.0\npctrl.dll" - -omnijar C:\Program Files\Mozilla Firefox\omni.jar 5464 \\.\pipe\gecko-crash-server-pipe.5464 plugin

This seems to suggest that the Silverlight plugin is causing the problem. Indeed, I confirm that manually disabling the Silverlight plugin (even after attempting to run in safe mode, as described above) greatly reduces the CPU usage of the plugin-container process.

sibiantony 0 solutions 3 answers

Hello all,

(Reposting the same workaround for https://support.mozilla.com/en-US/questions/708035 )

I had exactly same problem and has not appeared since I created a new profile and started using that. Unfortunately this workaround is listed as the last tip in Morbus' post above, so many wouldn't have tried that out. There seems to be some nasty bug to be fixed with old profiles ? :)

I was using Fedora 15(2.6.38.8-35.fc15.x86_64), and 64-bit firefox 5. I started noticing firefox eating away CPU a month back. For sure, I havn't noticed the same before. Occasionally, the browser started freezing and my CPU fan running in full speed. From 'top' I could see plugin-container almost at 90-100% and this would stay for 30-60 seconds. This kept repeating every 15 minutes or so... This would happen even when browser is idle - and even when there are no pages opened with flash content. I didn't have any extensions or themes installed, so was wondering what is causing this problem. There were no javascript-heavy pages opened either - even with a single-blank-idle-tab the browser would freeze and make other apps crawl.

At one point I even decided to switch to chrome, but later thought of trying some workarounds.

First I started with safe mode option - disabled all plugins - flash and googletalk-plugin. I attempted tweaking the dom.ipc.plugins.* booleans in the config. The problem was still there. Havn't thought of 'renicing' etc, which in my opinion is not a solution at all.

After reading the kb article here I attempted a profile switch. I havn't had the problem since that time, and things are normal. Firefox devs, please consider looking into this - specifically old profiles - if you think something needs to be addressed there.

Hope this helps someone.

retiredlou 0 solutions 1 answers

I have this problem when visiting sites with Flash content. I have tried everything including upgrading to latest version of flash. I don't know yet if this is resolved but there is a addon called flashblock. Check it out. Just click on addons in your option toolbar and search for "flashblock". It replaces Flash content on sites with a flash logo. You just have to click on the flash logo in the window if you wish to play.

jglynn1.2 0 solutions 1 answers

I disabled the BING add-on and it helped tremendously. I'll have to play around with the others.

coolcatsix 0 solutions 4 answers

Very good info for fixing many problems, and it's written so a computer semi-dummie like me can use it! I disabled all the plugins until my CPU usage dropped from about 90% to near zero, all the power was being taken by this: http://plus.cnbc.com/videoservice/partnerplayer.do?partnerId=1883&authkey=5ELJ%2F%2FHzQO9qe4oz5%2BeZc6jxRohXQUeXIM4X4fbYwYGEBAfZtsn8wGNJLAp8WXAtuuNhIg14%2BoLC%0Akef%2FxjwHuAi0JfLgrEaFba45Hf9KSrU%3D%0A

It's CNBC live thru my E-trade site, and it's a Shockwave Flash program. I also run a Marketcaster that is a java thing(technical term!), and I thought it would be disabled from that same plugin, but it wasn't. It seems all Adobe programs are CPU intensive! Now I know that ti improve my speed, I can't watch the CNBC parterplayer too. Now my only issue is whether I need to enable some of the others like Windows Office 2003, AOL Media Playback, Adobe Acrobat, etc., or will they run as needed? I hope someone responds to this, or even emails me at coolcatsix@aol.com. Thanks, Carl

infoforyou 0 solutions 1 answers

The cause is Kaspersky Internet Security (2012) on my system.

How I discovered this is because I disabled all add-ons and my CPU usage would still shoot up. Kaspersky has caused many other problems on my system so it was the first thing I could think of. I restarted, exited Kaspersky Internet Security then launched Firefox without any Kaspersky components running and went into the add-on tab; no problems.

If you are running Kaspersky on your system, see if this works for you.

n8399 0 solutions 1 answers

Dramatic reduction CPU use by adding ff9.0.1's plugin-container.exe to avast! a-v 6.0.1xxx's Behavior Shield >Expert Settings >Trusted Process list. Webpages also loaded much faster. Windows TaskManager and ProcessExplorer both show Firefox plugin-container.exe high cpu use with a-v tray icon scan activity when webpage is first loaded . Other a-v programs may also be suspect.

Modified by n8399

fredsone 0 solutions 2 answers

I am getting frustrated with this plugin-container high CPU usage issue... This problem has been periodically occurring for years and chasing the latest cause is a real pain in the wotsit!

Seriously, I again have high CPU usage caused by the plugin-container not playing well with others, this time the problem reappeared a short time after I let the latest Firefox update install.

So what now... do I again have to go through the arduous process of elimination, I mean, come on I just want to watch the occasional video without frying the CPU, is it really too much to ask?

Here’s an idea,

If we can’t get the plugin-container to play with others how about periodically compiling a list of user posted “fixes” so we can try the latest solutions when the CPU load goes through the roof again and again and again and…


Apart from that, I do like using Firefox :-)

Modified by fredsone

fredsone 0 solutions 2 answers

An update.

Well I started out with good intentions (again) updated all the plugins and then almost repeated the time consuming process of elimination to find the latest plugin-container related problem.

BUT, I have had enough and (like so many before me) I muttered &%$§ and disabled the plugin-container.

And guess what, the plugin-container related CPU load has dropped.

I should note that the plugin-container related CPU load would increase as the video duration increased. The load would become so bad that after about 20 minutes of video the CPU would be running at around 70-80% and the video would become choppy. Simply closing the tab that the video is playing in would almost instantly drop CPU load to around 10%. So far so good it looks promising....

However, there is more….

During my fiddling I have noticed something else, and that is Firefox.exe is also seriously CPU resource hungry. Is anyone else seeing 20-35% of CPU going to the Firefox.exe application?

Morbus 134 solutions 2338 answers

With all due respect, you're not helping anyone with your troubleshooting.

What you should do, first of all, is read and follow all suggestions that have been given in this thread and THEN you can follow up on them.

You say you've updated all your plugins, that's good. Now, have you tried disabling all your add-ons (both plugins and extensions)? If my terminology is too much for you, there's more helpful stuff posted previously.

Please do that and see if your problems persist. Tell us whether they do. If they don't, enable your add-ons one at a time until you find the culprit. This process WILL take time and effort so don't give up halfway through. Either do it and we'll help you (try to, anyway) or hire someone to do it, because we can't do it over the internet.

Here's hoping it helps and you find the solution to your problem.