X
Tap here to go to the mobile version of the site.

Support Forum

Sometimes long to load some websites (like google.com), only on firefox

Posted

Hi,

Often, like 1/10 times, it's very long (10-15 seconds) to hit a website (any website, like google.com).

I don't have this problem with other browsers (chrome, ie).

Same problem after completely reinstalled firefox (first deleting Mozilla folder in %appdata%).

Same when connect directly to modem.

Why only firefox does that ?

Hi, Often, like 1/10 times, it's very long (10-15 seconds) to hit a website (any website, like google.com). I don't have this problem with other browsers (chrome, ie). Same problem after completely reinstalled firefox (first deleting Mozilla folder in %appdata%). Same when connect directly to modem. Why only firefox does that ?

Modified by James

Chosen solution

WIth ipv6 re-enabled on firefox, on a different wifi, I have no problem.

I think that my Linksys E1200 router is too old (2011) to handle ipv6 correctly. Possible ?

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Google Update
  • Office Authorization plug-in for NPAPI browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 23.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.1.9.159
  • VLC media player Web Plugin
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

Moshy 0 solutions 2 answers

Helpful Reply

Any add-ons that may still be installed on Firefox that are running ?

Any add-ons that may still be installed on Firefox that are running ?
FredMcD
  • Top 10 Contributor
4266 solutions 59821 answers
Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? ---------------- '''https://support.mozilla.org/en-US/kb/websites-look-wrong-or-appear-differently''' '''https://support.mozilla.org/en-US/kb/firefox-slow-how-make-it-faster''' '''https://support.mozilla.org/en-US/kb/firefox-uses-too-many-cpu-resources-how-fix''' '''https://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding''' '''https://support.mozilla.org/kb/Firefox+is+already+running+but+is+not+responding'''

Question owner

Them problem also happen in safe mode.

Them problem also happen in safe mode.
FredMcD
  • Top 10 Contributor
4266 solutions 59821 answers

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

Question owner

Seems to only happen with google websites (google.com, google translate, ...).

I did previously erased all cache and cookies.

So why only google ?

Seems to only happen with google websites (google.com, google translate, ...). I did previously erased all cache and cookies. So why only google ?

Modified by trogne

Question owner

Also youtube, but that's google too.

So what's wrong with my google ?

Also youtube, but that's google too. So what's wrong with my google ?
FredMcD
  • Top 10 Contributor
4266 solutions 59821 answers

FredMcD said

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?
''FredMcD [[#answer-935216|said]]'' <blockquote> Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' websites. Is the problem still there? </blockquote>

Question owner

I just did that.

No problem after opening hundreds of google search, searching in link bar, search bar, and in google.

I then reboot in normal mode, and I cannot get the problem yet... hoping never.

I just did that. No problem after opening hundreds of google search, searching in link bar, search bar, and in google. I then reboot in normal mode, and I cannot get the problem yet... hoping never.

Question owner

In safe mode, there's no wifi.

I needed to plug the modem directly to computer.

Now I'm on wifi again. I'll see if problem occurs.

In safe mode, there's no wifi. I needed to plug the modem directly to computer. Now I'm on wifi again. I'll see if problem occurs.

Modified by trogne

Question owner

Problem again.

Currently loading gmail to see my mail. It took 20 seconds. Why ?

Then open new tab for google : another 20 seconds. This is crazy.

What's going on with my google ?

I repeat that this problem is ONLY on firefox.

Everything is fine on chrome and ie. But I prefer firefox by far.

Problem again. Currently loading gmail to see my mail. It took 20 seconds. Why ? Then open new tab for google : another 20 seconds. This is crazy. What's going on with my google ? I repeat that this problem is ONLY on firefox. Everything is fine on chrome and ie. But I prefer firefox by far.

Modified by trogne

FredMcD
  • Top 10 Contributor
4266 solutions 59821 answers

I called for more help. Is the problem back with the computer in Safe Mode?

I called for more help. Is the problem back with the computer in Safe Mode?

Question owner

In safe mode, there's no wifi adapter. It works.

I have the problem only on firefox, with my wifi,

When it happens, I have to wait. I cannot open another tab, or refresh. I have to wait. When the page finally loads, I can then open the page multiple times without the problem. A minute later, the problem happens again, I have to wait again.

In safe mode, there's no wifi adapter. It works. I have the problem only on firefox, with my wifi, When it happens, I have to wait. I cannot open another tab, or refresh. I have to wait. When the page finally loads, I can then open the page multiple times without the problem. A minute later, the problem happens again, I have to wait again.

Modified by trogne

Question owner

Disabling router ipv6 do NOT help. BUT I don't have the problem by disabling ipv6 in firefox (about:config , set "network.dns.disableIPv6" to true).

I also have problems on my wifi phone using GOOGLE translate. But I cannot disable ipv6 there.

I don't think it's a router issue. I have a Linksys E1200, latest frameware, and I did resetted the factory defaults.

One day after, still no problem with the "network.dns.disableIPv6" set to true.

So, where the issue ?!? I want to use firefox with ipv6!

Disabling router ipv6 do NOT help. BUT I don't have the problem by disabling ipv6 in firefox (about:config , set "network.dns.disableIPv6" to true). I also have problems on my wifi phone using GOOGLE translate. But I cannot disable ipv6 there. I don't think it's a router issue. I have a Linksys E1200, latest frameware, and I did resetted the factory defaults. One day after, still no problem with the "network.dns.disableIPv6" set to true. So, where the issue ?!? I want to use firefox with ipv6!

Modified by trogne

Chosen Solution

WIth ipv6 re-enabled on firefox, on a different wifi, I have no problem.

I think that my Linksys E1200 router is too old (2011) to handle ipv6 correctly. Possible ?

WIth ipv6 re-enabled on firefox, on a different wifi, I have no problem. I think that my Linksys E1200 router is too old (2011) to handle ipv6 correctly. Possible ?

Modified by trogne

FredMcD
  • Top 10 Contributor
4266 solutions 59821 answers

That's not my area. That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That's not my area. That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.