X
Tap here to go to the mobile version of the site.

Support Forum

Why whenever I try to print it automatically downloads it instead?

Posted

Only when I'm in firefox, I open a document (doesn't matter what program I'm in), hit print, it automatically downloads instead of printing. I have to go to downloads, retrieve it, then print, and it prints like a bad copy. this has been happening only for the last couple of weeks. I had no problems before that printing. Help!

Only when I'm in firefox, I open a document (doesn't matter what program I'm in), hit print, it automatically downloads instead of printing. I have to go to downloads, retrieve it, then print, and it prints like a bad copy. this has been happening only for the last couple of weeks. I had no problems before that printing. Help!

Chosen solution

Try using the Applications panel of the Options page to change how Firefox handles those particular types of downloads. It sounds like PDF is the place to start:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Applications. Firefox may pause for a few seconds while it loads the list. You should then see a box listing numerous different types of content. In the box above the list, type or paste pdf and Firefox should filter it to

Portable Document Format (PDF)

On the right side, if it says "Save File" change that to "Always Ask"

Any luck?


Now, if that doesn't work:

(1) There may be other content types the site is indicating for the attachments. You can scroll the full list looking for any others that are set to "Save File" and change those.

(2) The file which stores these preferences might have become corrupted. What we usually suggest in that case is as follows:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up, and it should build a new mimeTypes.rdf file from the Windows registry and plugin data. Normally your PDF viewer will be reset back to the built-one, but you can select Adobe Acrobat if you prefer. See: How to disable the built-in PDF viewer and use another viewer.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPWLPG
  • Shockwave Flash 23.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

The problem is printing in Firefox, or printing in another application like Word, Adobe Reader, etc.?

When you call up the Print dialog (usually Ctrl+p in most Windows applications), make sure the printer listed is your actual printer and the "Print to file" box is not checked.

The problem is printing in Firefox, or printing in another application like Word, Adobe Reader, etc.? When you call up the Print dialog (usually Ctrl+p in most Windows applications), make sure the printer listed is your actual printer and the "Print to file" box is not checked.

Question owner

It didn't have a problem going to the printer before. And when I hit control P it takes me to the printer. Just when I try to print from other applications, like a PDF attachment I receive in my email in firefox, when I try to print it, it just downloads it, doesn't give me an option. Same thing when I use Dotloop, an application for our real estate transactions. I try to print a document and it automatically downloads it instead of printing.

  • Update, my coworker just said she was downloading documents in firefox in our email and a popup showed up and asked if she wanted to do this for all future transactions, she thought it only meant when downloading so she said yes. How can I undo what she did? She doesn't remember anything more about the popup. Thanks for anyone's help on this.
It didn't have a problem going to the printer before. And when I hit control P it takes me to the printer. Just when I try to print from other applications, like a PDF attachment I receive in my email in firefox, when I try to print it, it just downloads it, doesn't give me an option. Same thing when I use Dotloop, an application for our real estate transactions. I try to print a document and it automatically downloads it instead of printing. *Update, my coworker just said she was downloading documents in firefox in our email and a popup showed up and asked if she wanted to do this for all future transactions, she thought it only meant when downloading so she said yes. How can I undo what she did? She doesn't remember anything more about the popup. Thanks for anyone's help on this.
jscher2000
  • Top 10 Contributor
8758 solutions 71655 answers

Chosen Solution

Try using the Applications panel of the Options page to change how Firefox handles those particular types of downloads. It sounds like PDF is the place to start:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Applications. Firefox may pause for a few seconds while it loads the list. You should then see a box listing numerous different types of content. In the box above the list, type or paste pdf and Firefox should filter it to

Portable Document Format (PDF)

On the right side, if it says "Save File" change that to "Always Ask"

Any luck?


Now, if that doesn't work:

(1) There may be other content types the site is indicating for the attachments. You can scroll the full list looking for any others that are set to "Save File" and change those.

(2) The file which stores these preferences might have become corrupted. What we usually suggest in that case is as follows:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old.

Start Firefox back up, and it should build a new mimeTypes.rdf file from the Windows registry and plugin data. Normally your PDF viewer will be reset back to the built-one, but you can select Adobe Acrobat if you prefer. See: How to disable the built-in PDF viewer and use another viewer.

Try using the Applications panel of the Options page to change how Firefox handles those particular types of downloads. It sounds like PDF is the place to start: "3-bar" menu button (or Tools menu) > Options In the left column, click Applications. Firefox may pause for a few seconds while it loads the list. You should then see a box listing numerous different types of content. In the box above the list, type or paste ''pdf'' and Firefox should filter it to Portable Document Format (PDF) On the right side, if it says "Save File" change that to "Always Ask" Any luck? ---- Now, if that doesn't work: (1) There may be other content types the site is indicating for the attachments. You can scroll the full list looking for any others that are set to "Save File" and change those. (2) The file which stores these preferences might have become corrupted. What we usually suggest in that case is as follows: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Leaving that window open, switch back to Firefox and Exit, either: * "3-bar" menu button > "power" button * (menu bar) File > Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old. Start Firefox back up, and it should build a new mimeTypes.rdf file from the Windows registry and plugin data. Normally your PDF viewer will be reset back to the built-one, but you can select Adobe Acrobat if you prefer. See: [[How to disable the built-in PDF viewer and use another viewer]].