X
Tap here to go to the mobile version of the site.

Support Forum

Why does Firefox only block notifications till Firefox restarted?

Posted

There is this AWFUL so called FEATURE that allows websites to send users notifications even when they are not on the site.

It is called Web Push Notifications and detailed here

https://support.mozilla.org/en-US/kb/push-notifications-firefox#firefox:win7:fx48

I hate this S^$*£^, I want it OFF firefox for ANY site, I want to say do not let any site disturb me EVER.

I do not want to have to turn this ^$&$*£ off every time I load Firefox.

I do not want websites installing bloat on my computer that you call a service worker.

"Websites can install a Service Worker, a background web page with a limited set of functionality, that can subscribe to the push service. "

I do not want to have to maintain a list of &*£&&$ sites that can and can't send me ^£&*£, if I want something I will go look for it, so thanks but NO THANKS.

I DO NOT WANT UPDATES EVER FROM ANYBODY.

Not just for this session, EVER, so how do I disable this &££&(

Now I realise that may help Firefox monetise me as a user, take money from commercial sites and force me to take it, file that under HOW TO LOSE USERS AND TRUST FOREVER.

If you had put a section in

https://support.mozilla.org/en-US/kb/push-notifications-firefox#firefox:win7:fx48

Telling users how to get rid of this rubbish I would not have to post this or get so frustrated with Firefox.

There is this AWFUL so called FEATURE that allows websites to send users notifications even when they are not on the site. It is called Web Push Notifications and detailed here https://support.mozilla.org/en-US/kb/push-notifications-firefox#firefox:win7:fx48 I hate this S^$*£^, I want it OFF firefox for ANY site, I want to say do not let any site disturb me EVER. I do not want to have to turn this ^$&$*£ off every time I load Firefox. I do not want websites installing bloat on my computer that you call a service worker. "Websites can install a Service Worker, a background web page with a limited set of functionality, that can subscribe to the push service. " I do not want to have to maintain a list of &*£&&$ sites that can and can't send me ^£&*£, if I want something I will go look for it, so thanks but NO THANKS. I DO NOT WANT UPDATES EVER FROM ANYBODY. Not just for this session, EVER, so how do I disable this &££&( Now I realise that may help Firefox monetise me as a user, take money from commercial sites and force me to take it, file that under HOW TO LOSE USERS AND TRUST FOREVER. If you had put a section in https://support.mozilla.org/en-US/kb/push-notifications-firefox#firefox:win7:fx48 Telling users how to get rid of this rubbish I would not have to post this or get so frustrated with Firefox.

Additional System Details

Installed Plug-ins

  • Citrix Online App Detector Plugin
  • LastPass Plugin
  • Shockwave Flash 23.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5337 solutions 39633 answers

In about:config - dom.push.enabled = double-click to toggle it to false.

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

In about:config - '''dom.push.enabled''' = double-click to toggle it to false. https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Question owner

the-edmeister said

In about:config - dom.push.enabled = double-click to toggle it to false. https://support.mozilla.org/en-US/kb/about-config-editor-firefox

MANY thanks @the-edmeister It would be great if they added that to the page I referenced under

How to disable this feature completely

One of the things I think make Firefox slow is background tasks we do not know are running, I am going to try your setting and report back in a day or so to see if it improves performance.

Many thanks for your prompt response.

''the-edmeister [[#answer-931166|said]]'' <blockquote> In about:config - '''dom.push.enabled''' = double-click to toggle it to false. https://support.mozilla.org/en-US/kb/about-config-editor-firefox </blockquote> MANY thanks @the-edmeister It would be great if they added that to the page I referenced under How to disable this feature completely One of the things I think make Firefox slow is background tasks we do not know are running, I am going to try your setting and report back in a day or so to see if it improves performance. Many thanks for your prompt response.
jscher2000
  • Top 10 Contributor
8026 solutions 65605 answers

Very few sites use this feature -- you would know because you would have had to give site-specific permission -- so if you have issues with Firefox being slow, this is unlikely to make any difference.

Is the slowness a new issue? For general suggestions, take a look at the following article, but also feel free to describe more specific symptoms:

Quick fixes if your Firefox slows down

Very few sites use this feature -- you would know because you would have had to give site-specific permission -- so if you have issues with Firefox being slow, this is unlikely to make any difference. Is the slowness a new issue? For general suggestions, take a look at the following article, but also feel free to describe more specific symptoms: [[Firefox is slow - How to make it faster]]
smed79 5 solutions 29 answers

Helpful Reply

Firefox/Mozilla should give us the ability to disable completely the Web Push Notifications feature https://support.mozilla.org/questions/1139372

Firefox/Mozilla should give us the ability to disable completely the '''Web Push Notifications''' feature https://support.mozilla.org/questions/1139372
jscher2000
  • Top 10 Contributor
8026 solutions 65605 answers

Hi SMed79, I added some replies to your thread.

Hi SMed79, I added some replies to your thread.
jscher2000
  • Top 10 Contributor
8026 solutions 65605 answers

Helpful Reply

To clarify for anyone else finding this thread:

Regular notifications end when you close the last tab for a site. Web push notifications keep a connection to the site in the background so you can get notifications even after the last tab for the site is closed (until you exit Firefox). If you still get permission requests after disabling push, you probably are visiting sites using regular (non-push) notifications.

For that:

Site-Specific Permissions/Blocks

While viewing the problem site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Session Do Not Disturb

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.

All-Site Persistent Disable

There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

Unlike setting dom.push.enabled to false, this doesn't prevent sites from using push for other features, if any were to become important in the future, who knows.

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Hopefully that gives you a useful range of options.

To clarify for anyone else finding this thread: '''Regular notifications''' end when you close the last tab for a site. '''Web push notifications''' keep a connection to the site in the background so you can get notifications even after the last tab for the site is closed (until you exit Firefox). '''If you still get permission requests after disabling push, you probably are visiting sites using regular (non-push) notifications.''' For that: '''''Site-Specific Permissions/Blocks''''' While viewing the problem site, you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either: * right-click a blank area of the page and choose View Page Info > Permissions * (menu bar) Tools menu > Page Info > Permissions * click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block). There's no save button for this panel, changes are saved as you go. '''''Session Do Not Disturb''''' To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either: * Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content * Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content * Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content * Anyone: Type or paste '''about:preferences#content''' in the address bar and press Enter/Return (you can bookmark this for faster future access) On the right side, under "Notifications", check the "Do not disturb me" box. '''''All-Site Persistent Disable''''' There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webno''' and pause while the list is filtered (3) To disable PUSH NOTIFICATIONS, double-click the '''dom.webnotifications.serviceworker.enabled''' preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site ''Unlike setting dom.push.enabled to false, this doesn't prevent sites from using push for other features, if any were to become important in the future, who knows.'' (4) To disable ALL NOTIFICATIONS, double-click the '''dom.webnotifications.enabled''' preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites Hopefully that gives you a useful range of options.
smed79 5 solutions 29 answers

Switching dom.webnotifications.enabled to false that's what i'm looking for :)

Thank you.

Switching '''dom.webnotifications.enabled''' to '''false''' that's what i'm looking for :) Thank you.

Modified by smed79