X
Tap here to go to the mobile version of the site.

Support Forum

Firefox 49 changes windows (7) aero theme to basic once opened

Posted

however once i start firefox in safemode it keeps the win aero theme. its a fresh install of firefox and the only thing i have noticed is in the new version of firefox the exit and minimize buttons are gone. and when i start in safe mode they come back along with firefoxes ability to run without changing my windows theme to basic again. been searching the internet for days on this and cant find a conclusion Thanks for all your help

however once i start firefox in safemode it keeps the win aero theme. its a fresh install of firefox and the only thing i have noticed is in the new version of firefox the exit and minimize buttons are gone. and when i start in safe mode they come back along with firefoxes ability to run without changing my windows theme to basic again. been searching the internet for days on this and cant find a conclusion Thanks for all your help

Chosen solution

Let's try this; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 23.0 r0
  • 5.1.50901.0

Application

  • Firefox 49.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
  • Support URL: https://support.mozilla.org/1/firefox/49.0.1/WINNT/en-US/

Extensions

  • Multi-process staged rollout 1.2 (e10srollout@mozilla.org)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 460
  • adapterDescription2: Intel(R) HD Graphics 4000
  • adapterDeviceID: 0x0e22
  • adapterDeviceID2: 0x0162
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterRAM: 1024
  • adapterRAM2: Unknown
  • adapterSubsysID: 34fc1458
  • adapterSubsysID2: 0000000c
  • adapterVendorID: 0x10de
  • adapterVendorID2: 0x8086
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.21976
  • driverDate: 7-10-2016
  • driverDate2: 5-25-2015
  • driverVersion: 10.18.13.6881
  • driverVersion2: 10.18.10.4226
  • failures: [u'CP+[GFX1]: DoesD3D11TextureSharingWork_SourceMutexTimeout', u'CP+[GFX1]: DoesD3D11TextureSharingWork_SourceMutexTimeout']
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • indices: [0, 1]
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'ApzWheelInput': 1}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 460 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8693 solutions 71058 answers

Helpful Reply

Could the problem be linked to your Firefox shortcut (desktop shortcut or pinned taskbar button)? There are a bunch of checkboxes on the Compatibility tab that could possible cause issues. To check for that, either:

  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties

Windows normally will select the Shortcut tab. Click the Compatibility tab. For best results, make sure no checkboxes are checked here. (Example screenshot attached.)

Could the problem be linked to your Firefox shortcut (desktop shortcut or pinned taskbar button)? There are a bunch of checkboxes on the Compatibility tab that could possible cause issues. To check for that, either: * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. Click the Compatibility tab. For best results, make sure no checkboxes are checked here. (Example screenshot attached.)

Question owner

thanks for your quick response, none of the "compatibility" buttons were checked... if i open firefox through the programs list it does the same thing

thanks for your quick response, none of the "compatibility" buttons were checked... if i open firefox through the programs list it does the same thing
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Chosen Solution

Let's try this; Type about:preferences#advanced<Enter> in the address bar. Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control>(Mac=<Command>) <Shift> A)

On the left side of the page, select Appearance. Then select Default.

Now restart Firefox.

Let's try this; Type '''about:preferences#advanced'''<Enter> in the address bar. Under '''Advanced,''' Select '''General.''' Look for and turn off '''Use Hardware Acceleration'''. Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager.''' Hot key; '''<Control>''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Appearance.''' Then select '''Default.''' Now restart Firefox.

Question owner

THATS IT! all i needed to do was uncheck the hardware acceleration, what does that mean for performance? i feel like my computer is pretty well capable of running with hardware acceleration, is it something with my video card maybe? all bonus questions but thank you all so much for your quick responses and getting to the bottom of this all!

A+

THATS IT! all i needed to do was uncheck the hardware acceleration, what does that mean for performance? i feel like my computer is pretty well capable of running with hardware acceleration, is it something with my video card maybe? all bonus questions but thank you all so much for your quick responses and getting to the bottom of this all! A+
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.


I have filed a bug report; 1310933 - Firefox 49 changes windows (7) aero theme to basic once opened

Hello, I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support. ---------------- I have filed a bug report; 1310933 - Firefox 49 changes windows (7) aero theme to basic once opened
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

ekips009 The bug people would like you to answer some questions. Please follow this link;

https://bugzilla.mozilla.org/show_bug.cgi?id=1310933#c1 Could you type about:support in the location bar and copy here the section "graphics".

'''ekips009''' The bug people would like you to answer some questions. Please follow this link; https://bugzilla.mozilla.org/show_bug.cgi?id=1310933#c1 Could you type '''about:support''' in the location bar and copy here the section "graphics".

Question owner

jscher2000 said

Could the problem be linked to your Firefox shortcut (desktop shortcut or pinned taskbar button)? There are a bunch of checkboxes on the Compatibility tab that could possible cause issues. To check for that, either:
  • Desktop shortcut: right-click the icon, choose Properties
  • Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties
Windows normally will select the Shortcut tab. Click the Compatibility tab. For best results, make sure no checkboxes are checked here. (Example screenshot attached.)

UPDATE!! So i had to do a fresh install of Firefox because it had gotten removed on accident and the problem was back again! went through the hardware acceleration steps and it was still changing back to basic, then i went through the compatibility settings under the "shortcut" properties and "disable desktop composition" was checked, unchecked it and now were all good again! so last time nothing was checked from the get go, and it was the hardware acceleration checkbox, and now its the compatibility tab check boxes... maybe you guys just fixed the problem initially? either way just wanted to update and thank you all again!

''jscher2000 [[#answer-927754|said]]'' <blockquote> Could the problem be linked to your Firefox shortcut (desktop shortcut or pinned taskbar button)? There are a bunch of checkboxes on the Compatibility tab that could possible cause issues. To check for that, either: * Desktop shortcut: right-click the icon, choose Properties * Pinned taskbar icon: right-click the icon, right-click Mozilla Firefox, choose Properties Windows normally will select the Shortcut tab. Click the Compatibility tab. For best results, make sure no checkboxes are checked here. (Example screenshot attached.) </blockquote> UPDATE!! So i had to do a fresh install of Firefox because it had gotten removed on accident and the problem was back again! went through the hardware acceleration steps and it was still changing back to basic, then i went through the compatibility settings under the "shortcut" properties and "disable desktop composition" was checked, unchecked it and now were all good again! so last time nothing was checked from the get go, and it was the hardware acceleration checkbox, and now its the compatibility tab check boxes... maybe you guys just fixed the problem initially? either way just wanted to update and thank you all again!

Question owner

p.s. FredMcD i just updated on the bugzilla site, sorry for the late responses

p.s. FredMcD i just updated on the bugzilla site, sorry for the late responses
FredMcD
  • Top 10 Contributor
4246 solutions 59390 answers

That was very good work. Well done. Please flag your https://support.mozilla.org/en-US/questions/1143455#answer-943596 post as Solved Problem so others will know.

That was very good work. Well done. Please flag your https://support.mozilla.org/en-US/questions/1143455#answer-943596 post as '''Solved Problem''' so others will know.