Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't find Firefox menu! I'm trying to opt out of Web Push...and want to stop all sites from sending me messages...Please help!

  • 2 replies
  • 2 have this problem
  • 3124 views
  • Last reply by jscher2000

more options

I was playing words w/friends on FaceBook, and the Web Push message came up, (which I thought was just from FB, and after I said

 okay to it, I found out it was not, and I want to Opt Out! but can't find the Firefox Menu so that I can select "Options" like it says to. 
  Please Help! 
  And Thank you in Advance!
  Ann Farnum

Chosen solution

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.


There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Does that work for you?

Read this answer in context 👍 4

All Replies (2)

more options

Hi Ann, do you recall what site was sending you notifications? Here are three possible situations:

Scenario #1: You gave Website A permission to display desktop notifications. You often visit Website A so you open a page there and use the Page Info dialog's Permissions panel to undo the permission. (Details below.)

Scenario #2: You gave Website A permission to display desktop notifications but you do not want to visit the site ever again. You open the Library dialog ("Show All History"), search for the site, right-click an entry from the site, and choose "Forget About this Site" to clear its history and permissions. (This also clears bookmarks, cookies, passwords, everything for that site.)

Scenario #3: You don't know what website got permission to send the notifications. This is the trickiest situation because there are only quite nerdy ways to figure out what site it was.

Could you let me know which scenario matches yours the most closely?


While viewing a site (Scenario #1), you can change the notifications permission using the Permissions panel of the Page Info dialog. To call that up, either:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or "i" icon to the left of the site address, then the ">" icon, then More Information > Permissions

Scroll down to "Receive Notifications" and you can check the "Use default" box (so you are prompted in the future) or uncheck that box and select the permission you prefer (for example, Block).

There's no save button for this panel, changes are saved as you go.

Note: This permission is part of a category of data called Site Preferences. If you have Firefox set to clear your history at shutdown, that feature has a checkbox for whether to clear the Site Preferences along with the other data. Don't clear the site preferences or Firefox will forget your setting.

more options

Chosen Solution

To disable all desktop notifications for the rest of your Firefox session (i.e., until you exit Firefox), you can turn on "Do Not Disturb" on the Options/Preferences page, Content panel. Either:

  • Windows: "3-bar" menu button (or Tools menu) > Options, then in the left column click Content
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences, then in the left column click Content
  • Linux: "3-bar" menu button (or Edit menu) > Preferences, then in the left column click Content
  • Anyone: Type or paste about:preferences#content in the address bar and press Enter/Return (you can bookmark this for faster future access)

On the right side, under "Notifications", check the "Do not disturb me" box.


There are two different preferences for notifications, a master switch, and one which is specific to background (web push) notifications that can appear after you leave the site which sends them.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webno and pause while the list is filtered

(3) To disable PUSH NOTIFICATIONS, double-click the dom.webnotifications.serviceworker.enabled preference to switch its value from true to false -- sites can still generate desktop notifications while you have a tab open to the site

(4) To disable ALL NOTIFICATIONS, double-click the dom.webnotifications.enabled preference to switch its value from true to false -- this is a master switch, you won't get any desktop notifications from sites

Does that work for you?