Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I stop Firefox from opening on startup?

  • 8 replies
  • 1 has this problem
  • 3481 views
  • Last reply by FredMcD

more options

I've checked MSconfig and firefox isn't there to enable/disable. Version 48.0.1 Windows 10

Chosen solution

That is good to hear. Please flag your last post as Solved Problem so others will know.

Read this answer in context 👍 0

All Replies (8)

more options

Does Firefox start up to your home page or previous session, or to another specific address?

I haven't used MSConfig in years, so perhaps it is duplicative, but do you want to try this Microsoft utility:

Autoruns: https://technet.microsoft.com/en-us/sysinternals/bb963902.aspx

more options

What does the browser open to?

more options

It'll open up to msn.com. It's not set to my default homepage nor do I ever go to it.

more options

Something on your start instructions is calling MSN. You have to find it and shut it down.

Autoexec.bat Task Scheduler msconfig.exe

more options

I'm on windows 10.

Nothing in msconfig, and autoexec doesn't exist or windows won't show it. Tried looking for it manually and no joy. Nothing in Task Scheduler either.

more options
more options

So whatever was causing it stopped without me making any changes. I think Firefox updated yesterday and since then it's stopped auto opening on startup.

Thanks for the help anyways everyone.

more options

Chosen Solution

That is good to hear. Please flag your last post as Solved Problem so others will know.