X
Tap here to go to the mobile version of the site.

Support Forum

You Tube message: browser does not currently recognise any of the video formats

Posted

I would first like to thank everyone for previous help/support. I am a 68 year old dedicated Firefox user dismayed by this continued issue with You Tube. When I select a video to watch I first get a flashed message saying “Your browser does not currently recognise any of the video formats available, click here to visit our frequently asked questions about HTML5 video”. Normally the flash is so fast it is impossible to read but this time a third party website held it in place of the captioned video so I captured the screen. Clicking as requested does not offer any direct solution and as an every day user I am confused by what happens next. The video begins as per normal when I go to full screen the colours are saturated and the resolution below normal. The video can run for an unlimited time, before it freezes after a random time duration and will not start again or play any other video. To illustrate this as a Firefox issue is easily sampled by comparing the same use of You Tube on 'Chrome'. None of these events take place on Chrome and the Chrome browser video is fine. I am just an ordinary user, can you advise please? Thanks Tom Leigh

I would first like to thank everyone for previous help/support. I am a 68 year old dedicated Firefox user dismayed by this continued issue with You Tube. When I select a video to watch I first get a flashed message saying “Your browser does not currently recognise any of the video formats available, click here to visit our frequently asked questions about HTML5 video”. Normally the flash is so fast it is impossible to read but this time a third party website held it in place of the captioned video so I captured the screen. Clicking as requested does not offer any direct solution and as an every day user I am confused by what happens next. The video begins as per normal when I go to full screen the colours are saturated and the resolution below normal. The video can run for an unlimited time, before it freezes after a random time duration and will not start again or play any other video. To illustrate this as a Firefox issue is easily sampled by comparing the same use of You Tube on 'Chrome'. None of these events take place on Chrome and the Chrome browser video is fine. I am just an ordinary user, can you advise please? Thanks Tom Leigh
Attached screenshots

Chosen solution

jscher2000 Disabling the YouTube related add-ons has solved the problem. My very sincere thanks for the education as well as the solution. As to which one? Well at this stage they are all superfluous to needs. Since my Internet speed has increased, eliminating the annoying buffering, downloading a video to watch in comfort has become obsolete. I am so relieved its lifted a depressing weight of my You Tube viewing. Cheers

Read this answer in context 6

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • GEPlugin
  • Google Update
  • Picasa plugin
  • Shockwave Flash 22.0 r0
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • Firefox 48.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
  • Support URL: https://support.mozilla.org/1/firefox/48.0/WINNT/en-GB/

Extensions

  • Adblock Plus 2.7.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.2.1-signed.1-signed (adblockpopups@jessehakanen.net)
  • AdBlocker Ultimate 2.23 (adblockultimate@adblockultimate.net)
  • Ant Video Downloader 2.4.7.43 (anttoolbar@ant.com)
  • Avast SafePrice 10.3.5.39 (sp@avast.com)
  • betterFox - Make your browsing experience 15% faster. 6.1.1 (multirevenue@googlemail.com)
  • Click&Clean 4.1.1-signed.1-signed (clickclean@hotcleaner.com)
  • ColorfulTabs 30.0.7 ({0545b830-f0aa-4d7e-8820-50a4629a56fe})
  • Easy Translate 1.34.1-signed.1-signed (jid1-f7dnBeTj8ElpWQ@jetpack)
  • Empty Cache Button 2.7.1-signed.1-signed ({4cc4a13b-94a6-7568-370d-5f9de54a9c7f})
  • Firefox Hello 1.4.3 (loop@mozilla.org)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF})
  • Multi-process staged rollout 1.0 (e10srollout@mozilla.org)
  • NoSquint Plus 47.8.0 (zoomlevelplus@zoomlevelplus.net)
  • Pinterest Guest 1.1.0 (jid1-SWdspnBEetWxoA@jetpack)
  • Pocket 1.0.4 (firefox@getpocket.com)
  • Pop-up Controller 0.9.1-signed.1-signed (jid1-MIAJd5BiK7V4Pw@jetpack)
  • Right Click Translate 0.3.2 (jid1-hhBMO3ij7xRsEw@jetpack)
  • Session Manager 0.8.1.12 ({1280606b-2510-4fe0-97ef-9b5a22eafe30})
  • Stop Ads 0.0.4 (@stopads)
  • Text-to-Speech (TTS) 0.1.5 (jid1-dqs9BdQga04hBw@jetpack)
  • To Google Translate 0.3.1-signed.1-signed (jid1-93WyvpgvxzGATw@jetpack)
  • Translate This! 3.5.0 (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • Webmail Ad Blocker 4.29 (gmailnoads@mywebber.com)
  • Youtube Downloader - 4K Download 8.2.0 (paulsaintuzb@gmail.com)
  • YouTube Flash Video Player 47.1 ({f3bd3dd2-2888-44c5-91a2-2caeb33fb898})
  • YouTube High Definition 47.0 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc})
  • Avast Online Security 10.3.3.44 (wrc@avast.com) (Inactive)
  • Google Maps Button 1.1.1-signed.1-signed ({537D2976-0C4F-4c28-952D-F0871637AF5D}) (Inactive)
  • Hoxx VPN Proxy 1.8.7 (@hoxx-vpn) (Inactive)
  • Make Address Bar Font Size Bigger 1.3.2.1-signed.1-signed (addressBarFontSizeBigger@papafresh.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) Iris(TM) Graphics 6100
  • adapterDescription2:
  • adapterDeviceID: 0x162b
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 20578086
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: B ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10586.494
  • driverDate: 5-4-2016
  • driverDate2:
  • driverVersion: 20.19.15.4454
  • driverVersion2:
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D11 API
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) Iris(TM) Graphics 6100 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: Yes
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Could you check this test page:

https://www.youtube.com/html5

Windows 10 usually would show 5 blue boxes and the last box red. How does yours look?

I don't know whether you are in any of the European countries where Microsoft is required to sell Windows "unbundled" from various media technologies but if you are, you will need this feature pack to enable Firefox to decode MPEG files:

https://support.microsoft.com/en-us/kb/3099229

Could you check this test page: https://www.youtube.com/html5 Windows 10 usually would show 5 blue boxes and the last box red. How does yours look? I don't know whether you are in any of the European countries where Microsoft is required to sell Windows "unbundled" from various media technologies but if you are, you will need this feature pack to enable Firefox to decode MPEG files: https://support.microsoft.com/en-us/kb/3099229

Question owner

Tahnks for such a quick responce I am actually in Australia and I purchased my windows 10 version a few months ago ahead of buying a NUC 5i7. attached is the screen shot of the test page. I got two red boxes. I then went to the support site which acknowledged my download but there was no install window and no record of the download in my download progress?

Tahnks for such a quick responce I am actually in Australia and I purchased my windows 10 version a few months ago ahead of buying a NUC 5i7. attached is the screen shot of the test page. I got two red boxes. I then went to the support site which acknowledged my download but there was no install window and no record of the download in my download progress?
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Helpful Reply

Hmm, that's a very unusual combination of red boxes. Possibly one of your video recording/downloading extensions is changing things to try to force a particular format it can capture.

You can view, disable, and often remove or configure extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then review your list on the right side and consider whether anything video-related could be disabled or reconfigured.

Settings Check

Some video capabilities can be blocked by these settings. Given your pattern of boxes, these might all be fine, it's hard to know.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

Media Foundation: necessary to decode H.264/MP4 media

(2) In the search box above the list, type or paste wmf and pause while the list is filtered

(3) If the media.wmf.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

Key H.264/MP4 Preferences

(4) In the search box above the list, type or paste mp4 and pause while the list is filtered

(5) If the media.mediasource.mp4.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

(6) If the media.mp4.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

Key WebM Preferences

(7) In the search box above the list, type or paste webm and pause while the list is filtered

(8) The media.mediasource.webm.enabled preference usually is disabled, but yours is enabled, which is fine unless you experience stability problems on YouTube

(9) If the media.webm.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

If you changed anything, please test again. If not, hmm...

Hmm, that's a very unusual combination of red boxes. Possibly one of your video recording/downloading extensions is changing things to try to force a particular format it can capture. You can view, disable, and often remove or configure extensions on the Add-ons page. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then review your list on the right side and consider whether anything video-related could be disabled or reconfigured. '''''Settings Check''''' Some video capabilities can be blocked by these settings. Given your pattern of boxes, these might all be fine, it's hard to know. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. ''Media Foundation: necessary to decode H.264/MP4 media'' (2) In the search box above the list, type or paste '''wmf''' and pause while the list is filtered (3) If the '''media.wmf.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true ''Key H.264/MP4 Preferences'' (4) In the search box above the list, type or paste '''mp4''' and pause while the list is filtered (5) If the '''media.mediasource.mp4.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true (6) If the '''media.mp4.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true ''Key WebM Preferences'' (7) In the search box above the list, type or paste '''webm''' and pause while the list is filtered (8) The '''media.mediasource.webm.enabled''' preference usually is disabled, but yours is enabled, which is fine unless you experience stability problems on YouTube (9) If the '''media.webm.enabled''' preference is bolded and "user set" to false, double-click it to restore the default value of true If you changed anything, please test again. If not, hmm...

Question owner

jscher2000 This is a prompt pretest thank you once again for your advice before I begin trying your suggestions. Your Hmmm over my problem only adds to my belief this is one of those issues threatened by the article I read, which claimed Microsoft, Google & Yahoo as unlikely bed partners were joining forces determined to target 'add blocker' users & specifically 'Firefox users'. Excuse me but I thought I kept the article URL bookmarked but can't find it right now. I will follow your instructions and report back tomorrow. cheers!

jscher2000 This is a prompt pretest thank you once again for your advice before I begin trying your suggestions. Your Hmmm over my problem only adds to my belief this is one of those issues threatened by the article I read, which claimed Microsoft, Google & Yahoo as unlikely bed partners were joining forces determined to target 'add blocker' users & specifically 'Firefox users'. Excuse me but I thought I kept the article URL bookmarked but can't find it right now. I will follow your instructions and report back tomorrow. cheers!

Question owner

Please excuse my delay. Thank you for the easy to follow guided check of my settings. Attached is what I found & as a result made no changes. The use of YouTube starts quite normally and to all intents and purposes appears to be fine. But after an unknown irregular period of 'play' suddenly the image freezes. This does not happen in 'Chrome', I don't use any other browser. This issue is specific to the YT website or any video on any website which uses YT to display a video. I find it interesting that the blue & red box configuration puzzles you. I am grateful for your knowledge and patience thanks.

Please excuse my delay. Thank you for the easy to follow guided check of my settings. Attached is what I found & as a result made no changes. The use of YouTube starts quite normally and to all intents and purposes appears to be fine. But after an unknown irregular period of 'play' suddenly the image freezes. This does not happen in 'Chrome', I don't use any other browser. This issue is specific to the YT website or any video on any website which uses YT to display a video. I find it interesting that the blue & red box configuration puzzles you. I am grateful for your knowledge and patience thanks.
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Helpful Reply

Could you try it with your video-related extensions disabled?

Open the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then disable Ant and the three YouTube extensions. Most likely a link will appear to restart Firefox so the disablement becomes effective.

Any difference?

Could you try it with your video-related extensions disabled? Open the Add-ons page using either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then disable Ant and the three YouTube extensions. Most likely a link will appear to restart Firefox so the disablement becomes effective. Any difference?

Chosen Solution

jscher2000 Disabling the YouTube related add-ons has solved the problem. My very sincere thanks for the education as well as the solution. As to which one? Well at this stage they are all superfluous to needs. Since my Internet speed has increased, eliminating the annoying buffering, downloading a video to watch in comfort has become obsolete. I am so relieved its lifted a depressing weight of my You Tube viewing. Cheers

jscher2000 Disabling the YouTube related add-ons has solved the problem. My very sincere thanks for the education as well as the solution. As to which one? Well at this stage they are all superfluous to needs. Since my Internet speed has increased, eliminating the annoying buffering, downloading a video to watch in comfort has become obsolete. I am so relieved its lifted a depressing weight of my You Tube viewing. Cheers