Search Support

Somehow the login for my online banking has been saved somewhere and I need to delete that for security reasons.

  • 13 replies
  • 2 have this problem
  • 752 views
  • Last reply by HVOIGT

more options

I need to remove two different saved logins that appear when I attempt to login to my online banking account. I want to be able to delete them so that I have to actually enter the login every time I want to access my account.

Chosen solution

Thank you. I think that I am good now. We'll see after rebooting the PC and try the site again. I appreciate your assistance.

Read this answer in context 👍 0

All Replies (13)

more options

Please check here if you haven't already:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Security. Then on the right side, find the "Saved Logins" button.

more options

You can set Firefox to not remember logins for specific sites, and of course delete any that have been saved. Please see

A quick method of getting to security settings is keying in to the address bar

about:preferences#security

There you are able to view and edit saved logins, and view and edit the list of sites in exceptions.

Possibly also of interest

You may also wish to use a private browsing Window whenever using financial etc sites, that will then not save cookies of logins etc.

more options

jscher2000 said

Please check here if you haven't already: "3-bar" menu button (or Tools menu) > Options In the left column, click Security. Then on the right side, find the "Saved Logins" button.
more options

I previously removed the login. It doesn't appear there. Thanks for the suggestion though.

more options

John99 said

You can set Firefox to not remember logins for specific sites, and of course delete any that have been saved. Please see A quick method of getting to security settings is keying in to the address bar about:preferences#security There you are able to view and edit saved logins, and view and edit the list of sites in exceptions. Possibly also of interest You may also wish to use a private browsing Window whenever using financial etc sites, that will then not save cookies of logins etc.
more options

Thanks for the suggestion. But that hasn't cleared anuthing.

more options

Is it form history? Form history is stored separately from logins, and isn't paired (i.e., fields are stored independently).

Form history for a field can be removed by arrowing down to an entry and pressing the Delete key on the keyboard.

To view and edit form history entries, you can use this extension: https://addons.mozilla.org/firefox/addon/form-history-control/

more options

jscher2000 said

Is it form history? Form history is stored separately from logins, and isn't paired (i.e., fields are stored independently). Form history for a field can be removed by arrowing down to an entry and pressing the Delete key on the keyboard. To view and edit form history entries, you can use this extension: https://addons.mozilla.org/firefox/addon/form-history-control/
more options

Downloading and installing the Forms add-in solved the saved login issue with my online banking account. However, the Bill Pay feature isn't working...the various accounts don't show up when I click on the icons. Works OK with Microsoft Edge.

more options

HVOIGT said

the Bill Pay feature isn't working...the various accounts don't show up when I click on the icons.

Is this a new issue or have you always had that issue in Firefox?

Could you check to see whether Tracking Protection could be causing the problem? When Firefox's Tracking Protection feature is blocking content in a page, a "shield" icon appears in the address bar, to the left of the site's URL, next to the little i-in-a-circle icon. This article has more information about this feature and how to make exceptions: What happened to Tracking Protection?.

more options

The "shield" icon isn't showing up when I get to the specific Bill Pay pages that appear blank when I click on the icons. It is a new issue for Firefox, which I have used for years and love. Thanks for the suggestion though.

more options

Have you made any changes related to cookie permissions? Sometimes banks use multiple servers and require "third party" cookies to cross over between them. This article describes how to confirm that you have cookie settings that maximize site compatibility: Websites say cookies are blocked - Unblock them.

Speaking of cookies...

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?

more options

Chosen Solution

Thank you. I think that I am good now. We'll see after rebooting the PC and try the site again. I appreciate your assistance.