Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I click on ads when I do a google search--the website loads as a blank page

  • 5 replies
  • 1 has this problem
  • 2 views
  • Last reply by ang133

more options

Many times when I search with google, I will see ads at the top or images of the things I'm searching for. For example, if I search for running shoes, I will see ads at the top of the search page for these or there will be pictures of running shoes. But if I click on the ads or the pictures it will load as a blank page. This is very annoying. How do I get these pages to load?

All Replies (5)

more options

Are they Google Shopping links, for example, a box that says "Shop for nike air on Google" above a row of images. Is that where the problem occurs?

Those links go through the googleadservices.com domain. If you use an ad blocker, that might be part of the problem.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

I am able to click on ads in safemode only. But nothing else --unchecking things, going back to a default didn't do anything.

more options

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools > Add-ons > Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via *"3-bar" menu button > Exit (Power button)

  • Windows: File > Exit
  • Mac: Firefox > Quit Firefox
  • Linux: File > Quit
more options

I did that. Then I just refreshed Firefox and lost all my open tabs. So I had to go back into the history. My solution: copy and paste ads into Internet Explorer.