X
Tap here to go to the mobile version of the site.

Support Forum

plug in check says adobe acrobact reader needs updated

Posted

The plug in check says I have version 15.10.20056.36345...I had updated adobe player minutes before...when I hit "update now" beside of acrobat reader adobe tells me I already have the newest version 15.10.20060...I checked "programs" and it also says I have15.10.20060. When I do plug in check, it still says reader adobe acrobat is vulnerable... update now..I have restarted both the browser and the whole computer..but it still says the same thing

The plug in check says I have version 15.10.20056.36345...I had updated adobe player minutes before...when I hit "update now" beside of acrobat reader adobe tells me I already have the newest version 15.10.20060...I checked "programs" and it also says I have15.10.20060. When I do plug in check, it still says reader adobe acrobat is vulnerable... update now..I have restarted both the browser and the whole computer..but it still says the same thing

Chosen solution

If you can't update the Adobe Reader program from within the reader (i.e. you have the latest version) then you can ignore the report on the plugin check page. We have seen in the past problems on the plugin check page with detecting the latest Adobe Reader version because Adobe changed the way the AR reports itself.

Adobe doesn't offer the latest version of the Adobe Reader on its downloads page and the only way to be sure that you have the latest AR version is by checking for updates in the AR program until no updates are available.

Read this answer in context 5

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.10.20056
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.73.2 for Mozilla browsers
  • Shockwave Flash 21.0 r0
  • 5.1.41212.0
  • Skype Web Plugin
  • NPWLPG

Application

  • Firefox 45.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.7.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • AVG Web TuneUp 4.2.8.608 (avg@toolbar) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 05741028
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 3-19-2012
  • driverDate2:
  • driverVersion: 8.15.10.2696
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17580 solutions 159069 answers

Chosen Solution

If you can't update the Adobe Reader program from within the reader (i.e. you have the latest version) then you can ignore the report on the plugin check page. We have seen in the past problems on the plugin check page with detecting the latest Adobe Reader version because Adobe changed the way the AR reports itself.

Adobe doesn't offer the latest version of the Adobe Reader on its downloads page and the only way to be sure that you have the latest AR version is by checking for updates in the AR program until no updates are available.

If you can't update the Adobe Reader program from within the reader (i.e. you have the latest version) then you can ignore the report on the plugin check page. We have seen in the past problems on the plugin check page with detecting the latest Adobe Reader version because Adobe changed the way the AR reports itself. Adobe doesn't offer the latest version of the Adobe Reader on its downloads page and the only way to be sure that you have the latest AR version is by checking for updates in the AR program until no updates are available.
quadrotriticale 0 solutions 3 answers

For what it's worth, the cause of this is the version reported by the nppdf32.dll that ships with Acrobat Reader. I upgraded my Acrobat Reader installation from 15.010.20056.36345 to 15.010.20060. The DLL did not change. I then uninstalled Acrobat Reader and installed version 15.010.20060, after which I checked the version in nppd32.dll -- it was still 15.010.20056.36345.

For what it's worth, the cause of this is the version reported by the nppdf32.dll that ships with Acrobat Reader. I upgraded my Acrobat Reader installation from 15.010.20056.36345 to 15.010.20060. The DLL did not change. I then uninstalled Acrobat Reader and installed version 15.010.20060, after which I checked the version in nppd32.dll -- it was still 15.010.20056.36345.

Question owner

Thanks..but could you put this in layman's terms..I think you mean that when you install the new version, it comes from adobe or is listed in the registry when you install it as the old version's number for some reason

 I just checked for updates while in the reader program and it said no updates available...have the newest update number installed...I then opened Mozilla Plug in Check and it still shows I have the old version number and that I'm "vulnerable and I need to update"..I checked to see if I have the old version still too and I don't...only the new version is listed in "programs"
Thanks..but could you put this in layman's terms..I think you mean that when you install the new version, it comes from adobe or is listed in the registry when you install it as the old version's number for some reason I just checked for updates while in the reader program and it said no updates available...have the newest update number installed...I then opened Mozilla Plug in Check and it still shows I have the old version number and that I'm "vulnerable and I need to update"..I checked to see if I have the old version still too and I don't...only the new version is listed in "programs"