Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Wrong version of addon reported by Firefox for Adobe Reader DC

  • 4 replies
  • 1 has this problem
  • 35 views
  • Last reply by guigs

more options

Firefox plugin status for Adobe Reader listed as - vulnerable version 15.10.20056.36345

My registry has the latest version listed under the Mozilla Plugin. Reg Key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\MozillaPlugins\Adobe Reader Has version 15.010.20060

Numerous references to 20056.36345 in registry even after running AdobeAcroCleaner_DC2015.

What Key does Firefox look at when checking plugin status?

All Replies (4)

more options

I think Firefox checks for version directly in the file (XPI or DLL). Is Adobe Reader DC an Extension or a Plugin?

For the first, go to about:support and see Extensions. That should tell you the ID of the add-on with the vulnerable version number. Check https://support.mozilla.org/en-US/kb/cannot-remove-add-on-extension-or-theme#w_uninstalling-manually for how to get rid of the bad version manually, if automation is not working.

For the latter, see https://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems#w_manually-uninstalling-a-plugin on how to get rid of bad versions. There's also a section on resetting the plugin database if it is acting up.

As you can see, the tl;dr is "delete or rename file(s) to repair".

more options

Thank you for the directions. They helped but did not solve. Adobe Reader DC is a plugin, about:plugins. The plugin points to a path: C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AIR\nppdf32.dll Version: 15.10.20056.36345

This dll is not updated with the latest Adobe Reader DC update Version 2015.010.20060.

1. I uninstalled Adobe Reader DC 2. Searched for nppdf32.dll. Not found on PC & folder deleted. 3. Ran AdobeAcroCleaner_DC2015 4. Installed Adobe Reader DC via https://get.adobe.com/reader/ 5. Installs nppdf32.dll Version: 15.10.20056.36345

more options

Sounds like a positive ID on the culprit; in this case I think you can only report the discrepancy to Adobe. If this is the DLL Firefox uses and checks, it needs to be updated so Firefox gets the correct version information.

It definitely appears you've installed the newest version correctly with no old version looming as a double in the background.

more options

This was one of the threads that was mentioned to have a vulnerable flag for Adobe Reader DC, would you mind confirming if it was the continuous or Classic? 15.010.20060 is the Continuous version that is recommend to update and classic may be the version that is marked as vulnerable. I don't to suggest its a typo on the Adobe Reader release without more investigation.

EDIT: It looks like the download page does not download the latest version https://support.mozilla.org/en-US/que.../1114993#answer-857939

Modified by guigs