X
Tap here to go to the mobile version of the site.

Support Forum

spell checker language selector not working

Posted

The Language selector menu from the right-click menu does not select the chosen language to use for spell checking.

I have only 1 dictionary installed, the British english dictionary, but both United kingdom and United states appear in the language menu. Selecting either of these does not work, there's no checkmark or anything next to the selected language. The spell checker works except for US/GB word spelling differences.

This started a few months ago and despite having all updates and even trying a new profile nothing seems to get the language selector to work.

The Language selector menu from the right-click menu does not select the chosen language to use for spell checking. I have only 1 dictionary installed, the British english dictionary, but both United kingdom and United states appear in the language menu. Selecting either of these does not work, there's no checkmark or anything next to the selected language. The spell checker works except for US/GB word spelling differences. This started a few months ago and despite having all updates and even trying a new profile nothing seems to get the language selector to work.

Chosen solution

oh, i've just found what was causing the problem.

The Metal Lion Australis theme i was using was causing some sort of conflict with the right-click menu, setting the theme back to default seems to fix it.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • Firefox 45.0
  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0
  • Support URL: https://support.mozilla.org/1/firefox/45.0/Linux/en-GB/

Extensions

  • Firefox Hello Beta 0.1 (loop@mozilla.org)
  • Flash Video Downloader - YouTube HD Download [4K] 9.5.1 (artur.dubovoy@gmail.com)
  • FurAffinity Extender 2.2.6.1 (faextender@neocodenetworks.com)
  • Ghostery 6.0.3 (firefox@ghostery.com)
  • Hide Unwanted Results of Google Search 1.6 (jid0-TpZJ4wPImlT1zIqfw58bD9vOeWQ@jetpack)
  • MEGA 3.4.13 (firefox@mega.co.nz)
  • Metal Lion Australis Scrollbars II 2.0.1.6 ({FDBAD97E-A258-4fe3-9CF6-60CF386C4422})
  • Places to CSV 0.5.2 ({f08a2443-ec7c-4b46-983e-21f2d8ead164})
  • Toggle animated GIFs 1.3 (giftoggle@simonsoftware.se)
  • uBlock Origin 1.6.4 (uBlock0@raymondhill.net)
  • BetterPrivacy 1.69 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3}) (Inactive)
  • FlashGot 1.5.6.13 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34}) (Inactive)
  • HTTPS-Everywhere 5.1.4 (https-everywhere@eff.org) (Inactive)
  • NoScript 2.9.0.5 ({73a6fe31-595d-460b-a920-fcc0f8843232}) (Inactive)
  • Password Exporter 1.3.1.1-signed ({B17C1C5A-04B1-11DB-9804-B622A1EF5492}) (Inactive)
  • Ubuntu Modifications 3.2 (ubufox@ubuntu.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel Open Source Technology Center -- Mesa DRI Intel(R) 915G x86/MMX/SSE2
  • adapterDeviceID: Mesa DRI Intel(R) 915G x86/MMX/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: Intel Open Source Technology Center
  • driverDate:
  • driverVersion: 1.4 Mesa 10.1.3
  • info: {u'CairoUseXRender': 1, u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 2
  • supportsHardwareH264: No;
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17573 solutions 158952 answers

Did you install the GB dictionary from the Add-ons website?

Are there dictionaries installed in the dictionaries folder in the Firefox program folder?

It is possible that Firefox is picking up dictionaries that are installed on the Linux OS level.

You can check these locations for globally installed dictionaries:

/usr/share/hunspell/
/usr/share/myspell/

You can check the spellchecker.dictionary pref on the about:config page.

Did you install the GB dictionary from the Add-ons website? *https://addons.mozilla.org/firefox/language-tools/ Are there dictionaries installed in the dictionaries folder in the Firefox program folder? It is possible that Firefox is picking up dictionaries that are installed on the Linux OS level. You can check these locations for globally installed dictionaries: /usr/share/hunspell/ /usr/share/myspell/ You can check the <b>spellchecker.dictionary</b> pref on the <b>about:config</b> page.

Question owner

The dictionary installed is

British English Dictionary (Updated) 1.19.6 (from the add-ons manager) this was installed from the addons.mozilla.org

English(GB) language pack 45.0 is installed

hunspell-en-us is installed

/usr/share/hunspell$ ls en_US.aff en_US.dic


myspell is not installed

spellchecker.dictionary is set to en-gb

The dictionary installed is British English Dictionary (Updated) 1.19.6 (from the add-ons manager) this was installed from the addons.mozilla.org English(GB) language pack 45.0 is installed hunspell-en-us is installed /usr/share/hunspell$ ls en_US.aff en_US.dic myspell is not installed spellchecker.dictionary is set to en-gb
cor-el
  • Top 10 Contributor
  • Moderator
17573 solutions 158952 answers

Does it help is you set spellchecker.dictionary to en-GB in case it is currently in lower case?

Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution.

You can find the full version of the current Firefox release (45.0) in all languages and all operating systems here:

Does it help is you set <b>spellchecker.dictionary</b> to en-GB in case it is currently in lower case? Try the Firefox version from the official Mozilla server if you currently use a version from the repositories of your Linux distribution. You can find the full version of the current Firefox release (45.0) in all languages and all operating systems here: *https://www.mozilla.org/en-US/firefox/all/

Question owner

I did not set the variable in Spellchecker.dictionary, it was set by default to en-GB.

The linux version from the official mozilla server doesn't even run.

The firefox i have is the most recent version

firefox:i386 45.0+build2-0ubuntu0.14.04.1

which was updated on 12/3/2016

I did not set the variable in Spellchecker.dictionary, it was set by default to en-GB. The linux version from the official mozilla server doesn't even run. The firefox i have is the most recent version firefox:i386 45.0+build2-0ubuntu0.14.04.1 which was updated on 12/3/2016

Chosen Solution

oh, i've just found what was causing the problem.

The Metal Lion Australis theme i was using was causing some sort of conflict with the right-click menu, setting the theme back to default seems to fix it.

oh, i've just found what was causing the problem. The Metal Lion Australis theme i was using was causing some sort of conflict with the right-click menu, setting the theme back to default seems to fix it.