Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Images not loading and general hangs in Version 44.0.2

  • 7 replies
  • 1 has this problem
  • 35 views
  • Last reply by John99

more options

Just since last night when I navigate to other pages my browser hangs for quite a bit longer than it usually does not loading the pages properly. As an example, when I scroll down my Yahoo! News homepage to read the news, some of the graphics for the thumbnails don't load. I'd had similar problems earlier in the week and a week ago, but updating my graphics seemed to have helped, but then this happened last night. Firefox 44 seems to be having lots and lots of glitches with graphics.

Anyone else having this problem? I refreshed Firefox (which required me to reinstall Classic Theme Restorer, Status-4-Evar, and QuickJava), and that didn't help.

All Replies (7)

more options

BTW, I just noticed that when I go to a new site, the url is not included in the location bar. How do I get this feature back. Sometimes I like to copy and paste the urls, and I can no longer do this.

more options

And, now, as I type a address into the location bar, it doesn't do anything.

more options

Now, when I try to open the comment section at Freep.com, it doesn't open. Nothing happens when I click on the comment link. This is something having to do with Firefox, people. What has been done with the graphics?

more options

Start Firefox in Safe Mode to check if one of the extensions (3-bar Menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: 3-bar Menu button/Tools > Add-ons > Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try to disable hardware acceleration in Firefox.

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

You need to close and restart Firefox after toggling this setting.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


See also:

more options

Do I have to restart the browser after I uncheck the acceleration checkmark? I also just noticed that embedded Tweets aren't loading propertly in my browser.

BTW, I've already done the graphic driver update.

EDIT: I see I've had this problem, before, and the embedded tweet problem was the result of Tracking Protection, which I disabled for all sites. There has to be a better default for this, or some kind of note left when updating that this will cause embedded tweets to not properly render.

Modified by FireFoxFan1

more options

Tracking Protection is only enabled in current Firefox releases when you are in Private Browsing mode and you will notice the shield in the location/address bar when content is blocked. If you have modified the involved prefs directly on the about:config page and Tracking Protection is also active in normal mode then you should be cautious and check for the shield icon.

  • privacy.trackingprotection.pbmode.enabled
  • privacy.trackingprotection.enabled
more options

Contributors Please note that Firefoxfan1 has multiple open current issues, so you may find answers or useful information in the other threads

X-Links

Modified by John99