Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 42 will not display http://nsidc.org/arcticseaicenews/ - previous versions worked OK

  • 11 replies
  • 1 has this problem
  • 12 views
  • Last reply by jscher2000

more options

This web site has always worked OK with Firefox on Windows XP. With the latest version, 42, it no longer works, although Internet Explorer 8 shows the web page OK. The page starts to load, and shows the background image, but the text and data do not display until I switch to another web site, and then the data briefly flashes on the screen before the new page starts loading. Milan Konecny

Chosen solution

I'm not sure. Can you think of any filtering add-ons or external software that might be blocking any of those domains (cdnjs.cloudflare.com, or others that do not show time bar)?

Read this answer in context 👍 0

All Replies (11)

more options

No problem here with http://nsidc.org/arcticseaicenews/


Reload the webpage while bypassing the cache using one of the following steps:

  • Hold down the Shift key and click the Reload FxReloadButton button in the navigation toolbar.

OR

  • Press Ctrl + F5 or Ctrl + Shift + R (Windows and Linux)
  • Press Command + Shift + R (Mac)

See if that solves your problem.

more options

It did NOT solve the problem. Any other ideas???

more options

ve3nzk said

It did NOT solve the problem. Any other ideas???

Yes, Try firefox in safemode. The site works fine for me on a clean version of firefox. Meaning it may be one of your addons/extensions/etc you have installed.


Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

more options

Safe mode and refresh did NOT fix the problem.

I tried the same web page on another computer with Firefox 42, and it worked fine! So it must be something peculiar with this system.

I re-loaded a backup of my profile from beginning of October, and the web page worked! Now the strage part is that I tried to do a MOZBACKUP of this working version, however Mozbackup just ran for a long time, calculating disk space - 30+ minutes, so I gave up and started Firefox again. I figured that the full cache was the problem with mozbackup, so I cleared the cache in Firefox. I then tried to access the same web page that worked before, and now it no longer loaded!

I will try to unistall Firefox, and try a fresh copy, and then switch to my old profile.....

Certainly a weird problem!

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.


Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) to see if that has effect.

more options

I tried the :Forget about this site" command, but it did not fix anything.

Any other ideas?

more options

From your description, it sounds as though Firefox had the relevant content, but was waiting on something before painting the page. The page was only painted when you initiated navigation to a different page, which probably canceled the outstanding request.

If you see this again, could you try using the Network Monitor to see what Firefox is waiting on (if my guess is correct)? Open the Web Console in the lower part of the tab using either:

  • Ctrl+Shift+k
  • Developer Tools menu

Then click Network along the top edge of the console, and finally reload the page above it. Firefox should display each request sent and the time needed to satisfy it. Does anything stick out?

Another possibility is that a long-running script was holding up painting of the page. Do you ever seen nonresponsive script dialogs, or might you have increased the timeout for slow scripts which in many cases just causes the page to hang for that much longer?

more options

Here is the result!

more options

Thanks for the screenshots. I don't know why the script from cloudflare isn't loading; that one might affect layout. Google custom search and Google analytics shouldn't hold up the page, I don't think.

more options

So what should I do???

more options

Chosen Solution

I'm not sure. Can you think of any filtering add-ons or external software that might be blocking any of those domains (cdnjs.cloudflare.com, or others that do not show time bar)?