Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On one system only, Amazon.com is stuck in text only mode - FF 42.0

  • 12 replies
  • 6 have this problem
  • 2251 views
  • Last reply by pprotus

more options

Using an older AMD system with windows XP Pro. Set it to be a POSready system via the registry, so security and updates should be current. Firefox version is 42.0. Few weeks ago, amazon.com web site changed from full-featured display with images & graphics to a text only display. I believe this to be mobile mode. No other web site gives this problem. Using the amazon fullsite URL (http://www.amazon.com/?force-full-site=1) brings-up the splash screen correctly, but using any link to leave the splash page returns the display to text only mode. This seems only to occur on the amazon.com domain. Text only mode seems to appear whenever the URL contains "amazon.com", whether or not I am logged in. Leads me to believe that this is a FF issue, as opposed to an Amazon issue. Other systems with FF 42.0 work fine. Only this one machine malfunctions. (The one where I spend 6-7 hours a day sitting.)

Chosen solution

Content blockers like Adblock Plus and NoScript can always block possibly wanted content, so you always need to check what is blocked by them and allow blocked content to see if you can make it work.

Read this answer in context 👍 0

All Replies (12)

more options

Example of amazon.com text-only strikepage (splash screen). Image attached.

more options

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

You can check the log in the Web Console for error messages and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked.

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

more options

Hopefully cor-el's suggestions will help you track it down, but this made me curious so I'll add some thoughts.

How did you discover "force-full-site=1" ? The fact that this resolves the issue very much suggests that Amazon is intentionally sending you the other version based on something it thinks it knows about your Firefox, or a cookie Firefox is sending to the site when requesting a page.

When I look up the "PosReady" hack, I can't help wondering whether that information somehow it making its way to Amazon and affecting what page you are served -- since it indicates an embedded version of Windows rather than a normal desktop version. If you inspect the headers sent by your Firefox to my test page, do you see anything unusual?

https://jeffersonscher.com/res/jstest.php

Check the "Full HTTP Request Headers" section for any reference to POS, embedded, etc.

more options

If the page width if below a specific size the server might send data formatted for other devices. Zooming a page (View > Zoom > Reset) can also affect reporting screen dimensions via JavaScript. If you have cookies set from past visits then websites can keep using this format.

more options

Hi cor-el;

Thanks for the idea. I tried clearing everything I could find. From the toolbar I went to "history>clear recent history>details". I saw seven line item selection boxes and checked (enabled) them all, and then clicked "clear now". Rebooted the system afterwards. No joy. Still seeing text-only mode on Amazon.

Hi jscher2000;

I need to visit the URL you gave me. Give me an hour or so.

more options

Hello again cor-el;

I used the process you described: "tools>options>privacy>remove individual cookies" and found about a dozen amazon cookies. I didn't know if these were new cookies, or from before yesterday. So I deleted them all. Also I set the FF theme to "default". No joy. Didn't try FF safe mode yet.

Hello jscher2000;

While searching the Amazon support blogs, I found a recommendation to engage the Amazon web site(s) using "www.amazon.com/fullsite". If you bookmark this page after it loads, the bookmark will show "http://www.amazon.com/?force-full-site=1". This didn't solve my issue. (Didn't solve it for the person who posted to the Amazon support blog, either.)

more options

Hi jscher2000;

Here are the first two info boxes from the browser test URL that you sent to me. (Attached image.) I'm not seeing any reference to POSready...but I don't understand what all of the codes mean, and so it could be there nonetheless.

Need to go AFK for a short while. Be back soon.

more options

Hi pprotus, those headers seem totally normal. I don't know why Amazon thinks you need a special page. It may be detecting the embedded aspect using a script after the page loads. I searched around the other day but couldn't uncover any technique for doing that...

more options

You can check the log in the Web Console for error messages and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked.

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.


What browser information do you see:

more options

Hah. When FF is in safe mode, amazon.com appears to work correctly. I have not yet tested everything, but on a few pages I seem to get the images, graphics, formatting, etc that all look "normal" to me. Closing FF and restarting NOT in safe mode puts amazon.com into text-only mode. Note that safe mode may not be the only actor here. I previously deleted all cache & cookies, and set the FF theme to "default".

I have not upgraded the hardware on this beast in years. And amazon.com was working fine until just recently. So I don't think that hardware acceleration is an issue. Maybe. But for now I'll set HW incompatibility to the side. My primary suspect right now, is an auto-update to one or more of my add-ons/extensions.

I have six active extensions, and five disabled extensions. Active extensions are in the image below.

Does anyone know if disabled extensions can still interfere with FF functionality? Normally, I would expect not.

Does anyone know if one or more of the extensions below has recently started to disagree with amazon.com?

more options

Chosen Solution

Content blockers like Adblock Plus and NoScript can always block possibly wanted content, so you always need to check what is blocked by them and allow blocked content to see if you can make it work.

more options

Woo-Hoo! Success! I got tired of experimenting. So I went through and deleted all of the custom/personal entries for "Adblock Plus" and for "NoScript". I also cleaned out all a number of entries in the NoScript ABE collection. Amazon never looked better, and all of my pull-downs and pop-ups work again.

Looking back, I should have done NoScript, Adblock Plus, and NoScript ABE separately...to see which was the actual source of the problem. Oops. Too late now.

Thanks to you guys for all your help. I am grateful.

Modified by pprotus