Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I eliminate Firefox crashes due to Adobe Flash?

  • 2 replies
  • 4 have this problem
  • Last reply by MGMofTulsa

more options

I have spent the better part of last Saturday working through prescribed support suggestions, due to crashes in Firefox. The crashes are caused by Adobe Flash. I have run Firefox in Safe Mode, I have refreshed it, and done the other helps. I have endured this problem for several months. Since Saturday, I have uninstalled Adobe Flash and now Firefox does not crash, nor hang. A solution would be helpful for my Windows 7 Professional system (64 bit). Thank you.

Chosen solution

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

You can check for problems with current Shockwave Flash plugin versions and try this:

See also:

more options

Thank you Cor-el for the list of solutions.

Earlier, I had tried many of the remedies and suggestions offered in Firefox helps. Now it seems that the simplest solution seems to take care of most of the problem.

That simplest is to disable hardware acceleration in the Flash plugin.

Also in my solutions, I have set the switch for the Add-On to "Ask to Activate". Thus, when Adobe Flash is needed, I have the option to activate or not. (Go to the tool bar, at the 3 bars click and see "Add-ons", go to Adobe Flash or Shockwave Flash and change the setting.)

In the weeks since I have tackled this problem, I think I have only had one crash. This is huge since I was about to give up on Firefox.

At first I read past the solution for "disable flash" since I had already tried most of the other solutions. When I went back through the list, I could have kicked myself for its simplicity.

Again, thank you Cor-el.