Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 42 not displaying some websites like other browsers

  • 14 replies
  • 2 have this problem
  • 148 views
  • Last reply by Mike416

more options

For example on this site http://www.adminarsenal.com if I go to video and then search, nothing is displayed but in Chrome I see all the search results. This seems to have just started recently. Please let me know if I need to provide any other information. Thank you in advance.

Attached screenshots

Chosen solution

This is fixed in the last release 43.0.3 Thank you

Read this answer in context 👍 0

All Replies (14)

more options

You are not showing the full Firefox window, so it isn't possible to check for special icons on the location/address bar on the Navigation Toolbar.

Are you running Firefox in private browsing mode?

Firefox 42+ has a new Tracking Protection feature that is enabled by default in Private Browsing mode. You can see a shield icon at the left end of the location/address bar when you are in private browsing mode that some content is blocked. You can disable this feature in "Options/Preferences > Privacy".

  • Options/Preferences > Privacy: "Use Tracking Protection in Private Windows"

You can see in the Web Console (Firefox menu button or Tools > Web Developer) what content is blocked. You can possibly hide other messages and only leave security related messages.

Modified by cor-el

more options

I'm not using private browsing mode.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

Are you using any blocking software / add-ons?

more options

If you use extensions (Firefox menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thanks for the suggestions...but the issue persists with cache, history, cookies, and web content cleared and it is still the same in safe mode/add-ons disabled. Hardware acceleration is disabled. Screenshots attached of add-ons/extensions.

I created a new profile and started it with add-on disabled and it's still the same. Weird right?

more options

So i was able to recreate this issue on my version of Firefox.

What i found the issue to be is a Scripting/ Css+HTML coding issue on the sites side. For some reason the results are showed in chrome (web-kit) but not Firefox? If i remember Firefox lacks support for some web-kit styles . This could be causing your issue.

more options

So to make sure I understand- there's nothing I can do about this if I view in FF? Any suggestions? Switch to another browser if I encounter this?

more options

The Inspector shows for me that LI elements for the results are present, but that is no content text in the LI elements and thus nothing shows. If I edit the code and add some text to the innerHTML of the LI element then the entry shows and can be clicked. I'm not able to find out how creating this UL container works, so I don't know where and when things go wrong in Firefox. You can see that by pasting this code in the command line of the Web Console (Firefox menu button or Tools > Web Developer).

e=$("#vid_contain li");for(i=0;E=e[i];i++){E.innerHTML="result: "+(i+1)}

Possible bookmarklet:

javascript:(function(){var e=document.querySelectorAll("#vid_contain li[onclick]");for(i=0;E=e[i];i++){E.innerHTML=E.getAttribute("onclick").replace(/^([^']*')(.+)('\))/,'$2');}})()

Modified by cor-el

more options

They are using innerText instead of textContent when setting the visible text of the list items:

var l = document.createElement('li'); var a = document.createElement('a'); a.href = '#!' + vids[value][i].name; l.innerText = vids[value][i].title; l.setAttribute('onClick', 'javascript:loadVid(\'' + vids[value][i].name + '\')'); u1.appendChild(l);

A userscript consisting just of the following (with @grant none) will allow the page to work, but I don't have time to post it right now:

HTMLElement.prototype.__defineSetter__("innerText", function (txt) {   this.textContent = txt; });

Edit: fixed wiki markup problems

Modified by jscher2000

more options

Thanks guys. But this is far beyond me.

Do I need (or should I) mark your answers as helpful or solved the issue?

more options

You can use the code that jscher2000 posted above instead of what I posted above to create a bookmarklet and invoke this bookmarklet before typing in the search bar of the Video page.

Create a new bookmark and paste the JavaScript bookmarklet code in its location field. You can do that via the right-click context menu of the Bookmarks Toolbar (New Bookmark) and name the new bookmark Video or something that suits you better.

javascript:HTMLElement.prototype.__defineSetter__("innerText",function(txt){this.textContent = txt;});

When you click this bookmark once to run the JavaScript code then you should see the names of the videos once you start typing in the search bar.

more options

In researching the cleanest way to do this, I came across an article indicating that innerText may appear in Firefox 45 (http://perfectionkills.com/the-poor-m.../#update). But you still need a workaround until then...

This is the combination:

(1) Greasemonkey extension: https://addons.mozilla.org/firefox/addon/greasemonkey/

(2) User script: https://greasyfork.org/en/scripts/13962-innertext

more options

It works in the current Nightly build of Firefox 45 (landed a few weeks ago at around Nov 2).

  • Bug 264412 - (innertext) Add support for element.innerText

Modified by cor-el

more options

Chosen Solution

This is fixed in the last release 43.0.3 Thank you