Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube videos wont play. Has black screen and thumbnails are same.

  • 14 replies
  • 4 have this problem
  • 319 views
  • Last reply by cor-el

more options

The videos wont play or load at all. As will the thumbnails. The comments section constantly says "loading". I have tried every thing listed on the website here to fix these problems. The only thing that has worked to be honest was loading Internet Explorer. Adblock plus and Flashplayer plugins are either removed or disabled. Tried making a new profile as well as deleting the folder in %appdata%. It works for a while and then randomly does it again.

Things that MAY assist in this problem. Youtube is the only website that does this when it comes to videos. Sites require a flash use sometimes wont play even though everything is clean installed. I have Nvidia Geforce experience running with shadowplay enabled to also record desktop connections. Since it uses the h.24 codec I thought it was clashing with it causing the problem. I can turn shadowplay off and reload the youtube page 2 to 3 times and the main video only will play.

Finally I gave up the other day , put everything back the way it was and put the computer to sleep. When I woke up I decided what the hey, Ill just load youtube up for laughs to see if it magically fixed. Well it did. Then tonight its back to square one again. I had noticed my yahoo home page with the news wouldnt change articles when moused over. So I decided to try the webtools / network tool to reload the page. It fixed yahoo flash run news articles but then my youtube problem came back! Ive had fire fox for as long as I can remember and never had problems with it! If Ive come here, it means ive given up being stubborn. I pride myself on fixing my own problems , but this one has me so I yield.

Below is an attatched image.

Regards, VAM the Anomaly

Chosen solution

You can check the log in the Web Console for error messages and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked.

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

Read this answer in context 👍 0

All Replies (14)

more options

If you use extensions (Firefox menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)

Clear the cache and remove cookies only from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

Thanks for the reply! I will have to examine it further if it did it again. Here's an update on what happened since the time I posted that. I noticed my computer had some windows updates to install that required a shutdown. I turned it off, waited a few seconds until it was completely off and turned it back on.

Updates installed and did their thing. Everything was working normally again. Im not holding my breath though because Ive gotten in the habit of not getting my hopes up. The updates were a security update for MS Security Essentials and a Windows update for 64 bit systems which shouldnt have had anything to do with it. Ill report back and try those steps if it does it again but for the now the shutdown and restart fixed it.

Thank you for the quick reply.

Modified by vamtheanomaly

more options

I see a special red play button next to the YouTube label.

Is this button added by an extension?

Such extensions always have the risk of malfunctioning.

more options

I tried everything listed on here and just to be safe i completely removed my three add ons / extensions. Still nothing. IE works fine.

more options

I disabled the h.264 plugin and the main video loaded but nothing else. Sometimes I can repeat this to get the main vid to play disabling nvidia shadowplay which ALSO uses that same codec which makes me think it has something to do with this codec / plugin and / or shadowplay in firefox.

more options

Also, I can easily "fix it" by deleting the %appdata% folder but that is a tiresome fix that deletes a lot of settings and bookmarks etc JUST because one / two sites wont work.

more options

Try updating your firefox browser and Adobe flash player. If your flash player is a older version it tends to malfunction at times.

more options

Roopak said

Try updating your firefox browser and Adobe flash player. If your flash player is a older version it tends to malfunction at times.

Did all of these as stated. Nothing. Gawd I really really REALLY dont want to use IE....

more options

They just came out with ANOTHER version of flash Roopak, So ill try that now.

more options

Im gonna reset firefox again by deleting the %appdata% folder and doing a fresh clean install with no bookmarks or addons. It does the same thing in safe mode so it isnt extensions or addons according to support. If it keeps doing it, I have no choice but to learn a new browser as that is annoying to have to keep resetting. Sad too, because I've used Firefox since early 2000s.

more options

Well Its official. I have an unsolvable problem it seems. Clean installed FF with no add ons, extensions and NO imported bookmarks or anything. Ran fine all night. Put the computer to sleep. Woke it up. Used it, no problems. Had to reset my computer and connection which I do every night before i begin a big gaming session. Loaded youtube and the problem is back.

more options

Continuing. Even went back a full version and turned updates off . Using ver 41. Same thing happens.

more options

cor-el said

If you use extensions (Firefox menu button/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content. You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • Hold down the Shift key and left-click the Reload button
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (Mac)
Clear the cache and remove cookies only from websites that cause problems. "Clear the Cache":
  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"
"Remove Cookies" from sites causing problems:
  • Firefox/Tools > Options > Privacy > "Use custom settings for history" > Cookies: "Show Cookies"
Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.
  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Are my questions no longer getting answered?

more options

Chosen Solution

You can check the log in the Web Console for error messages and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked.

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.